]> git.pld-linux.org Git - packages/flif.git/blob - flif.spec
57456965063cc75cc54040edd896ddc35178ef73
[packages/flif.git] / flif.spec
1 Summary:        Free Lossless Image Format library
2 Summary(pl.UTF-8):      Biblioteka do obsługi formatu FLIF (Free Lossless Image Format)
3 Name:           flif
4 Version:        0.2.2
5 Release:        1
6 License:        LGPL v3+ (libflif and programs), Apache v2.0 (libflif_dec)
7 Group:          Libraries
8 #Source0Download: https://github.com/FLIF-hub/FLIF/releases
9 Source0:        https://github.com/FLIF-hub/FLIF/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  a6be0a90cf3a90cdfcb1b4b0391237b9
11 Patch0:         %{name}-install.patch
12 URL:            http://flif.info/
13 BuildRequires:  SDL2-devel >= 2
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  libpng-devel
16 BuildRequires:  libstdc++-devel >= 6:4.7
17 BuildRequires:  pkgconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 FLIF is a lossless image format based on MANIAC compression. MANIAC
22 (Meta-Adaptive Near-zero Integer Arithmetic Coding) is a variant of
23 CABAC (context-adaptive binary arithmetic coding), where the contexts
24 are nodes of decision trees which are dynamically learned at encode
25 time.
26
27 FLIF outperforms PNG, FFV1, lossless WebP, lossless BPG and lossless
28 JPEG2000 in terms of compression ratio.
29
30 Moreover, FLIF supports a form of progressive interlacing (essentially
31 a generalization/improvement of PNG's Adam7).
32
33 %description -l pl.UTF-8
34 FLIF (Free Lossless Image Format - wolnodostępny, bezstratny format
35 obrazu) to bezstratny format obrazów oparty na kompresji MANIAC.
36 MANIAC (Meta-Adaptive Near-zero Integer Arithmetic Coding -
37 meta-adaptacyjne kodowanie arytmetyczne liczbami całkowitymi bliskimi
38 zeru) to wariant kompresji CABAC (kontekstowo-adaptacyjne binarne
39 kodowanie arytmetyczne), gdzie kontekstem są węzły drzew decyzyjnych,
40 dynamicznie wyuczanych w trakcie kodowania.
41
42 FLIF pod względem współczynnika kompresji jest wydajniejszy niż PNG,
43 FFV1, bezstratny WebP, bezstratny BPG i bezstratny JPEG2000.
44
45 Ponadto FLIF obsługuje rodzaj przeplotu progresywnego (zasadniczo
46 uogólnienie/rozwinięcie schematu Adam7 z PNG).
47
48 %package devel
49 Summary:        Header files for FLIF libraries
50 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek FLIF
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for FLIF libraries.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe bibliotek FLIF.
59
60 %package dec
61 Summary:        FLIF decoder library
62 Summary(pl.UTF-8):      Biblioteka dekodera FLIF
63 License:        Apache v2.0
64 Group:          Libraries
65
66 %description dec
67 FLIF decoder library.
68
69 %description dec -l pl.UTF-8
70 Biblioteka dekodera FLIF.
71
72 %package dec-devel
73 Summary:        Development files for FLIF decoder library
74 Summary(pl.UTF-8):      Pliki programistyczne biblioteki dekodera FLIF
75 License:        Apache v2.0
76 Group:          Development/Libraries
77 Requires:       %{name}-dec = %{version}-%{release}
78 # for headers
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description dec-devel
82 Development files for FLIF decoder library.
83
84 %description dec-devel -l pl.UTF-8
85 Pliki programistyczne biblioteki dekodera FLIF.
86
87 %package tools
88 Summary:        Tools to convert from/to FLIF image format
89 Summary(pl.UTF-8):      Narzędzia do konwersji do/z formatu obrazów FLIF
90 License:        LGPL v3+
91 Group:          Applications/Graphics
92 Suggests:       ImageMagick >= 1:6.8
93 Suggests:       apngdis >= 2.5
94
95 %description tools
96 Tools to convert from/to FLIF image format.
97
98 %description tools -l pl.UTF-8
99 Narzędzia do konwersji do/z formatu obrazów FLIF.
100
101 %package view
102 Summary:        SDL2 based FLIF viewer
103 Summary(pl.UTF-8):      Przeglądarka plików FLIF oparta na bibliotece SDL2
104 License:        LGPL v3+
105 Group:          Applications/Graphics
106 Requires:       %{name}-dec = %{version}-%{release}
107
108 %description view
109 SDL2 based FLIF viewer.
110
111 %description view -l pl.UTF-8
112 Przeglądarka plików FLIF oparta na bibliotece SDL2.
113
114 %prep
115 %setup -q -n FLIF-%{version}
116 %patch0 -p1
117
118 %build
119 install -d src/build
120 cd src/build
121 %cmake ..
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} -C src/build install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 install -Dp doc/flif.1 $RPM_BUILD_ROOT%{_mandir}/man1/flif.1
131 install tools/{apng2flif,gif2flif} $RPM_BUILD_ROOT%{_bindir}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %post   dec -p /sbin/ldconfig
140 %postun dec -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc LICENSE README.md
145 %attr(755,root,root) %{_libdir}/libflif.so.0
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc doc/metadata
150 %attr(755,root,root) %{_libdir}/libflif.so
151 %{_includedir}/flif*.h
152
153 %files dec
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libflif_dec.so.0
156
157 %files dec-devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libflif_dec.so
160
161 %files tools
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/apng2flif
164 %attr(755,root,root) %{_bindir}/flif
165 %attr(755,root,root) %{_bindir}/gif2flif
166 %{_mandir}/man1/flif.1*
167
168 %files view
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/viewflif
This page took 0.063947 seconds and 2 git commands to generate.