]> git.pld-linux.org Git - packages/fio.git/blob - fio.spec
175a4ab614dfd5196360018f268b646e63a41c98
[packages/fio.git] / fio.spec
1 # TODO:
2 # - HDFS (hadoop, --enable-libhdfs, requires also java)
3 # - fusion-aw (nvm-primitives): http://opennvm.github.io/
4 # - cuda
5 #
6 # Conditional build:
7 %bcond_without  ceph            # RBD (CephFS) support
8 %bcond_without  glusterfs       # GFAPI support
9 %bcond_without  gtk             # GTK+ based GUI (gfio)
10 %bcond_without  numa            # NUMA support
11 %bcond_without  pmem            # NVM support (using PMDK)
12 #
13 %ifnarch %{x8664} aarch64
14 %undefine       with_pmem
15 %endif
16 Summary:        I/O tool for benchmark and stress/hardware verification
17 Summary(pl.UTF-8):      Narzędzie do mierzenia wydajności I/O i sprawdzania sprawności sprzętu
18 Name:           fio
19 Version:        3.20
20 Release:        1
21 License:        GPL v2+
22 Group:          Applications/System
23 Source0:        http://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2
24 # Source0-md5:  5cf2eabf487c51001aceada90f961555
25 Patch0:         %{name}-guasi.patch
26 URL:            http://git.kernel.dk/?p=fio.git;a=summary
27 BuildRequires:  bison
28 %{?with_ceph:BuildRequires:     ceph-devel}
29 BuildRequires:  flex
30 %{?with_glusterfs:BuildRequires:        glusterfs-devel}
31 BuildRequires:  guasi-devel
32 BuildRequires:  libaio-devel
33 BuildRequires:  libibverbs-devel
34 BuildRequires:  librdmacm-devel
35 BuildRequires:  libzbc-devel
36 BuildRequires:  numactl-devel
37 %{?with_pmem:BuildRequires:     pmdk-devel}
38 BuildRequires:  sed >= 4.0
39 BuildRequires:  zlib-devel
40 %if %{with gtk}
41 BuildRequires:  cairo-devel
42 BuildRequires:  glib2-devel >= 2.0
43 BuildRequires:  gtk+2-devel >= 2:2.18.0
44 BuildRequires:  pkgconfig
45 %endif
46 # x86 features detection relies on cpuid
47 ExcludeArch:    i386 i486
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 fio is an I/O tool meant to be used both for benchmark and
52 stress/hardware verification. It has support for 9 different types of
53 I/O engines (sync, mmap, libaio, posixaio, SG v3, splice, null,
54 network, syslet), I/O priorities (for newer Linux kernels), rate I/O,
55 forked or threaded jobs, and much more. It can work on block devices
56 as well as files. fio accepts job descriptions in a
57 simple-to-understand text format. Several example job files are
58 included. fio displays all sorts of I/O performance information. It
59 supports Linux, FreeBSD, and OpenSolaris.
60
61 %description -l pl.UTF-8
62 fio to narzędzie do mierzenia wydajności I/O oraz sprawdzania
63 sprawności sprzętu pod dużym obciążeniem. Obsługuje 9 różnych rodzajów
64 silników I/O (sync, mmap, libaio, posixaio, SG v3, splice, null,
65 network, syslet), priorytety I/O (dla nowszych jąder Linuksa),
66 przepustowość I/O, zadania wieloprocesowe lub wielowątkowe i wiele
67 więcej. Może działać na urządzeniach blokowych oraz na plikach. fio
68 przyjmuje opisy zadań w formacie tekstowym prostym do zrozumienia. Ma
69 załączone kilka przykładowych plików zadań. Wyświetla wszystkie
70 rodzaje informacji o wydajności I/O. Obsługuje Linuksa, FreeBSD i
71 OpenSolarisa.
72
73 %package devel
74 Summary:        Header files for developing FIO engine modules
75 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia modułów silników FIO
76 Group:          Development/Libraries
77 # doesn't require base
78 Requires:       guasi-devel
79
80 %description devel
81 Header files for developing FIO engine modules.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe do tworzenia modułów silników FIO.
85
86 %package -n gfio
87 Summary:        GTK+ based graphical front-end for fio
88 Summary(pl.UTF-8):      Oparty na GTK+ graficzny interfejs do fio
89 Group:          X11/Applications
90 Requires:       %{name} = %{version}-%{release}
91
92 %description -n gfio
93 gfio is a GTK+ based graphical front-end for fio. It is often
94 installed on the testers workstation whereas fio would be installed on
95 the server.
96
97 %description -n gfio -l pl.UTF-8
98 gfio to oparty na GTK+ graficzny interfejs do fio. Zwykle jest
99 instalowany na komputerze testerów, podczas gdy fio jest zainstalowany
100 na serwerze.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105
106 %{__sed} -i -e '1s,/usr/bin/bash,/bin/bash,' tools/genfio
107 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' tools/{hist/fio-histo-log-pctiles.py,plot/fio2gnuplot}
108
109 %build
110 ./configure \
111         --cc="%{__cc}" \
112         --extra-cflags="%{rpmcflags} %{rpmcppflags}" \
113         %{!?with_glusterfs:--enable-gfapi} \
114         %{?with_gtk:--enable-gfio} \
115         %{!?with_numa:--disable-numa} \
116         %{!?with_pmem:--disable-pmem} \
117         %{!?with_ceph:--disable-rbd}
118
119 %{__make} \
120         LDFLAGS="%{rpmldflags}" \
121         V=1
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         prefix="%{_prefix}" \
128         mandir="%{_mandir}" \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 # development files for fio modules
132 install -d $RPM_BUILD_ROOT%{_includedir}/fio/{arch,crc,compiler,engines,lib,os/linux,oslib}
133 cp -p blktrace_api.h blktrace.h cairo_text_helpers.h cgroup.h client.h config-host.h debug.h diskutil.h err.h fifo.h file.h filehash.h filelock.h fio.h fio_sem.h fio_time.h flist.h flow.h gclient.h gcompat.h gerror.h gettime.h gfio.h ghelpers.h goptions.h graph.h hash.h helpers.h helper_thread.h idletime.h io_ddir.h ioengines.h iolog.h io_u.h io_u_queue.h json.h log.h minmax.h optgroup.h options.h parse.h printing.h profile.h pshared.h rate-submit.h rwlock.h server.h smalloc.h stat.h steadystate.h td_error.h thread_options.h tickmarks.h trim.h verify.h verify-state.h workqueue.h zbd.h zbd_types.h zone-dist.h $RPM_BUILD_ROOT%{_includedir}/fio
134 cp -p arch/arch.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
135 %ifarch %{ix86} %{x8664} x32
136 cp -p arch/arch-x86.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
137 %endif
138 %ifarch %{x8664} x32
139 cp -p arch/arch-x86_64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
140 %endif
141 %ifarch %{ix86} %{x8664} x32
142 cp -p arch/arch-x86-common.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
143 %endif
144 %ifarch ppc ppc64
145 cp -p arch/arch-ppc.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
146 %endif
147 %ifarch ia64
148 cp -p arch/arch-ia64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
149 %endif
150 %ifarch alpha
151 cp -p arch/arch-ia64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
152 %endif
153 %ifarch s390 s390x
154 cp -p arch/arch-s390.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
155 %endif
156 %ifarch sparc sparcv9 sparc64
157 cp -p arch/arch-sparc.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
158 %endif
159 %ifarch sparc64
160 cp -p arch/arch-sparc64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
161 %endif
162 %ifarch %{arm} aarch64
163 cp -p arch/arch-arm.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
164 %endif
165 %ifarch mips
166 cp -p arch/arch-mips.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
167 %endif
168 %ifarch sh
169 cp -p arch/arch-sh.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
170 %endif
171 %ifarch hppa
172 cp -p arch/arch-hppa.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
173 %endif
174 %ifarch aarch64
175 cp -p arch/arch-aarch64.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
176 %endif
177 %ifnarch %{ix86} %{x8664} x32 ppc ppc64 ia64 alpha s390 s390x sparc sparcv9 sparc64 %{arm} mips sh hppa aarch64
178 cp -p arch/arch-generic.h $RPM_BUILD_ROOT%{_includedir}/fio/arch
179 %endif
180 cp -p compiler/{compiler,compiler-gcc*}.h $RPM_BUILD_ROOT%{_includedir}/fio/compiler
181 cp -p crc/{crc{16,32,32c,64,7},fnv,md5,murmur3,sha{1,256,3,512},test,xxhash}.h $RPM_BUILD_ROOT%{_includedir}/fio/crc
182 cp -p lib/{axmap,bloom,bswap,ffz,fls,gauss,getrusage,hweight,ieee754,lfsr,memalign,memcpy,mountcheck,nowarn_snprintf,num2str,output_buffer,pattern,pow2,prio_tree,rand,rbtree,seqlock,strntol,types,zipf}.h $RPM_BUILD_ROOT%{_includedir}/fio/lib
183 cp -p os/{os,os-linux,os-linux-syscall}.h $RPM_BUILD_ROOT%{_includedir}/fio/os
184 cp -p os/linux/io_uring.h $RPM_BUILD_ROOT%{_includedir}/fio/os/linux
185 cp -p oslib/{asprintf,getopt,inet_aton,libmtd_common,libmtd,libmtd_int,libmtd_xalloc,linux-dev-lookup,strcasestr,strlcat,strndup,strsep}.h $RPM_BUILD_ROOT%{_includedir}/fio/oslib
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %files
191 %defattr(644,root,root,755)
192 %doc GFIO-TODO HOWTO MORAL-LICENSE README REPORTING-BUGS SERVER-TODO STEADYSTATE-TODO examples
193 %attr(755,root,root) %{_bindir}/fio
194 %attr(755,root,root) %{_bindir}/fio-btrace2fio
195 %attr(755,root,root) %{_bindir}/fio-dedupe
196 %attr(755,root,root) %{_bindir}/fio-genzipf
197 %attr(755,root,root) %{_bindir}/fio-histo-log-pctiles.py
198 %attr(755,root,root) %{_bindir}/fio-verify-state
199 %attr(755,root,root) %{_bindir}/fio2gnuplot
200 %attr(755,root,root) %{_bindir}/fio_generate_plots
201 %attr(755,root,root) %{_bindir}/fio_jsonplus_clat2csv
202 %attr(755,root,root) %{_bindir}/fiologparser.py
203 %attr(755,root,root) %{_bindir}/fiologparser_hist.py
204 %attr(755,root,root) %{_bindir}/genfio
205 %{_datadir}/fio
206 %{_mandir}/man1/fio.1*
207 %{_mandir}/man1/fio2gnuplot.1*
208 %{_mandir}/man1/fio_generate_plots.1*
209 %{_mandir}/man1/fiologparser_hist.py.1*
210
211 %files devel
212 %defattr(644,root,root,755)
213 %{_includedir}/fio
214
215 %if %{with gtk}
216 %files -n gfio
217 %defattr(644,root,root,755)
218 %doc GFIO-TODO
219 %attr(755,root,root) %{_bindir}/gfio
220 %endif
This page took 0.084216 seconds and 2 git commands to generate.