]> git.pld-linux.org Git - packages/ffms2.git/blob - ffms2.spec
- updated to 2.23
[packages/ffms2.git] / ffms2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  avresample      # avresample support via libavresample
5
6 Summary:        FFmpegSource - FFmpeg wrapper library
7 Summary(pl.UTF-8):      FFmpegSource - biblioteka obudowująca FFmpeg
8 Name:           ffms2
9 Version:        2.23
10 Release:        1
11 License:        MIT (ffmpegsource itself), GPL v3+ (forced by ffmpeg)
12 Group:          Libraries
13 #Source0Download: https://github.com/FFMS/ffms2/releases
14 Source0:        https://github.com/FFMS/ffms2/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  e7728ae581e278ade6bc9f204faaff9e
16 URL:            https://github.com/FFMS/ffms2
17 BuildRequires:  autoconf >= 2.58
18 BuildRequires:  automake >= 1:1.11
19 # PKG_CHECK_MODULES(LIBAV, [libavformat >= 53.20.0 libavcodec >= 53.24.0 libswscale >= 0.7.0 libavutil >= 51.21.0 ])
20 BuildRequires:  ffmpeg-devel >= 0.9
21 # libavresample >= 1.0.0 or libswresample >= 1.0.0
22 %{?with_avresample:BuildRequires:       ffmpeg-devel >= 1.1}
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:2.0
25 BuildRequires:  pkgconfig >= 1:0.22
26 BuildRequires:  rpmbuild(macros) >= 1.566
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  zlib-devel
29 Obsoletes:      ffmpegsource < 2.20
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 FFmpegSource (usually known as FFMS or FFMS2) is a cross-platform
34 wrapper library around FFmpeg, plus some additional components to deal
35 with file formats FFmpeg's libavformat has (or used to have) problems
36 with. It gives you an easy, convenient way to say "open and decompress
37 this media file for me, I don't care how you do it" and get frame- and
38 sample-accurate access (usually), without having to bother with the
39 sometimes less than straightforward and less than perfectly documented
40 FFmpeg API.
41
42 %description -l pl.UTF-8
43 FFmpegSource (zwykle zwana FFMS lub FFMS2) to wieloplatformowa
44 biblioteka obudowująca FFmpeg wraz z paroma dodatkowymi komponentami
45 mającymi radzić sobie z formatami plików, z którymi libavformat z
46 FFmpeg ma (lub miał) problemy. Umożliwia w łatwy sposób zażądanie
47 "otwórz i zdekompresuj ten plik, nieważne jak" i uzyskanie dostępu
48 (zwykle) z dokładnością do ramek i próbek, bez potrzeby zajmowania się
49 często złożonym, nie najlepiej udokumentowanym API FFmpeg.
50
51 %package devel
52 Summary:        Header files for FFmpegSource library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FFmpegSource
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 %if %{with avresample}
57 Requires:       ffmpeg-devel >= 1.1
58 %else
59 Requires:       ffmpeg-devel >= 0.9
60 %endif
61 Requires:       libstdc++-devel
62 Requires:       zlib-devel
63 Provides:       ffmpegsource-devel = %{version}-%{release}
64 Obsoletes:      ffmpegsource-devel < 2.20
65
66 %description devel
67 Header files for FFmpegSource library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki FFmpegSource.
71
72 %package static
73 Summary:        Static FFmpegSource library
74 Summary(pl.UTF-8):      Statyczna biblioteka FFmpegSource
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77 Obsoletes:      ffmpegsource-static < 2.20
78
79 %description static
80 Static FFmpegSource library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka FFmpegSource.
84
85 %prep
86 %setup -q
87
88 %build
89 CXXFLAGS="%{rpmcxxflags} -Wall -Wextra"
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --enable-avresample%{!?with_avresample:=no} \
97         --disable-silent-rules \
98         --enable-shared \
99         %{__enable_disable static_libs static}
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 # obsoleted by pkg-config
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libffms2.la
111
112 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc COPYING README.md
123 %attr(755,root,root) %{_bindir}/ffmsindex
124 %attr(755,root,root) %{_libdir}/libffms2.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libffms2.so.4
126
127 %files devel
128 %defattr(644,root,root,755)
129 %doc doc/ffms2-*.md
130 %attr(755,root,root) %{_libdir}/libffms2.so
131 %{_includedir}/ffms.h
132 %{_includedir}/ffmscompat.h
133 %{_pkgconfigdir}/ffms2.pc
134
135 %if %{with static_libs}
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libffms2.a
139 %endif
This page took 0.093453 seconds and 3 git commands to generate.