]> git.pld-linux.org Git - packages/ffmpeg.git/blob - ffmpeg.spec
another symbol missing when library is not fresh enough, this time
[packages/ffmpeg.git] / ffmpeg.spec
1 # TODO: libzmq ?
2 #
3 # How to deal with ffmpeg/opencv checken-egg problem:
4 #       1. make-request -r --without opencv ffmpeg.spec
5 #       2. make-request -r opencv.spec
6 #       3. bump release of ffmpeg.spec
7 #       4. make-request -r ffmpeg.spec
8 #
9 # Conditional build:
10 %bcond_with     nonfree         # non free options of package (currently: faac)
11 %bcond_with     aacplus         # AAC+ encoding via libaacplus (requires nonfree)
12 %bcond_with     fdk_aac         # AAC de/encoding via libfdk_aac (requires nonfree)
13 %bcond_without  caca            # textual display using libcaca
14 %bcond_without  flite           # flite voice synthesis support
15 %bcond_without  frei0r          # frei0r video filtering
16 %bcond_without  gme             # Game Music Emu support
17 %bcond_without  ilbc            # iLBC de/encoding via WebRTC libilbc
18 %bcond_without  ladspa          # LADSPA audio filtering
19 %bcond_without  ssh             # SFTP protocol support via libssh
20 %bcond_without  openal          # OpenAL 1.1 capture support
21 %bcond_with     opencl          # OpenCL code [OpenCL 1.2, but Mesa 9.1.x headers don't suffice]
22 %bcond_without  opencv          # OpenCV video filtering
23 %bcond_without  pulseaudio      # PulseAudio input support
24 %bcond_without  quvi            # quvi input support
25 %bcond_without  shine           # shine fixed-point MP3 encoder
26 %bcond_without  soxr            # SoX Resampler support
27 %bcond_without  x264            # x264 encoder
28 %bcond_without  utvideo         # Ut Video decoder
29 %bcond_without  va              # VAAPI (Video Acceleration API)
30 %bcond_without  vidstab         # vid.stab video stabilization support
31 %bcond_without  vpx             # VP8, a high-quality video codec
32 %bcond_without  wavpack         # wavpack encoding support
33 %bcond_without  zmq             # 0MQ message passing
34 %bcond_without  zvbi            # teletext via libzvbi
35 %bcond_without  doc             # don't build docs
36
37 Summary:        FFmpeg - a very fast video and audio converter
38 Summary(pl.UTF-8):      FFmpeg - szybki konwerter audio/wideo
39 Name:           ffmpeg
40 Version:        2.1.1
41 Release:        4
42 # LGPL or GPL, chosen at configure time (GPL version is more featured)
43 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
44 # using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
45 License:        GPL v3+ with LGPL v3+ parts
46 Group:          Applications/Multimedia
47 Source0:        http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
48 # Source0-md5:  2719ab2b3311ac3775b9cdeb66c54849
49 Source1:        ffserver.init
50 Source2:        ffserver.sysconfig
51 Source3:        ffserver.conf
52 Patch0:         %{name}-opencv24.patch
53 Patch1:         freetype2.patch
54 URL:            http://www.ffmpeg.org/
55 %{?with_openal:BuildRequires:   OpenAL-devel >= 1.1}
56 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.2}
57 BuildRequires:  SDL-devel >= 1.2.1
58 BuildRequires:  alsa-lib-devel
59 BuildRequires:  bzip2-devel
60 BuildRequires:  celt-devel >= 0.11.0
61 %{?with_nonfree:BuildRequires:  faac-devel}
62 %{?with_fdk_aac:BuildRequires:  fdk-aac-devel}
63 %{?with_flite:BuildRequires:    flite-devel >= 1.4}
64 BuildRequires:  fontconfig-devel
65 BuildRequires:  freetype-devel
66 %{?with_frei0r:BuildRequires:   frei0r-devel}
67 %{?with_gme:BuildRequires:      game-music-emu-devel}
68 %ifarch ppc
69 # require version with altivec support fixed
70 BuildRequires:  gcc >= 5:3.3.2-3
71 %endif
72 BuildRequires:  gnutls-devel
73 BuildRequires:  jack-audio-connection-kit-devel
74 %{?with_ladspa:BuildRequires:   ladspa-devel}
75 BuildRequires:  lame-libs-devel >= 3.98.3
76 %{?with_aacplus:BuildRequires:  libaacplus-devel >= 2.0.0}
77 BuildRequires:  libass-devel
78 BuildRequires:  libavc1394-devel
79 BuildRequires:  libbluray-devel
80 %{?with_caca:BuildRequires:     libcaca-devel}
81 BuildRequires:  libcdio-paranoia-devel >= 0.90-2
82 BuildRequires:  libdc1394-devel >= 2
83 BuildRequires:  libgsm-devel
84 BuildRequires:  libiec61883-devel
85 BuildRequires:  libmodplug-devel
86 BuildRequires:  libnut-devel
87 %{?with_quvi:BuildRequires:     libquvi-devel}
88 BuildRequires:  libraw1394-devel >= 2
89 BuildRequires:  librtmp-devel
90 %{?with_ssh:BuildRequires:      libssh-devel}
91 BuildRequires:  libtheora-devel >= 1.0-0.beta3
92 BuildRequires:  libtool >= 2:1.4d-3
93 BuildRequires:  libv4l-devel
94 %{?with_va:BuildRequires:       libva-devel >= 1.0.3}
95 BuildRequires:  libvdpau-devel >= 0.2
96 BuildRequires:  libvorbis-devel
97 %{?with_vpx:BuildRequires:      libvpx-devel >= 0.9.7}
98 # X264_BUILD >= 118
99 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3-1.20111212_2245}
100 %ifarch %{ix86}
101 %ifnarch i386 i486
102 BuildRequires:  nasm
103 %endif
104 %endif
105 BuildRequires:  opencore-amr-devel
106 %{?with_opencv:BuildRequires:   opencv-devel}
107 BuildRequires:  openjpeg-devel >= 1.5
108 BuildRequires:  opus-devel
109 BuildRequires:  perl-Encode
110 BuildRequires:  perl-tools-pod
111 BuildRequires:  pkgconfig
112 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
113 BuildRequires:  rpmbuild(macros) >= 1.470
114 BuildRequires:  schroedinger-devel
115 %{?with_shine:BuildRequires:    shine-devel >= 3.0.0}
116 %{?with_soxr:BuildRequires:     soxr-devel}
117 BuildRequires:  speex-devel >= 1:1.2-rc1
118 %{?with_doc:BuildRequires:      tetex}
119 %{?with_doc:BuildRequires:      texi2html}
120 %{?with_doc:BuildRequires:      texinfo}
121 BuildRequires:  twolame-devel
122 %{?with_utvideo:BuildRequires:  utvideo-devel >= 12}
123 %{?with_vidstab:BuildRequires:  vid.stab-devel}
124 BuildRequires:  vo-aacenc-devel
125 BuildRequires:  vo-amrwbenc-devel
126 %{?with_wavpack:BuildRequires:  wavpack-devel}
127 %{?with_ilbc:BuildRequires:     webrtc-libilbc-devel}
128 BuildRequires:  xavs-devel
129 BuildRequires:  xorg-lib-libX11-devel
130 BuildRequires:  xorg-lib-libXext-devel
131 BuildRequires:  xorg-lib-libXfixes-devel
132 BuildRequires:  xvid-devel >= 1:1.1.0
133 BuildRequires:  yasm
134 %{?with_zmq:BuildRequires:      zeromq-devel}
135 %{?with_zvbi:BuildRequires:     zvbi-devel}
136 BuildRequires:  zlib-devel
137 %{?with_autoreqdep:BuildConflicts:      libpostproc}
138 # overflows maximum hash table size
139 BuildConflicts: pdksh < 5.2.14-57
140 Requires:       %{name}-libs = %{version}-%{release}
141 %{?with_utvideo:Requires:       utvideo >= 12}
142 %{?with_ilbc:Requires:  webrtc-libilbc}
143 Requires:       xvid >= 1:1.1.0
144 Obsoletes:      libpostproc
145 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
148
149 %define         specflags       -fno-strict-aliasing
150
151 # -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
152 %define         specflags_ia32  -fomit-frame-pointer
153 # -mmmx is needed to enable <mmintrin.h> code.
154 %define         specflags_i586  -mmmx
155 %define         specflags_i686  -mmmx
156 %define         specflags_ppc   -fPIC
157
158 %description
159 FFmpeg is a complete solution to record, convert and stream audio and
160 video. It is a command line tool to convert one video file format to
161 another. It also supports grabbing and encoding in real time from a TV
162 card.
163
164 %description -l pl.UTF-8
165 FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
166 strumieni dźwięku i obrazu. Jest to działające z linii poleceń
167 narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
168 także przechwytywanie i kodowanie w czasie rzeczywistym z karty
169 telewizyjnej.
170
171 %package libs
172 Summary:        ffmpeg libraries
173 Summary(pl.UTF-8):      Biblioteki ffmpeg
174 Requires:       gnutls-libs >= 3.0.20
175 Group:          Libraries
176
177 %description libs
178 This package contains the ffmpeg shared libraries:
179 - the codec library (libavcodec). It supports most existing encoding
180   formats (MPEG, DivX, MPEG4, AC3, DV...),
181 - demuxer library (libavformat). It supports most existing file
182   formats (AVI, MPEG, OGG, Matroska, ASF...),
183 - video postprocessing library (libpostproc).
184
185 %description libs -l pl.UTF-8
186 Ten pakiet zawiera biblioteki współdzielone ffmpeg:
187 - bibliotekę kodeków (libavcodec); obsługuje większość istniejących
188   formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
189 - bibliotekę demuksera (libavformat); obsługuje większość istniejących
190   formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
191 - bibliotekę postprocessingu (libpostproc).
192
193 %package devel
194 Summary:        ffmpeg header files
195 Summary(pl.UTF-8):      Pliki nagłówkowe ffmpeg
196 Group:          Development/Libraries
197 Requires:       %{name}-libs = %{version}-%{release}
198 # Libs.private from *.pc (unreasonably they are all the same)
199 %{?with_opencl:Requires:        OpenCL-devel >= 1.2}
200 Requires:       SDL-devel >= 1.2.1
201 Requires:       alsa-lib-devel
202 Requires:       bzip2-devel
203 Requires:       celt-devel >= 0.11.0
204 %{?with_nonfree:Requires:       faac-devel}
205 %{?with_fdk_aac:Requires:       fdk-aac-devel}
206 %{?with_flite:Requires: flite-devel >= 1.4}
207 Requires:       fontconfig-devel
208 Requires:       freetype-devel
209 %{?with_gme:Requires:   game-music-emu-devel}
210 Requires:       jack-audio-connection-kit-devel
211 Requires:       lame-libs-devel >= 3.98.3
212 %{?with_aacplus:Requires:       libaacplus-devel >= 2.0.0}
213 Requires:       libass-devel
214 Requires:       libavc1394-devel
215 Requires:       libbluray-devel
216 %{?with_caca:Requires:  libcaca-devel}
217 Requires:       libcdio-paranoia-devel >= 0.90-2
218 Requires:       libdc1394-devel >= 2
219 Requires:       libgsm-devel
220 Requires:       libiec61883-devel
221 Requires:       libmodplug-devel
222 Requires:       libnut-devel
223 %{?with_quvi:Requires:  libquvi-devel}
224 Requires:       libraw1394-devel >= 2
225 Requires:       librtmp-devel
226 Requires:       libtheora-devel >= 1.0-0.beta3
227 %{?with_va:Requires:    libva-devel >= 1.0.3}
228 Requires:       libvorbis-devel
229 %{?with_vpx:Requires:   libvpx-devel >= 0.9.7}
230 %{?with_x264:Requires:  libx264-devel >= 0.1.3-1.20110625_2245}
231 Requires:       opencore-amr-devel
232 %{?with_opencv:Requires:        opencv-devel}
233 Requires:       openjpeg-devel >= 1.5
234 Requires:       schroedinger-devel
235 %{?with_shine:Requires: shine-devel >= 3.0.0}
236 %{?with_soxr:Requires:  soxr-devel}
237 Requires:       speex-devel >= 1:1.2-rc1
238 Requires:       twolame-devel
239 %{?with_utvideo:Requires:       utvideo-devel >= 12}
240 %{?with_vidstab:Requires:       vid.stab-devel}
241 Requires:       vo-aacenc-devel
242 Requires:       vo-amrwbenc-devel
243 %{?with_wavpack:Requires:       wavpack-devel}
244 %{?with_ilbc:Requires:  webrtc-libilbc-devel}
245 Requires:       xavs-devel
246 Requires:       xorg-lib-libXext-devel
247 Requires:       xorg-lib-libXfixes-devel
248 Requires:       xvid-devel >= 1:1.1.0
249 %{?with_zmq:Requires:   zeromq-devel}
250 Requires:       zlib-devel
251 Obsoletes:      libpostproc-devel
252
253 %description devel
254 ffmpeg header files.
255
256 %description devel -l pl.UTF-8
257 Pliki nagłówkowe ffmpeg.
258
259 %package static
260 Summary:        ffmpeg static libraries
261 Summary(pl.UTF-8):      Statyczne biblioteki ffmpeg
262 Group:          Development/Libraries
263 Requires:       %{name}-devel = %{version}-%{release}
264
265 %description static
266 ffmpeg static libraries (libavcodec and libavformat).
267
268 %description static -l pl.UTF-8
269 Statyczne biblioteki ffmpeg (libavcodec i libavformat).
270
271 %package ffplay
272 Summary:        FFplay - SDL-based media player
273 Summary(pl.UTF-8):      FFplay - odtwarzacz mediów oparty na SDL
274 Group:          Applications/Multimedia
275 Requires:       %{name}-libs = %{version}-%{release}
276
277 %description ffplay
278 FFplay is a very simple and portable media player using the FFmpeg
279 libraries and the SDL library. It is mostly used as a test bench for
280 the various APIs of FFmpeg.
281
282 %description ffplay -l pl.UTF-8
283 FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
284 bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
285 testowania różnych API FFmpeg.
286
287 %package ffserver
288 Summary:        FFserver video server
289 Summary(pl.UTF-8):      FFserver - serwer strumieni obrazu
290 Group:          Daemons
291 Requires(post,preun):   /sbin/chkconfig
292 Requires:       %{name}-libs = %{version}-%{release}
293 Requires:       rc-scripts >= 0.4.0.10
294
295 %description ffserver
296 FFserver is a streaming server for both audio and video. It supports
297 several live feeds, streaming from files and time shifting on live
298 feeds (you can seek to positions in the past on each live feed,
299 provided you specify a big enough feed storage in ffserver.conf).
300
301 %description ffserver -l pl.UTF-8
302 FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
303 źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
304 czasie dla źródeł na żywo (można przeskakiwać na położenia w
305 przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
306 dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
307
308 %package doc
309 Summary:        Manual for ffmpeg
310 Summary(fr.UTF-8):      Documentation pour ffmpeg
311 Summary(it.UTF-8):      Documentazione di ffmpeg
312 Summary(pl.UTF-8):      Podręcznik dla ffmpeg
313 Group:          Documentation
314 %if "%{_rpmversion}" >= "5"
315 BuildArch:      noarch
316 %endif
317
318 %description doc
319 Documentation for ffmpeg.
320
321 %description doc -l fr.UTF-8
322 Documentation pour ffmpeg.
323
324 %description doc -l it.UTF-8
325 Documentazione di ffmpeg.
326
327 %description doc -l pl.UTF-8
328 Dokumentacja do ffmpeg.
329
330 %prep
331 %setup -q
332 %patch0 -p1
333 %patch1 -p1
334
335 # package the grep result for mplayer, the result formatted as ./mplayer/configure
336 cat <<EOF > ffmpeg-avconfig
337 #! /bin/sh
338 libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
339 libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
340 libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
341 libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
342 libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
343 libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
344 libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
345 libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
346 libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
347 EOF
348 cat <<'EOF' >> ffmpeg-avconfig
349
350 case "$1" in
351 --decoders)
352         echo $libavdecoders_all
353         ;;
354 --encoders)
355         echo $libavencoders_all
356         ;;
357 --parsers)
358         echo $libavparsers_all
359         ;;
360 --bsfs)
361         echo $libavbsfs_all
362         ;;
363 --demuxers)
364         echo $libavdemuxers_all
365         ;;
366 --muxers)
367         echo $libavmuxers_all
368         ;;
369 --protocols)
370         echo $libavprotocols_all
371         ;;
372 --hwaccels)
373         echo $libavhwaccels_all
374         ;;
375 --filters)
376         echo $libavfilters_all
377         ;;
378 *)
379         cat <<USAGE
380 Usage: $0 [OPTION]
381 Options:
382   --decoders
383   --encoders
384   --parsers
385   --bsfs
386   --demuxers
387   --muxers
388   --protocols
389   --hwaccels
390   --filters
391 USAGE
392         exit 1;;
393 esac
394
395 exit 0
396 EOF
397
398 %build
399 # notes:
400 # - it's not autoconf configure
401 # - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
402 ./configure \
403         --arch=%{_target_base_arch} \
404         --prefix=%{_prefix} \
405         --libdir=%{_libdir} \
406         --shlibdir=%{_libdir} \
407         --mandir=%{_mandir} \
408         --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
409         --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
410         --cc="%{__cc}" \
411         --disable-debug \
412         --disable-optimizations \
413         --disable-stripping \
414         --enable-avfilter \
415         --enable-avresample \
416         --enable-gnutls \
417         --enable-gpl \
418         --enable-version3 \
419         --enable-fontconfig \
420         %{?with_frei0r:--enable-frei0r} \
421         %{?with_ladspa:--enable-ladspa} \
422         %{?with_aacplus:--enable-libaacplus} \
423         --enable-libass \
424         --enable-libbluray \
425         %{?with_caca:--enable-libcaca} \
426         --enable-libcelt \
427         --enable-libcdio \
428         --enable-libdc1394 \
429         %{?with_fdk_aac:--enable-libfdk-aac} \
430         %{?with_flite:--enable-libflite} \
431         --enable-libfreetype \
432         %{?with_gme:--enable-libgme} \
433         --enable-libgsm \
434         --enable-libiec61883 \
435         %{?with_ilbc:--enable-libilbc} \
436         --enable-libmodplug \
437         --enable-libmp3lame \
438         --enable-libnut \
439         --enable-libopencore-amrnb \
440         --enable-libopencore-amrwb \
441         %{?with_opencv:--enable-libopencv} \
442         --enable-libopenjpeg \
443         --enable-libopus \
444         %{?with_pulseaudio:--enable-libpulse} \
445         %{?with_quvi:--enable-libquvi} \
446         --enable-librtmp \
447         --enable-libschroedinger \
448         %{?with_shine:--enable-libshine} \
449         %{?with_soxr:--enable-libsoxr} \
450         --enable-libspeex \
451         %{?with_ssh:--enable-libssh} \
452         --enable-libtheora \
453         --enable-libtwolame \
454         %{?with_utvideo:--enable-libutvideo} \
455         --enable-libv4l2 \
456         %{?with_vidstab:--enable-libvidstab} \
457         --enable-libvo-aacenc \
458         --enable-libvo-amrwbenc \
459         --enable-libvorbis \
460         %{?with_vpx:--enable-libvpx} \
461         %{?with_wavpack:--enable-libwavpack} \
462         %{?with_x264:--enable-libx264} \
463         --enable-libxavs \
464         --enable-libxvid \
465         %{?with_zmq:--enable-libzmq} \
466         %{?with_zvbi:--enable-libzvbi} \
467         %{?with_openal:--enable-openal} \
468         %{?with_opencl:--enable-opencl} \
469         --enable-postproc \
470         --enable-pthreads \
471         --enable-shared \
472         --enable-swscale \
473         %{!?with_va:--disable-vaapi} \
474         --enable-x11grab \
475 %ifnarch %{ix86} %{x8664}
476         --disable-mmx \
477 %endif
478 %ifarch i386 i486
479         --disable-mmx \
480 %endif
481 %if %{with nonfree}
482         --enable-nonfree \
483         --enable-libfaac \
484 %endif
485         --enable-runtime-cpudetect
486
487 %{__make} \
488         V=1
489
490 # CC_O to add -c to commandline. makefile should be patched
491 %{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
492
493 %install
494 rm -rf $RPM_BUILD_ROOT
495 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
496         $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
497         $RPM_BUILD_ROOT/var/{cache,log}/ffserver
498
499 %{__make} install install-headers \
500         DESTDIR=$RPM_BUILD_ROOT \
501         V=1
502
503 # install nonstandard, non-public headers manually
504 cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
505 for a in libavutil/*/bswap.h; do
506         install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
507 done
508 cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
509 # for lim-omx ffmpeg components
510 cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
511
512 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
513 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
514 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
515 mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
516 install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
517
518 # install as ffmpeg-avconfig to avoid with possible programs looking for
519 # ffmpeg-config and expecting --libs output from it which is not implemented
520 # simple to do (by querying pkgconfig), but why?
521 install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
522
523 %clean
524 rm -rf $RPM_BUILD_ROOT
525
526 %post   libs -p /sbin/ldconfig
527 %postun libs -p /sbin/ldconfig
528
529 %pre ffserver
530 %groupadd -g 167 ffserver
531 %useradd -g ffserver -u 167 ffserver
532
533 %post ffserver
534 /sbin/chkconfig --add ffserver
535 %service ffserver restart
536
537 %preun ffserver
538 if [ "$1" = 0 ]; then
539         %service ffserver stop
540         /sbin/chkconfig --del ffserver
541 fi
542
543 %postun ffserver
544 if [ "$1" = 0 ]; then
545         %userremove ffserver
546         %groupremove ffserver
547 fi
548
549 %files
550 %defattr(644,root,root,755)
551 %doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
552 %attr(755,root,root) %{_bindir}/ffmpeg
553 %attr(755,root,root) %{_bindir}/ffprobe
554 %attr(755,root,root) %{_bindir}/qt-faststart
555 %dir %{_datadir}/ffmpeg
556 %{_datadir}/ffmpeg/*.ffpreset
557 %{_datadir}/ffmpeg/ffprobe.xsd
558 %if %{with doc}
559 %{_mandir}/man1/ffmpeg.1*
560 %{_mandir}/man1/ffmpeg-all.1*
561 %{_mandir}/man1/ffmpeg-bitstream-filters.1*
562 %{_mandir}/man1/ffmpeg-codecs.1*
563 %{_mandir}/man1/ffmpeg-devices.1*
564 %{_mandir}/man1/ffmpeg-filters.1*
565 %{_mandir}/man1/ffmpeg-formats.1*
566 %{_mandir}/man1/ffmpeg-protocols.1*
567 %{_mandir}/man1/ffmpeg-resampler.1*
568 %{_mandir}/man1/ffmpeg-scaler.1*
569 %{_mandir}/man1/ffmpeg-utils.1*
570 %{_mandir}/man1/ffprobe.1*
571 %{_mandir}/man1/ffprobe-all.1*
572 %endif
573
574 %files libs
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
578 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
580 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
582 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
584 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
586 %attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
587 %attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
588 %attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
590 %attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
591 %attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
592 %attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
593 %attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
594
595 %files devel
596 %defattr(644,root,root,755)
597 %doc doc/optimization.txt
598 %attr(755,root,root) %{_bindir}/ffmpeg-avconfig
599 %attr(755,root,root) %{_libdir}/libavcodec.so
600 %attr(755,root,root) %{_libdir}/libavdevice.so
601 %attr(755,root,root) %{_libdir}/libavfilter.so
602 %attr(755,root,root) %{_libdir}/libavformat.so
603 %attr(755,root,root) %{_libdir}/libavresample.so
604 %attr(755,root,root) %{_libdir}/libavutil.so
605 %attr(755,root,root) %{_libdir}/libpostproc.so
606 %attr(755,root,root) %{_libdir}/libswresample.so
607 %attr(755,root,root) %{_libdir}/libswscale.so
608 %{_includedir}/ffmpeg
609 %{_includedir}/libavcodec
610 %{_includedir}/libavdevice
611 %{_includedir}/libavfilter
612 %{_includedir}/libavformat
613 %{_includedir}/libavresample
614 %{_includedir}/libavutil
615 %{_includedir}/libpostproc
616 %{_includedir}/libswresample
617 %{_includedir}/libswscale
618 %{_pkgconfigdir}/libavcodec.pc
619 %{_pkgconfigdir}/libavdevice.pc
620 %{_pkgconfigdir}/libavfilter.pc
621 %{_pkgconfigdir}/libavformat.pc
622 %{_pkgconfigdir}/libavresample.pc
623 %{_pkgconfigdir}/libavutil.pc
624 %{_pkgconfigdir}/libpostproc.pc
625 %{_pkgconfigdir}/libswresample.pc
626 %{_pkgconfigdir}/libswscale.pc
627 %if %{with doc}
628 %{_mandir}/man3/libavcodec.3*
629 %{_mandir}/man3/libavdevice.3*
630 %{_mandir}/man3/libavfilter.3*
631 %{_mandir}/man3/libavformat.3*
632 %{_mandir}/man3/libavutil.3*
633 %{_mandir}/man3/libswresample.3*
634 %{_mandir}/man3/libswscale.3*
635 %endif
636
637 %files static
638 %defattr(644,root,root,755)
639 %{_libdir}/libavcodec.a
640 %{_libdir}/libavdevice.a
641 %{_libdir}/libavfilter.a
642 %{_libdir}/libavformat.a
643 %{_libdir}/libavresample.a
644 %{_libdir}/libavutil.a
645 %{_libdir}/libpostproc.a
646 %{_libdir}/libswresample.a
647 %{_libdir}/libswscale.a
648
649 %files ffplay
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_bindir}/ffplay
652 %if %{with doc}
653 %{_mandir}/man1/ffplay.1*
654 %{_mandir}/man1/ffplay-all.1*
655 %endif
656
657 %files ffserver
658 %defattr(644,root,root,755)
659 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
660 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
661 %attr(755,root,root) %{_sbindir}/ffserver
662 %attr(754,root,root) /etc/rc.d/init.d/ffserver
663 %if %{with doc}
664 %{_mandir}/man1/ffserver.1*
665 %{_mandir}/man1/ffserver-all.1*
666 %endif
667 %dir %attr(770,root,ffserver) /var/cache/ffserver
668 %dir %attr(770,root,ffserver) /var/log/ffserver
669
670 %if %{with doc}
671 %files doc
672 %defattr(644,root,root,755)
673 %doc doc/*.html
674 %endif
This page took 0.090052 seconds and 4 git commands to generate.