]> git.pld-linux.org Git - packages/ffcall.git/blob - ffcall.spec
- rel. 2, fix build, cleaning
[packages/ffcall.git] / ffcall.spec
1 Summary:        Libraries for building foreign function call interfaces
2 Summary(pl.UTF-8):      Biblioteki do tworzenia interfejsów wywołań obcych funkcji
3 Name:           ffcall
4 Version:        1.10
5 Release:        2
6 Epoch:          1
7 License:        GPL
8 Group:          Libraries
9 Source0:        ftp://ftp.santafe.edu/pub/gnu/%{name}-%{version}.tar.gz
10 # Source0-md5:  2db95007e901f3bc2ae7e5a9fe9ebea4
11 Patch0:         %{name}-make-jN.patch
12 URL:            http://www.haible.de/bruno/packages-ffcall.html
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 This is a collection of four libraries which can be used to build
17 foreign function call interfaces in embedded interpreters.
18
19 The four packages are:
20 - avcall - calling C functions with variable arguments
21 - vacall - C functions accepting variable argument prototypes
22 - trampoline - closures as first-class C functions
23 - callback - closures with variable arguments as first-class C
24   functions (a reentrant combination of vacall and trampoline)
25
26 This version B includes some minor configuration changes so that files
27 are installed in the proper place. Also it compiles on cygwin and
28 mingw32.
29
30 %description -l pl.UTF-8
31 To jest zestaw czterech bibliotek, których można użyć do tworzenia
32 interfejsów wywołań obcych procedur we wbudowanych interpreterach.
33
34 Te cztery pakiety to:
35 - avcall - wywoływanie funkcji w C ze zmiennymi argumentami
36 - vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
37 - trampoline - domknięcia jako funkcje C pierwszej klasy
38 - callback - domknięcia ze zmiennymi argumentami jako funkcje C
39   pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
40
41 Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
42 pliki instalują się we właściwych miejscach. A także kompiluje się pod
43 cygwinem i mingw32.
44
45 %package devel
46 Summary:        Development files for ffcall libraries
47 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek ffcall
48 Group:          Development/Libraries
49 Requires:       %{name} = %{epoch}:%{version}-%{release}
50
51 %description devel
52 Development files for ffcall libraries: headers and static trampoline
53 and vacall libraries.
54
55 %description devel -l pl.UTF-8
56 Pliki dla programistów używających bibliotek ffcall: nagłówki i
57 statyczne biblioteki trampoline oraz vacall.
58
59 %package static
60 Summary:        Static versions of avcall and callback libraries
61 Summary(pl.UTF-8):      Statyczne wersje bibliotek avcall i callback
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
64
65 %description static
66 Static versions of avcall and callback libraries.
67
68 %description static -l pl.UTF-8
69 Statyczne wersje bibliotek avcall i callback.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 %configure \
77         --enable-shared
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_mandir}
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 # don't need those since we have man pages
89 %{__rm} $RPM_BUILD_ROOT/usr/share/html/*.html
90
91 %clean
92 rm -fr $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc NEWS README
100 %attr(755,root,root) %{_libdir}/lib*.so.*.*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %doc */*.html
105 %attr(755,root,root) %{_libdir}/lib*.so*
106 %{_libdir}/lib*.la
107 %{_libdir}/libtrampoline.a
108 %{_libdir}/libvacall.a
109 %{_includedir}/*
110 %{_mandir}/man?/*
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libavcall.a
115 %{_libdir}/libcallback.a
This page took 0.325032 seconds and 4 git commands to generate.