]> git.pld-linux.org Git - packages/ffcall.git/blob - ffcall.spec
- new url
[packages/ffcall.git] / ffcall.spec
1 %define         snap    20090629
2
3 Summary:        Libraries for building foreign function call interfaces
4 Summary(pl.UTF-8):      Biblioteki do tworzenia interfejsów wywołań obcych funkcji
5 Name:           ffcall
6 Version:        1.11
7 Release:        0.%{snap}.1
8 Epoch:          1
9 License:        GPL
10 Group:          Libraries
11 # cvs -d:pserver:anonymous@cvs.sv.gnu.org:/sources/libffcall co .
12 Source0:        %{name}-%{snap}.tar.bz2
13 # Source0-md5:  a5190885da8e701a012bb282bfb3c51b
14 Patch0:         %{name}-make-jN.patch
15 URL:            http://savannah.gnu.org/projects/libffcall
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This is a collection of four libraries which can be used to build
20 foreign function call interfaces in embedded interpreters.
21
22 The four packages are:
23 - avcall - calling C functions with variable arguments
24 - vacall - C functions accepting variable argument prototypes
25 - trampoline - closures as first-class C functions
26 - callback - closures with variable arguments as first-class C
27   functions (a reentrant combination of vacall and trampoline)
28
29 This version B includes some minor configuration changes so that files
30 are installed in the proper place. Also it compiles on cygwin and
31 mingw32.
32
33 %description -l pl.UTF-8
34 To jest zestaw czterech bibliotek, których można użyć do tworzenia
35 interfejsów wywołań obcych procedur we wbudowanych interpreterach.
36
37 Te cztery pakiety to:
38 - avcall - wywoływanie funkcji w C ze zmiennymi argumentami
39 - vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
40 - trampoline - domknięcia jako funkcje C pierwszej klasy
41 - callback - domknięcia ze zmiennymi argumentami jako funkcje C
42   pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
43
44 Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
45 pliki instalują się we właściwych miejscach. A także kompiluje się pod
46 cygwinem i mingw32.
47
48 %package devel
49 Summary:        Development files for ffcall libraries
50 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek ffcall
51 Group:          Development/Libraries
52 Requires:       %{name} = %{epoch}:%{version}-%{release}
53
54 %description devel
55 Development files for ffcall libraries: headers and static trampoline
56 and vacall libraries.
57
58 %description devel -l pl.UTF-8
59 Pliki dla programistów używających bibliotek ffcall: nagłówki i
60 statyczne biblioteki trampoline oraz vacall.
61
62 %package static
63 Summary:        Static versions of avcall and callback libraries
64 Summary(pl.UTF-8):      Statyczne wersje bibliotek avcall i callback
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
67
68 %description static
69 Static versions of avcall and callback libraries.
70
71 %description static -l pl.UTF-8
72 Statyczne wersje bibliotek avcall i callback.
73
74 %prep
75 %setup -q -n %{name}-%{snap}
76 %patch0 -p1
77
78 %build
79 %configure \
80         --enable-shared
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_mandir}
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # don't need those since we have man pages
92 %{__rm} $RPM_BUILD_ROOT/usr/share/html/*.html
93
94 %clean
95 rm -fr $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc NEWS README
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %doc */*.html
108 %attr(755,root,root) %{_libdir}/lib*.so*
109 %{_libdir}/lib*.la
110 %{_libdir}/libtrampoline.a
111 %{_libdir}/libvacall.a
112 %{_includedir}/*
113 %{_mandir}/man?/*
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libavcall.a
118 %{_libdir}/libcallback.a
This page took 0.062987 seconds and 4 git commands to generate.