]> git.pld-linux.org Git - packages/ffcall.git/blob - ffcall.spec
11528703822349e30d5455a1c9571a9c8ea75413
[packages/ffcall.git] / ffcall.spec
1 %define         snap    20090629
2 %define         rel     2
3
4 Summary:        Libraries for building foreign function call interfaces
5 Summary(pl.UTF-8):      Biblioteki do tworzenia interfejsów wywołań obcych funkcji
6 Name:           ffcall
7 Version:        1.11
8 Release:        0.%{snap}.%{rel}
9 Epoch:          1
10 License:        GPL
11 Group:          Libraries
12 # cvs -d:pserver:anonymous@cvs.sv.gnu.org:/sources/libffcall co .
13 Source0:        %{name}-%{snap}.tar.bz2
14 # Source0-md5:  a5190885da8e701a012bb282bfb3c51b
15 Patch0:         %{name}-make-jN.patch
16 Patch1:         %{name}-sparcv9.patch
17 # https://savannah.gnu.org/bugs/index.php?22081
18 Patch2:         %{name}-sparc64.patch
19 URL:            http://savannah.gnu.org/projects/libffcall
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %undefine       __cxx
23
24 %description
25 This is a collection of four libraries which can be used to build
26 foreign function call interfaces in embedded interpreters.
27
28 The four packages are:
29 - avcall - calling C functions with variable arguments
30 - vacall - C functions accepting variable argument prototypes
31 - trampoline - closures as first-class C functions
32 - callback - closures with variable arguments as first-class C
33   functions (a reentrant combination of vacall and trampoline)
34
35 This version B includes some minor configuration changes so that files
36 are installed in the proper place. Also it compiles on cygwin and
37 mingw32.
38
39 %description -l pl.UTF-8
40 To jest zestaw czterech bibliotek, których można użyć do tworzenia
41 interfejsów wywołań obcych procedur we wbudowanych interpreterach.
42
43 Te cztery pakiety to:
44 - avcall - wywoływanie funkcji w C ze zmiennymi argumentami
45 - vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
46 - trampoline - domknięcia jako funkcje C pierwszej klasy
47 - callback - domknięcia ze zmiennymi argumentami jako funkcje C
48   pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
49
50 Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
51 pliki instalują się we właściwych miejscach. A także kompiluje się pod
52 cygwinem i mingw32.
53
54 %package devel
55 Summary:        Development files for ffcall libraries
56 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek ffcall
57 Group:          Development/Libraries
58 Requires:       %{name} = %{epoch}:%{version}-%{release}
59
60 %description devel
61 Development files for ffcall libraries: headers and static trampoline
62 and vacall libraries.
63
64 %description devel -l pl.UTF-8
65 Pliki dla programistów używających bibliotek ffcall: nagłówki i
66 statyczne biblioteki trampoline oraz vacall.
67
68 %package static
69 Summary:        Static versions of avcall and callback libraries
70 Summary(pl.UTF-8):      Statyczne wersje bibliotek avcall i callback
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
73
74 %description static
75 Static versions of avcall and callback libraries.
76
77 %description static -l pl.UTF-8
78 Statyczne wersje bibliotek avcall i callback.
79
80 %prep
81 %setup -q -n %{name}-%{snap}
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p0
85
86 %build
87 %configure \
88         --enable-shared
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_mandir}
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # don't need those since we have man pages
100 %{__rm} $RPM_BUILD_ROOT%{_datadir}/html/*.html
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc ChangeLog NEWS PLATFORMS README
111 %attr(755,root,root) %{_libdir}/libavcall.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libavcall.so.0
113 %attr(755,root,root) %{_libdir}/libcallback.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libcallback.so.0
115
116 %files devel
117 %defattr(644,root,root,755)
118 %doc */*.html
119 %attr(755,root,root) %{_libdir}/libavcall.so
120 %attr(755,root,root) %{_libdir}/libcallback.so
121 %{_libdir}/libavcall.la
122 %{_libdir}/libcallback.la
123 %{_libdir}/libtrampoline.a
124 %{_libdir}/libvacall.a
125 %{_includedir}/avcall.h
126 %{_includedir}/callback.h
127 %{_includedir}/trampoline*.h
128 %{_includedir}/vacall*.h
129 %{_mandir}/man3/avcall.3*
130 %{_mandir}/man3/callback.3*
131 %{_mandir}/man3/trampoline*.3*
132 %{_mandir}/man3/vacall.3*
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libavcall.a
137 %{_libdir}/libcallback.a
This page took 0.101471 seconds and 2 git commands to generate.