]> git.pld-linux.org Git - packages/feathercoin.git/blob - feathercoin.spec
- package devel stuff; release 2 (rebuild with protobuf 3.6)
[packages/feathercoin.git] / feathercoin.spec
1 # NOTE: "portable wallet" wants BDB 4.8
2 #
3 # Conditional build:
4 %bcond_with     ccache  # use ccache for building
5 %bcond_without  gui     # Qt5 GUI
6
7 Summary:        Feathercoin - a peer-to-peer currency
8 Summary(pl.UTF-8):      Feathercoin - waluta peer-to-peer
9 Name:           feathercoin
10 Version:        0.16.3
11 Release:        2
12 License:        MIT
13 Group:          Applications/Networking
14 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15 Source0:        https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  eaecf6f317091f52fae0eff95ac3b7be
17 Patch0:         lib.patch
18 URL:            https://www.feathercoin.com/
19 %if %{with gui}
20 BuildRequires:  Qt5Core-devel >= 5
21 BuildRequires:  Qt5DBus-devel >= 5
22 BuildRequires:  Qt5Gui-devel >= 5
23 BuildRequires:  Qt5Network-devel >= 5
24 BuildRequires:  Qt5PrintSupport-devel >= 5
25 BuildRequires:  Qt5Test-devel >= 5
26 BuildRequires:  Qt5Widgets-devel >= 5
27 %endif
28 BuildRequires:  autoconf >= 2.69
29 BuildRequires:  automake
30 BuildRequires:  boost-devel
31 %{?with_ccache:BuildRequires:   ccache}
32 BuildRequires:  db-cxx-devel >= 4.8
33 BuildRequires:  gettext-tools
34 %{?with_gui:BuildRequires:      libpng-devel}
35 BuildRequires:  libsecp256k1-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool
38 BuildRequires:  libunivalue-devel
39 BuildRequires:  miniupnpc-devel >= 1.5
40 BuildRequires:  openssl-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  protobuf-devel
43 BuildRequires:  qrencode-devel
44 %{?with_gui:BuildRequires:      qt5-build >= 5}
45 %{?with_gui:BuildRequires:      zlib-devel}
46 BuildRequires:  zxing-cpp-devel
47 Requires:       perl-base
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
52 central authority issues new money or tracks transactions. These tasks
53 are managed collectively by the network.
54
55 %description -l pl.UTF-8
56 Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
57 centralnego urzędu, który emituje nowe pieniądze czy śledzi
58 transakcje. Zadania te są obsługiwane zespołowo przez sieć.
59
60 %package devel
61 Summary:        Header file for bitcoinconsensus library
62 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bitcoinconsensus
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       openssl-devel
66 Conflicts:      bitcoin-devel
67
68 %description devel
69 Header file for bitcoinconsensus library.
70
71 %description devel -l pl.UTF-8
72 Plik nagłówkowy biblioteki bitcoinconsensus.
73
74 %package static
75 Summary:        Static bitcoinconsensus library
76 Summary(pl.UTF-8):      Statyczna biblioteka bitcoinconsensus
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79 Conflicts:      bitcoin-static
80
81 %description static
82 Static bitcoinconsensus library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka bitcoinconsensus.
86
87 %package qt
88 Summary:        Qt-based Feathercoin Wallet
89 Summary(pl.UTF-8):      Oparty na Qt portfel Feathercoin
90 Group:          X11/Applications
91
92 %description qt
93 Qt-based Feathercoin Wallet.
94
95 %description qt -l pl.UTF-8
96 Oparty na Qt portfel Feathercoin.
97
98 %prep
99 %setup -q -n Feathercoin-%{version}
100 %patch0 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 # --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
109 %configure \
110         --enable-ccache%{!?with_ccache:=no} \
111         --disable-silent-rules \
112         --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
113         --with-incompatible-bdb \
114         --with-system-univalue
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
126
127 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
128 sed -e 's#bitcoin#feathercoin#g;s#Bitcoin#Feathercoin#g' contrib/debian/bitcoin-qt.desktop > $RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
129 sed -e 's#bitcoin#feathercoin#g' contrib/debian/bitcoin-qt.protocol > $RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc COPYING README.md doc/*.txt contrib/debian/examples/bitcoin.conf
140 %attr(755,root,root) %{_bindir}/feathercoin-cli
141 %attr(755,root,root) %{_bindir}/feathercoin-tx
142 %attr(755,root,root) %{_bindir}/feathercoind
143 %{_mandir}/man1/feathercoin-cli.1*
144 %{_mandir}/man1/feathercoin-tx.1*
145 %{_mandir}/man1/feathercoind.1*
146 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
152 %{_includedir}/bitcoinconsensus.h
153 %{_pkgconfigdir}/libbitcoinconsensus.pc
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libbitcoinconsensus.a
158
159 %files qt
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/feathercoin-qt
162 %{_datadir}/kde4/services/feathercoin-qt.protocol
163 %{_desktopdir}/feathercoin-qt.desktop
164 %{_mandir}/man1/feathercoin-qt.1*
This page took 0.113395 seconds and 3 git commands to generate.