]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
- rel 3; fix format
[packages/expect.git] / expect.spec
1 #
2 # BIG FAT WARNING:
3 #       - expect requires mounted /dev/pts to avoid `spawn failed' errors.
4 #
5 %bcond_without  tests
6 Summary:        Tcl expect extension
7 Summary(de.UTF-8):      Tcl-Erweiterung
8 Summary(fr.UTF-8):      Extension Tcl
9 Summary(pl.UTF-8):      Rozszerzenie Tcl expect
10 Summary(ru.UTF-8):      Расширение Tcl для управления программами из скриптов
11 Summary(tr.UTF-8):      Programlar arası etkileşimi mümkün kılan Tcl genişletmesi
12 Summary(uk.UTF-8):      Розширення Tcl для керування програмами зі скриптів
13 Name:           expect
14 Version:        5.45
15 Release:        3
16 License:        BSD
17 Group:          Development/Languages/Tcl
18 Source0:        http://downloads.sourceforge.net/expect/%{name}%{version}.tar.gz
19 # Source0-md5:  44e1a4f4c877e9ddc5a542dfa7ecc92b
20 Patch0:         %{name}-pty.patch
21 Patch1:         %{name}-bug7869.patch
22 Patch2:         %{name}-soname.patch
23 Patch3:         %{name}-format.patch
24 URL:            http://expect.nist.gov/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  tcl-devel >= 8.5.0
28 BuildRequires:  tk-devel >= 8.5.0
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRequires:  xorg-lib-libXext-devel
31 BuildRequires:  xorg-lib-libXScrnSaver-devel
32 Requires:       tcl >= 8.5.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _ulibdir        /usr/lib
36
37 %description
38 Expect is a tool for automating interactive applications such as
39 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
40 script to control another program and interact with it.
41
42 %description -l pl.UTF-8
43 Expect to narzędzie do automatyzacji interakcji z aplikacjami takimi
44 jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w łatwy
45 sposób przy pomocy skryptu kontrolować inny program.
46
47 %description -l de.UTF-8
48 Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
49 telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
50 Skript ein anderes Programm sehr leicht steuern oder damit
51 interagieren.
52
53 %description -l fr.UTF-8
54 expect est un un outil pour automatiser les applications interactives
55 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
56 pour un script de contrôler un autre programme et d'interagir avec
57 lui.
58
59 %description -l tr.UTF-8
60 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileşimli
61 uygulamaları otomatize etmeye yarayan bir araçtır. Bir uygulamanın bir
62 diğer uygulamayı denetlemesini kolaylaştırır.
63
64 %description -l ru.UTF-8
65 Expect - это инструмент для автоматизации интерактивных программ,
66 таких как telnet, ftp, passwd, fsck, rlogin, tip, и т.п. Позволяет
67 управлять программами и взаимодействовать с ними из скриптов.
68
69 %description -l uk.UTF-8
70 Expect - це інструмент для автоматизації інтерактивних програм, таких
71 як telnet, ftp, passwd, fsck, rlogin, tip, і т.і. Дозволяє керувати
72 програмами та взаємодіяти з ними зі скриптів.
73
74 %package X11
75 Summary:        Tk extension
76 Summary(pl.UTF-8):      Rozszerzenie Tk
77 Group:          Development/Languages/Tcl
78 Requires:       %{name} = %{version}-%{release}
79
80 %description X11
81 This package contains expectk, which is an Tk extension, just as
82 expect Tcl extension.
83
84 %description X11 -l pl.UTF-8
85 Ten pakiet zawiera expectk, który jest rozszerzeniem dla Tk takim jak
86 expect jest dla Tcl.
87
88 %package devel
89 Summary:        Tcl expect extension header files and development documentation
90 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do rozszerzenia expect języka Tcl
91 Group:          Development/Languages/Tcl
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       tcl-devel >= 8.5.0
94 Obsoletes:      expect-static
95
96 %description devel
97 Tcl expect extension language header files and development
98 documentation.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe i dokumentacja do rozszerzenia expect języka Tcl.
102
103 %prep
104 %setup -q -n %{name}%{version}
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109
110 chmod +w {.,testsuite}/configure
111
112 %build
113 install /usr/share/automake/config.* .
114 # only local macros, don't call aclocal
115 %{__autoconf}
116 cd testsuite
117 %{__autoconf} -I ..
118 cd ..
119 CFLAGS="%{rpmcflags} -I%{_includedir}/tcl-private/unix"
120 %configure \
121 %if "%{_lib}" == "lib64"
122         --enable-64bit \
123 %endif
124         --enable-gcc \
125         --enable-shared \
126         --with-tclconfig=%{_ulibdir} \
127         --with-tkconfig=%{_ulibdir} \
128         --with-tclinclude=%{_includedir} \
129         --with-tkinclude=%{_includedir}
130
131 %{__make}
132
133 %{?with_tests:%{__make} test TCLSH_PROG=tclsh}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT \
141         TCLSH_PROG=tclsh
142
143 mv -f $RPM_BUILD_ROOT%{_bindir}/{rftp,rftp-expect}
144
145 mv -f $RPM_BUILD_ROOT%{_libdir}/expect%{version}/libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}
146 ln -sf ../libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}/expect%{version}/libexpect%{version}.so
147 ln -sf libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}/libexpect.so
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc ChangeLog FAQ HISTORY NEWS README
158 %attr(755,root,root) %{_bindir}/autoexpect
159 %attr(755,root,root) %{_bindir}/autopasswd
160 %attr(755,root,root) %{_bindir}/cryptdir
161 %attr(755,root,root) %{_bindir}/decryptdir
162 %attr(755,root,root) %{_bindir}/dislocate
163 %attr(755,root,root) %{_bindir}/expect
164 %attr(755,root,root) %{_bindir}/ftp-rfc
165 %attr(755,root,root) %{_bindir}/kibitz
166 %attr(755,root,root) %{_bindir}/lpunlock
167 %attr(755,root,root) %{_bindir}/mkpasswd
168 %attr(755,root,root) %{_bindir}/passmass
169 %attr(755,root,root) %{_bindir}/rftp-expect
170 %attr(755,root,root) %{_bindir}/rlogin-cwd
171 %attr(755,root,root) %{_bindir}/timed-read
172 %attr(755,root,root) %{_bindir}/timed-run
173 %attr(755,root,root) %{_bindir}/unbuffer
174 %attr(755,root,root) %{_bindir}/weather
175 %attr(755,root,root) %{_libdir}/libexpect%{version}.so
176 %dir %{_libdir}/expect%{version}
177 %attr(755,root,root) %{_libdir}/expect%{version}/pkgIndex.tcl
178 %attr(755,root,root) %{_libdir}/expect%{version}/libexpect%{version}.so
179 %{_mandir}/man1/autoexpect.1*
180 %{_mandir}/man1/cryptdir.1*
181 %{_mandir}/man1/decryptdir.1*
182 %{_mandir}/man1/dislocate.1*
183 %{_mandir}/man1/expect.1*
184 %{_mandir}/man1/kibitz.1*
185 %{_mandir}/man1/mkpasswd.1*
186 %{_mandir}/man1/passmass.1*
187 %{_mandir}/man1/unbuffer.1*
188
189 %files X11
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/multixterm
192 %attr(755,root,root) %{_bindir}/tknewsbiff
193 %attr(755,root,root) %{_bindir}/tkpasswd
194 %attr(755,root,root) %{_bindir}/xkibitz
195 %attr(755,root,root) %{_bindir}/xpstat
196 %{_mandir}/man1/multixterm.1*
197 %{_mandir}/man1/tknewsbiff.1*
198 %{_mandir}/man1/xkibitz.1*
199
200 %files devel
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libexpect.so
203 %{_includedir}/expect*.h
204 %{_includedir}/tcldbg.h
205 %{_mandir}/man3/libexpect.3*
This page took 0.035972 seconds and 3 git commands to generate.