]> git.pld-linux.org Git - packages/exo.git/blob - exo.spec
fix shebang
[packages/exo.git] / exo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     static_libs     # don't build static library
5
6 %define         xfce_version    4.12.0
7 Summary:        Extension library to Xfce developed by os-cillation
8 Summary(pl.UTF-8):      Biblioteka rozszerzeń do Xfce opracowana przez os-cillation
9 Name:           exo
10 Version:        0.12.8
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Libraries
14 Source0:        http://archive.xfce.org/src/xfce/exo/0.12/%{name}-%{version}.tar.bz2
15 # Source0-md5:  e618ce760a12ac7427a48a44c69f3d31
16 Patch0:         mate-terminal.patch
17 URL:            http://www.os-cillation.com/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gettext-tools
22 BuildRequires:  glib2-devel >= 1:2.30.0
23 BuildRequires:  gtk+2-devel >= 2:2.24.0
24 BuildRequires:  gtk+3-devel
25 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
26 BuildRequires:  gtk-doc-automake
27 BuildRequires:  intltool >= 0.35.0
28 BuildRequires:  libtool
29 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
30 BuildRequires:  libxfce4util-devel >= %{xfce_version}
31 BuildRequires:  perl-URI
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpmbuild(macros) >= 1.601
34 BuildRequires:  xfce4-dev-tools >= 4.10.0
35 Requires:       glib2 >= 1:2.27.0
36 Requires:       xfce4-dirs >= 4.6
37 Provides:       libexo
38 Obsoletes:      libexo
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Extension library to Xfce developed by os-cillation.
43
44 %description -l pl.UTF-8
45 Biblioteka rozszerzeń do Xfce opracowana przez os-cillation.
46
47 %package -n xfce-preferred-applications
48 Summary:        The Xfce Preferred Applications framework
49 Summary(pl.UTF-8):      Struktura Preferowanych Aplikacji Xfce
50 Group:          X11/Applications
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       gtk-update-icon-cache
53 Requires:       hicolor-icon-theme
54
55 %description -n xfce-preferred-applications
56 The Xfce Preferred Applications framework.
57
58 %description -n xfce-preferred-applications -l pl.UTF-8
59 Struktura Preferowanych Aplikacji Xfce.
60
61 %package apidocs
62 Summary:        libexo API documentation
63 Summary(pl.UTF-8):      Dokumentacja API libexo
64 Group:          Documentation
65 Requires:       gtk-doc-common
66 Provides:       libexo-apidocs
67 Obsoletes:      libexo-apidocs
68 %if "%{_rpmversion}" >= "5"
69 BuildArch:      noarch
70 %endif
71
72 %description apidocs
73 libexo API documentation.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API libexo.
77
78 %package devel
79 Summary:        Header files for libexo library
80 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libexo
81 Group:          X11/Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       gtk+2-devel >= 2:2.14.0
84 Requires:       gtk+3-devel
85 Requires:       libxfce4util-devel >= %{xfce_version}
86 Provides:       libexo-devel
87 Obsoletes:      libexo-devel
88
89 %description devel
90 Header files for libexo library.
91
92 %description devel -l pl.UTF-8
93 Pliki nagłówkowe biblioteki libexo.
94
95 %package static
96 Summary:        Static libexo library
97 Summary(pl.UTF-8):      Statyczna biblioteka libexo
98 Group:          X11/Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100 Provides:       libexo-static
101 Obsoletes:      libexo-static
102
103 %description static
104 Static libexo library.
105
106 %description static -l pl.UTF-8
107 Statyczna biblioteka libexo.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112
113 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
114 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' exo-helper/helpers/exo-compose-mail
115
116 mkdir -p m4
117
118 %build
119 %{?with_apidocs:%{__gtkdocize}}
120 %{__intltoolize}
121 %{__libtoolize}
122 %{__aclocal}
123 %{__autoheader}
124 %{__automake}
125 %{__autoconf}
126 %configure \
127         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
128         --with-html-dir=%{_gtkdocdir} \
129         %{!?with_static_libs:--disable-static} \
130         --disable-silent-rules
131
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
140
141 # already exists as ur
142 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
143
144 # unknown / unsupported
145 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{hy_AM,ie}
146
147 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/exo}
148
149 %find_lang exo-1
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %post   -n xfce-preferred-applications
158 %update_icon_cache hicolor
159
160 %postun -n xfce-preferred-applications
161 %update_icon_cache hicolor
162
163 %files -f exo-1.lang
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog HACKING NEWS README TODO
166 %attr(755,root,root) %{_libdir}/libexo-1.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libexo-1.so.0
168 %attr(755,root,root) %{_libdir}/libexo-2.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libexo-2.so.0
170 %{_pixmapsdir}/exo
171
172 %files -n xfce-preferred-applications
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/exo-desktop-item-edit
175 %attr(755,root,root) %{_bindir}/exo-open
176 %attr(755,root,root) %{_bindir}/exo-preferred-applications
177 %dir %{_libdir}/xfce4/exo
178 %attr(755,root,root) %{_libdir}/xfce4/exo/exo-compose-mail
179 %dir %{_libdir}/xfce4/exo-2
180 %attr(755,root,root) %{_libdir}/xfce4/exo-2/exo-helper-2
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/xfce4/*.rc
182 %dir %{_datadir}/xfce4/helpers
183 %{_datadir}/xfce4/helpers/*.desktop
184 %{_desktopdir}/*.desktop
185 %{_iconsdir}/hicolor/*/apps/preferences-desktop-default-applications.png
186 %{_mandir}/man1/*.1*
187
188 %if %{with apidocs}
189 %files apidocs
190 %defattr(644,root,root,755)
191 %{_gtkdocdir}/exo-1
192 %endif
193
194 %files devel
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_bindir}/exo-csource
197 %attr(755,root,root) %{_libdir}/libexo-1.so
198 %attr(755,root,root) %{_libdir}/libexo-2.so
199 %{_includedir}/exo-1
200 %{_includedir}/exo-2
201 %{_pkgconfigdir}/exo-1.pc
202 %{_pkgconfigdir}/exo-2.pc
203
204 %if %{with static_libs}
205 %files static
206 %defattr(644,root,root,755)
207 %{_libdir}/libexo-1.a
208 %{_libdir}/libexo-2.a
209 %endif
This page took 0.11421 seconds and 3 git commands to generate.