]> git.pld-linux.org Git - packages/exiv2.git/blob - exiv2.spec
- enabled BMFF support
[packages/exiv2.git] / exiv2.spec
1 #
2 # Conditional build:
3 %bcond_with     curl            # enable webready with HTTP support via curl
4 %bcond_with     libssh          # enable webready with SSH support via libssh
5
6 Summary:        EXIF and IPTC metadata manipulation tools
7 Summary(pl.UTF-8):      Narzędzia do obróbki metadanych EXIF i IPTC
8 Name:           exiv2
9 Version:        0.27.4
10 Release:        1
11 License:        GPL v2+
12 Group:          Applications/Graphics
13 #Source0Download: https://www.exiv2.org/download.html
14 Source0:        https://www.exiv2.org/builds/%{name}-%{version}-Source.tar.gz
15 # Source0-md5:  15c24498a7d6abd171ae525574f98efb
16 Patch0:         %{name}-no-xmpsdk-install.patch
17 URL:            https://www.exiv2.org/
18 BuildRequires:  cmake >= 3.3.2
19 %{?with_curl:BuildRequires:     curl-devel}
20 BuildRequires:  expat-devel
21 BuildRequires:  gettext-tools
22 %{?with_libssh:BuildRequires:   libssh-devel}
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  zlib-devel
25 Requires:       %{name}-libs = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 EXIF and IPTC metadata manipulation tools.
30
31 %description -l pl.UTF-8
32 Narzędzia do obróbki metadanych EXIF i IPTC.
33
34 %package libs
35 Summary:        EXIF and IPTC metadata manipulation library
36 Summary(pl.UTF-8):      Biblioteka do obróbki metadanych EXIF i IPTC
37 Group:          Libraries
38
39 %description libs
40 EXIF and IPTC metadata manipulation library.
41
42 %description libs -l pl.UTF-8
43 Biblioteka do obróbki metadanych EXIF i IPTC.
44
45 %package devel
46 Summary:        EXIF and IPTC metadata manipulation library development files
47 Summary(pl.UTF-8):      Pliki programistyczne biblioteki do obróbki metadanych EXIF i IPTC
48 Group:          Development/Libraries
49 Requires:       %{name}-libs = %{version}-%{release}
50 %{?with_curl:Requires:  curl-devel}
51 Requires:       expat-devel
52 %{?with_libssh:Requires:        libssh-devel}
53 Requires:       libstdc++-devel
54 Requires:       zlib-devel
55 Obsoletes:      exiv2-static
56
57 %description devel
58 EXIF and IPTC metadata manipulation library development files.
59
60 %description devel -l pl.UTF-8
61 Pliki programistyczne biblioteki do obróbki metadanych EXIF i IPTC.
62
63 %prep
64 %setup -q -n %{name}-%{version}-Source
65 %patch0 -p1
66
67 %build
68 install -d build
69 cd build
70 %cmake .. \
71         -DEXIV2_BUILD_SAMPLES=OFF \
72         -DEXIV2_ENABLE_BMFF=ON \
73         %{?with_curl:-DEXIV2_ENABLE_CURL=ON} \
74         -DEXIV2_ENABLE_NLS=ON \
75         %{?with_libssh:-DEXIV2_ENABLE_SSH=ON} \
76         -DEXIV2_ENABLE_VIDEO=ON \
77 %if %{with curl} || %{with libssh}
78         -DEXIV2_ENABLE_WEBREADY=ON
79 %endif
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} -C build install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %find_lang %{name}
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   libs -p /sbin/ldconfig
95 %postun libs -p /sbin/ldconfig
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc README.md doc/ChangeLog doc/cmd.txt
100 %attr(755,root,root) %{_bindir}/exiv2
101 %{_mandir}/man1/exiv2.1*
102
103 %files libs
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libexiv2.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libexiv2.so.27
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libexiv2.so
111 %{_includedir}/exiv2
112 %{_pkgconfigdir}/exiv2.pc
113 %{_libdir}/cmake/exiv2
This page took 0.339208 seconds and 3 git commands to generate.