]> git.pld-linux.org Git - packages/exiv2.git/blob - exiv2.spec
- updated to 0.25 (note: new soname)
[packages/exiv2.git] / exiv2.spec
1 #
2 # Conditional build:
3 %bcond_with     curl    # enable webready with HTTP support via curl
4 %bcond_with     libssh  # enable webready with SSH support via libssh
5
6 Summary:        EXIF and IPTC metadata manipulation tools
7 Summary(pl.UTF-8):      Narzędzia do obróbki metadanych EXIF i IPTC
8 Name:           exiv2
9 Version:        0.25
10 Release:        1
11 License:        GPL v2+
12 Group:          Applications/Graphics
13 #Source0Download: http://www.exiv2.org/download.html
14 Source0:        http://www.exiv2.org/%{name}-%{version}.tar.gz
15 # Source0-md5:  258d4831b30f75a01e0234065c6c2806
16 Patch0:         %{name}-mkinstalldirs.patch
17 Patch1:         %{name}-png_support.patch
18 URL:            http://www.exiv2.org/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake
21 %{?with_curl:BuildRequires:     curl-devel}
22 BuildRequires:  expat-devel
23 BuildRequires:  gettext-tools
24 %{?with_libssh:BuildRequires:   libssh-devel}
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:2.0
27 BuildRequires:  zlib-devel
28 Requires:       %{name}-libs = %{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 EXIF and IPTC metadata manipulation tools.
33
34 %description -l pl.UTF-8
35 Narzędzia do obróbki metadanych EXIF i IPTC.
36
37 %package libs
38 Summary:        EXIF and IPTC metadata manipulation library
39 Summary(pl.UTF-8):      Biblioteka do obróbki metadanych EXIF i IPTC
40 Group:          Libraries
41
42 %description libs
43 EXIF and IPTC metadata manipulation library.
44
45 %description libs -l pl.UTF-8
46 Biblioteka do obróbki metadanych EXIF i IPTC.
47
48 %package devel
49 Summary:        EXIF and IPTC metadata manipulation library development files
50 Summary(pl.UTF-8):      Pliki programistyczne biblioteki do obróbki metadanych EXIF i IPTC
51 Group:          Development/Libraries
52 Requires:       %{name}-libs = %{version}-%{release}
53 %{?with_curl:Requires:  curl-devel}
54 Requires:       expat-devel
55 %{?with_libssh:Requires:        libssh-devel}
56 Requires:       libstdc++-devel
57 Requires:       zlib-devel
58
59 %description devel
60 EXIF and IPTC metadata manipulation library development files.
61
62 %description devel -l pl.UTF-8
63 Pliki programistyczne biblioteki do obróbki metadanych EXIF i IPTC.
64
65 %package static
66 Summary:        EXIF and IPTC metadata manipulation static library
67 Summary(pl.UTF-8):      Statyczna biblioteka do obróbki metadanych EXIF i IPTC
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 EXIF and IPTC metadata manipulation static library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka do obróbki metadanych EXIF i IPTC.
76
77 %prep
78 %setup -q
79 %patch0 -p0
80 %patch1 -p1
81
82 ln -s config/configure.ac .
83
84 # AX_CXX_CHECK_FLAG from old autoconf-archive, missing in acinclude or separate file
85 tail -n +10113 config/aclocal.m4 >> acinclude.m4
86
87 %build
88 %{__libtoolize} --install
89 %{__aclocal}
90 %{__autoconf}
91 # don't touch autoheader, config.h.in has been manually modified
92 %configure \
93         --enable-video \
94 %if %{with curl} || %{with libssh}
95         --enable-webready \
96         %{!?with_curl:--without-curl} \
97         %{!?with_libssh:--without-ssh}
98 %endif
99
100 %{__make} \
101         CFLAGS="%{rpmcflags} -Wall" \
102         CXXFLAGS="%{rpmcxxflags} -Wall"
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         incdir=%{_includedir}/exiv2 \
109         libdir=%{_libdir} \
110         bindir=%{_bindir} \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # obsoleted by pkg-config
114 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libexiv2.la
115 # let rpm autodetect dependencies
116 chmod 755 $RPM_BUILD_ROOT%{_libdir}/libexiv2.so*
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   libs -p /sbin/ldconfig
124 %postun libs -p /sbin/ldconfig
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %doc doc/ChangeLog README
129 %attr(755,root,root) %{_bindir}/%{name}
130 %{_mandir}/man1/exiv2.1*
131
132 %files libs
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libexiv2.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libexiv2.so.14
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libexiv2.so
140 %{_includedir}/%{name}
141 %{_pkgconfigdir}/exiv2.pc
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libexiv2.a
This page took 0.078837 seconds and 3 git commands to generate.