]> git.pld-linux.org Git - packages/exempi.git/blob - exempi.spec
f37ce429ed209fbd5453d231ea5250c0bc985ad4
[packages/exempi.git] / exempi.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        An XMP metadata support library
6 Summary(pl.UTF-8):      Biblioteka obsługująca metadane XMP
7 Name:           exempi
8 Version:        2.4.5
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 Source0:        https://libopenraw.freedesktop.org/download/%{name}-%{version}.tar.bz2
13 # Source0-md5:  bb7a06ef8bbf79a59e32562b198daefd
14 URL:            https://libopenraw.freedesktop.org/wiki/Exempi
15 %{?with_tests:BuildRequires:    boost-devel >= 1.48.0}
16 BuildRequires:  expat-devel >= 1.95
17 BuildRequires:  libstdc++-devel >= 6:4.4
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 XMP metadata parsing and IO library.
23
24 %description -l pl.UTF-8
25 Biblioteka do analizy oraz wejścia/wyjścia metadanych XMP.
26
27 %package devel
28 Summary:        Header files for exempi
29 Summary(pl.UTF-8):      Pliki nagłówkowe exempi
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       expat-devel >= 1.95
33 Requires:       libstdc++-devel >= 6:4.4
34 Requires:       zlib-devel
35
36 %description devel
37 Header files for exempi.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe exempi.
41
42 %package static
43 Summary:        Static exempi library
44 Summary(pl.UTF-8):      Statyczna biblioteka exempi
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static exempi library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka exempi.
53
54 %package samples
55 Summary:        Sample exempi programs
56 Summary(pl.UTF-8):      Przykładowe programy exempi
57 Group:          Applications/Archiving
58 # doesn't require base, statically linked with exempi code
59
60 %description samples
61 Sample programs using exempi library.
62
63 %description samples -l pl.UTF-8
64 Przykładowe programy używające biblioteki exempi.
65
66 %prep
67 %setup -q
68
69 %build
70 # configure fails on boost linking check
71 %configure \
72         --disable-silent-rules \
73         %{!?with_tests:--disable-unittest}
74 %{__make}
75
76 %if %{with tests}
77 %{__make} check
78 %endif
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{_bindir}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 # obsoleted by pkg-config
88 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libexempi.la
89
90 install samples/source/{dumpmainxmp,dumpxmp,xmpcoverage,xmpfilescoverage} $RPM_BUILD_ROOT%{_bindir}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc AUTHORS COPYING ChangeLog NEWS README TODO
101 %attr(755,root,root) %{_bindir}/exempi
102 %attr(755,root,root) %{_libdir}/libexempi.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libexempi.so.3
104 %{_mandir}/man1/exempi.1*
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libexempi.so
109 %{_includedir}/exempi-2.0
110 %{_pkgconfigdir}/exempi-2.0.pc
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libexempi.a
115
116 %files samples
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/dumpmainxmp
119 %attr(755,root,root) %{_bindir}/dumpxmp
120 %attr(755,root,root) %{_bindir}/xmpcoverage
121 %attr(755,root,root) %{_bindir}/xmpfilescoverage
This page took 0.079737 seconds and 2 git commands to generate.