]> git.pld-linux.org Git - packages/exempi.git/blob - exempi.spec
- updated to 2.5.0 (note: new soname)
[packages/exempi.git] / exempi.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        An XMP metadata support library
6 Summary(pl.UTF-8):      Biblioteka obsługująca metadane XMP
7 Name:           exempi
8 Version:        2.5.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://libopenraw.freedesktop.org/exempi/
13 Source0:        https://libopenraw.freedesktop.org/download/%{name}-%{version}.tar.bz2
14 # Source0-md5:  e0976661e4a09b6206228c8b8b447b53
15 URL:            https://libopenraw.freedesktop.org/exempi/
16 %{?with_tests:BuildRequires:    boost-devel >= 1.48.0}
17 BuildRequires:  expat-devel >= 1.95
18 BuildRequires:  libstdc++-devel >= 6:4.4
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 XMP metadata parsing and IO library.
24
25 %description -l pl.UTF-8
26 Biblioteka do analizy oraz wejścia/wyjścia metadanych XMP.
27
28 %package devel
29 Summary:        Header files for exempi
30 Summary(pl.UTF-8):      Pliki nagłówkowe exempi
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33 Requires:       expat-devel >= 1.95
34 Requires:       libstdc++-devel >= 6:4.4
35 Requires:       zlib-devel
36
37 %description devel
38 Header files for exempi.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe exempi.
42
43 %package static
44 Summary:        Static exempi library
45 Summary(pl.UTF-8):      Statyczna biblioteka exempi
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static exempi library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka exempi.
54
55 %package samples
56 Summary:        Sample exempi programs
57 Summary(pl.UTF-8):      Przykładowe programy exempi
58 Group:          Applications/Archiving
59 # doesn't require base, statically linked with exempi code
60
61 %description samples
62 Sample programs using exempi library.
63
64 %description samples -l pl.UTF-8
65 Przykładowe programy używające biblioteki exempi.
66
67 %prep
68 %setup -q
69
70 %build
71 # configure fails on boost linking check
72 %configure \
73         --disable-silent-rules \
74         %{!?with_tests:--disable-unittest}
75 %{__make}
76
77 %if %{with tests}
78 %{__make} check
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_bindir}
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 # obsoleted by pkg-config
89 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libexempi.la
90
91 install samples/source/{dumpmainxmp,dumpxmp,xmpcoverage,xmpfilescoverage} $RPM_BUILD_ROOT%{_bindir}
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS COPYING ChangeLog NEWS README TODO
102 %attr(755,root,root) %{_bindir}/exempi
103 %attr(755,root,root) %{_libdir}/libexempi.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libexempi.so.8
105 %{_mandir}/man1/exempi.1*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libexempi.so
110 %{_includedir}/exempi-2.0
111 %{_pkgconfigdir}/exempi-2.0.pc
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libexempi.a
116
117 %files samples
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_bindir}/dumpmainxmp
120 %attr(755,root,root) %{_bindir}/dumpxmp
121 %attr(755,root,root) %{_bindir}/xmpcoverage
122 %attr(755,root,root) %{_bindir}/xmpfilescoverage
This page took 0.049104 seconds and 3 git commands to generate.