]> git.pld-linux.org Git - packages/exempi.git/blob - exempi.spec
refresh config.sub
[packages/exempi.git] / exempi.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 Summary:        An XMP metadata support library
6 Summary(pl.UTF-8):      Biblioteka obsługująca metadane XMP
7 Name:           exempi
8 Version:        2.5.1
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://libopenraw.freedesktop.org/exempi/
13 Source0:        https://libopenraw.freedesktop.org/download/%{name}-%{version}.tar.bz2
14 # Source0-md5:  c32bcd9feed5a0c1523d5652ef1804b0
15 URL:            https://libopenraw.freedesktop.org/exempi/
16 %{?with_tests:BuildRequires:    boost-devel >= 1.48.0}
17 BuildRequires:  expat-devel >= 1.95
18 BuildRequires:  libstdc++-devel >= 6:4.4
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 XMP metadata parsing and IO library.
24
25 %description -l pl.UTF-8
26 Biblioteka do analizy oraz wejścia/wyjścia metadanych XMP.
27
28 %package devel
29 Summary:        Header files for exempi
30 Summary(pl.UTF-8):      Pliki nagłówkowe exempi
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33 Requires:       expat-devel >= 1.95
34 Requires:       libstdc++-devel >= 6:4.4
35 Requires:       zlib-devel
36
37 %description devel
38 Header files for exempi.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe exempi.
42
43 %package static
44 Summary:        Static exempi library
45 Summary(pl.UTF-8):      Statyczna biblioteka exempi
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static exempi library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka exempi.
54
55 %package samples
56 Summary:        Sample exempi programs
57 Summary(pl.UTF-8):      Przykładowe programy exempi
58 Group:          Applications/Archiving
59 # doesn't require base, statically linked with exempi code
60
61 %description samples
62 Sample programs using exempi library.
63
64 %description samples -l pl.UTF-8
65 Przykładowe programy używające biblioteki exempi.
66
67 %prep
68 %setup -q
69
70 %build
71 cp -f /usr/share/automake/config.sub .
72 # configure fails on boost linking check
73 %configure \
74         --disable-silent-rules \
75         %{!?with_tests:--disable-unittest}
76 %{__make}
77
78 %if %{with tests}
79 %{__make} check
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_bindir}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 # obsoleted by pkg-config
90 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libexempi.la
91
92 install samples/source/{dumpmainxmp,dumpxmp,xmpcoverage,xmpfilescoverage} $RPM_BUILD_ROOT%{_bindir}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS COPYING ChangeLog NEWS README TODO
103 %attr(755,root,root) %{_bindir}/exempi
104 %attr(755,root,root) %{_libdir}/libexempi.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libexempi.so.8
106 %{_mandir}/man1/exempi.1*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libexempi.so
111 %{_includedir}/exempi-2.0
112 %{_pkgconfigdir}/exempi-2.0.pc
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libexempi.a
117
118 %files samples
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/dumpmainxmp
121 %attr(755,root,root) %{_bindir}/dumpxmp
122 %attr(755,root,root) %{_bindir}/xmpcoverage
123 %attr(755,root,root) %{_bindir}/xmpfilescoverage
This page took 0.106316 seconds and 3 git commands to generate.