]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
up to 3.1.10-340-gfc2f2394
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  340
7 %define         githash fc2f2394
8 %define         php_min_version 5.5.0
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.1.10
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  89a78328f88d8b27aab1756ebc824b46
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source8:        %{name}-irc.init
26 Source9:        %{name}-irc.sysconfig
27 Source10:       sphinx.crontab
28 Source13:       %{name}-router-postfix.sh
29 Source14:       %{name}.logrotate
30 Source15:       %{name}-lighttpd.conf
31 Source16:       http://www.isocra.com/images/updown2.gif
32 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33 Source17:       %{name}.tmpfiles
34 Patch2:         %{name}-order.patch
35 #Patch3:                group-users.patch
36 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
37 # packaging patches that probably never go upstream
38 Patch100:       %{name}-paths.patch
39 Patch107:       %{name}-gettext.patch
40 Patch108:       autoload.patch
41 # some tests
42 Patch200:       %{name}-fixed-nav.patch
43 URL:            https://wiki.github.com/eventum/eventum/
44 BuildRequires:  gettext-tools
45 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
46 BuildRequires:  rpmbuild(macros) >= 1.654
47 BuildRequires:  sed >= 4.0
48 Requires(postun):       /usr/sbin/groupdel
49 Requires(postun):       /usr/sbin/userdel
50 Requires(pre):  /bin/id
51 Requires(pre):  /usr/bin/getgid
52 Requires(pre):  /usr/sbin/groupadd
53 Requires(pre):  /usr/sbin/useradd
54 Requires:       fonts-TTF-RedHat-liberation
55 Requires:       php(core) >= %{php_min_version}
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-ZendFramework-Config >= 2.4
67 Requires:       php-ZendFramework-Loader >= 2.4
68 Requires:       php-ZendFramework-Mail >= 2.4.9-2
69 Requires:       php-ZendFramework-Mime >= 2.4
70 Requires:       php-ZendFramework-ServiceManager >= 2.4
71 Requires:       php-ZendFramework-Validator >= 2.4
72 Requires:       php-monolog >= 1.17.2
73 Requires:       php-pear-Mail
74 Requires:       php-pear-Mail_Mime
75 Requires:       php-pear-Mail_mimeDecode
76 Requires:       php-pear-Math_Stats
77 Requires:       php-pear-Net_SMTP
78 Requires:       php-pear-Net_Socket
79 Requires:       php-pear-Net_URL
80 Requires:       php-pear-PEAR-core
81 Requires:       php-pear-Text_Diff
82 Requires:       php-psr-Log >= 1.0.0-2
83 Requires:       php-symfony2-Config >= 2.7.7
84 Requires:       php-symfony2-Console >= 2.7.7
85 Requires:       php-symfony2-Filesystem >= 2.7.7
86 Requires:       php-symfony2-HttpFoundation >= 2.7.7
87 Requires:       php-symfony2-OptionsResolver >= 2.7.7
88 Requires:       php-symfony2-Serializer >= 2.7.7
89 Requires:       php-symfony2-Yaml >= 2.7.7
90 Requires:       phplot >= 5.8.0
91 Requires:       webapps
92 Requires:       webserver(access)
93 Requires:       webserver(alias)
94 Requires:       webserver(indexfile)
95 Requires:       webserver(php) >= 4.2.0
96 Suggests:       localedb
97 Suggests:       php(mcrypt)
98 Suggests:       php(openssl)
99 Suggests:       php-pear-Net_LDAP2
100 Suggests:       php-pear-Net_POP3
101 Suggests:       webserver(setenv)
102 Provides:       group(eventum)
103 Provides:       user(eventum)
104 Obsoletes:      eventum-base < 3.0.3-1.305
105 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
106 Obsoletes:      eventum-route-emails < 3.0.8-1.1
107 Obsoletes:      eventum-route-notes < 3.0.8-1.1
108 Conflicts:      logrotate < 3.8.0
109 BuildArch:      noarch
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
113
114 # exclude optional php dependencies
115 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
116
117 %define         _noautoreq      %{_noautophp}
118
119 %define         _libdir         %{_prefix}/lib/%{name}
120 %define         _appdir         %{_datadir}/%{name}
121 %define         _smartydir      %{php_data_dir}/Smarty
122 %define         _webapps        /etc/webapps
123 %define         _webapp         %{name}
124 %define         _webappdir      %{_webapps}/%{_webapp}
125 %define         _sysconfdir     /etc/%{name}
126
127 %description
128 Eventum is a user-friendly and flexible issue tracking system that can
129 be used by a support department to track incoming technical support
130 requests, or by a software development team to quickly organize tasks
131 and bugs.
132
133 %description -l pl.UTF-8
134 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
135 może być używany przez dział obsługi do śledzenia przychodzących żądań
136 obsługi technicznej albo przez zespół tworzący oprogramowanie do
137 szybkiej organizacji zadań i błędów.
138
139 %package setup
140 Summary:        Eventum setup package
141 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
142 Group:          Applications/WWW
143 Requires:       %{name} = %{version}-%{release}
144
145 %description setup
146 Install this package to configure initial Eventum installation. You
147 should uninstall this package when you're done, as it considered
148 insecure to keep the setup files in place.
149
150 %description setup -l pl.UTF-8
151 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
152 pierwszej instalacji. Potem należy go odinstalować, jako że
153 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
154
155 %package doc
156 Summary:        Eventum documentation and Wiki
157 Group:          Documentation
158
159 %description doc
160 Eventum documentation and copy of Wiki.
161
162 %package mail-queue
163 Summary:        Eventum mail queue process
164 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
165 Group:          Applications/WWW
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       crondaemon
168
169 %description mail-queue
170 Beginning with the first release of Eventum, emails are not directly
171 sent out from the various scripts, but rather added to a mail queue
172 table that is processed by a cron job. If an email cannot be sent, it
173 will be marked as such in the mail queue log, and the cron job script
174 will re-try to send it again the next time it runs.
175
176 This package contains the cron job.
177
178 %description mail-queue -l pl.UTF-8
179 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
180 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
181 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
182 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
183 następnym razem.
184
185 Ten pakiet zawiera zadanie dla crona.
186
187 %package mail-download
188 Summary:        Eventum email download
189 Summary(pl.UTF-8):      Ściąganie poczty Eventum
190 Group:          Applications/WWW
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       crondaemon
193
194 %description mail-download
195 In order for Eventum's email integration feature to work, you need to
196 setup a cron job to run the script every so often.
197
198 This package contains the cron job.
199
200 %description mail-download -l pl.UTF-8
201 Aby integracja poczty elektronicznej w Eventum działała, trzeba
202 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
203 często.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package reminder
208 Summary:        Eventum Reminder System
209 Summary(pl.UTF-8):      System przypominania dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       crondaemon
213
214 %description reminder
215 The reminder system was designed with the objective as serving as a
216 safe net for issues that need attention. Depending on what
217 configuration you create, you may have several reminders (or alerts)
218 be sent out whenever an issue needs attention, for whatever parameter
219 you may deem necessary.
220
221 This package contains the cron job.
222
223 %description reminder -l pl.UTF-8
224 System przypominania został zaprojektowany tak, aby służył jako
225 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
226 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
227 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
228 uważać za potrzebny.
229
230 Ten pakiet zawiera zadanie dla crona.
231
232 %package monitor
233 Summary:        Eventum Heartbeat Monitor
234 Summary(pl.UTF-8):      Monitor życia dla Eventum
235 Group:          Applications/WWW
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       crondaemon
238 Requires:       php(posix)
239
240 %description monitor
241 The heartbeat monitor is a feature designed for the administrator that
242 wants to be alerted whenever a common problem in Eventum is detected,
243 like the database server not being available anymore, or maybe when
244 the recommended permissions for certain configuration files are
245 changed.
246
247 Please note that before running the heartbeat monitor, you may need to
248 customize some of the checks to be appropriate for your own system,
249 particularly the permission and file checks on
250 Monitor::checkConfiguration().
251
252 This package contains the cron job.
253
254 %description monitor -l pl.UTF-8
255 Monitor życia to funkcjonalność zaprojektowana dla administratora
256 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
257 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
258 do plików konfiguracyjnych.
259
260 Należy zauważyć, że przed uruchomieniem tego monitora może być
261 konieczne dostosowanie niektórych testów do systemu, w szczególności
262 testów uprawnień i plików w Monitor::checkConfiguration().
263
264 Ten pakiet zawiera zadanie dla crona.
265
266 %package router-postfix
267 Summary:        Eventum Mail Routing - Postfix
268 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
269 Group:          Applications/Mail
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       postfix
272 Provides:       eventum(router)
273 Obsoletes:      eventum(router)
274
275 %description router-postfix
276 This package provides way of routing notes and emails back to Eventum
277 via Postfix.
278
279 The Postfix configuration instructions you can find from
280 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
281
282 %description router-postfix -l pl.UTF-8
283 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
284 przez Postfiksa.
285
286 Opis konfiguracji Postfiksa można znaleźć pod adresem
287 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
288
289 %package irc
290 Summary:        Eventum IRC Notification Bot
291 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
292 Group:          Applications/WWW
293 Requires(post,preun):   /sbin/chkconfig
294 Requires:       %{name} = %{version}-%{release}
295 Requires:       php(pcntl)
296 Requires:       php(sockets)
297 Requires:       php-pear-Net_SmartIRC >= 1.1.9
298 Requires:       rc-scripts >= 0.4.0.18
299
300 %description irc
301 The IRC notification bot is a nice feature for remote teams that want
302 to handle issues and want to have a quick and easy way to get simple
303 notifications. Right now the bot notifies of the following actions:
304 - New Issues
305 - Blocked emails
306 - Issues that got their assignment list changed
307
308 NOTE: You will need to manually edit the bot.php script to set your
309 appropriate preferences, like IRC server and channel that the bot
310 should join.
311
312 %description irc -l pl.UTF-8
313 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
314 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
315 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
316 następujących zdarzeniach:
317 - nowych sprawach
318 - zablokowanych listach
319 - sprawach, dla których zmieniła się lista powiązań
320
321 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
322 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
323
324 %package cli
325 Summary:        Eventum command-line interface
326 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
327 Group:          Applications/WWW
328 Requires:       php(core) >= %{php_min_version}
329 Requires:       php(phar)
330
331 %description cli
332 The Eventum command-line interface allows you to access most of the
333 features of the web interface straight from your command shell.
334
335 %description cli -l pl.UTF-8
336 Interfejs linii poleceń Eventum pozwala na dostęp do większości
337 funkcji interfejsu WWW prosto z linii poleceń powłoki.
338
339 %package sphinx
340 Summary:        Eventum Sphinx Search
341 Group:          Applications/WWW
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       crondaemon
344 Requires:       sphinx
345
346 %description sphinx
347 Sphinx search integration for Eventum.
348
349 This package contains the cron job.
350
351 %prep
352 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
353
354 mv docs/examples .
355
356 # bug fixes / features
357 %{?with_order:%patch2 -p1}
358 #%patch3 -p0
359 #%patch4 -p1
360
361 %{?with_order:cp -p %{SOURCE16} htdocs/images}
362
363 #%patch200 -p1
364
365 # produce default sphinx config
366 # must be run before paths.patch
367 %if 0
368 cat <<'EOF' > config/config.php
369 <?php
370 define('APP_SQL_DBTYPE', 'mysql');
371 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
372 define('APP_SQL_DBPORT', 3306);
373 define('APP_SQL_DBNAME', 'eventum');
374 define('APP_SQL_DBUSER', 'mysql');
375 define('APP_SQL_DBPASS', '');
376 define('APP_TABLE_PREFIX', 'eventum_');
377 EOF
378 php config/sphinx.conf.php > config/sphinx.conf
379 rm config/config.php
380 %endif
381
382 # packaging
383 %patch100 -p1
384 %patch107 -p1
385 %patch108 -p1
386
387 rm htdocs/.htaccess.dist
388
389 mv config/irc_config{.dist.php,.php}
390 rm config/config.dist.php
391
392 # cleanup vendor. keep only needed libraries.
393 # (the rest are packaged with system packages)
394 mv vendor vendor.dist
395 vendor() {
396         local path dir
397         for path; do
398                 dir=$(dirname $path)
399                 test -d vendor/$dir || mkdir -p vendor/$dir
400                 mv vendor.dist/$path vendor/$path
401         done
402 }
403 vendor autoload.php
404 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
405 vendor composer/ClassLoader.php
406 vendor ircmaxell/{random-lib,security-lib}
407 vendor defuse/php-encryption
408 vendor willdurand/email-reply-parser
409 vendor theorchard/monolog-cascade
410 vendor malkusch/lock
411 vendor phpxmlrpc/phpxmlrpc
412
413 # remove backups from patching as we use globs to package files to buildroot
414 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
415
416 %build
417 %{__make} -C localization
418
419 %install
420 rm -rf $RPM_BUILD_ROOT
421 install -d \
422         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
423         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
424         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
425         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
426         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
427         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
428
429 %{__make} install-eventum install-cli install-localization \
430         sysconfdir=%{_webappdir} \
431         localedir=%{_localedir} \
432         DESTDIR=$RPM_BUILD_ROOT
433
434 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
435
436 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
437
438 # unsupported locale
439 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
440
441 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
442 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
443
444 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
445
446 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
447 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
448 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
449 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
450
451 install -d $RPM_BUILD_ROOT/etc/sphinx
452 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
453 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
454
455 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
456 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
457 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
458 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
459 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
460
461 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
462 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
463
464 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
465
466 # postfix router
467 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
468
469 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
470
471 %find_lang %{name}
472
473 %clean
474 rm -rf $RPM_BUILD_ROOT
475
476 %pre
477 %groupadd -g 146 %{name}
478 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
479 %addusertogroup http %{name}
480
481 %post
482 # create empty ghost files
483 # these permissions ensure the logs are write only
484 for a in \
485         errors.log login_attempts.log \
486         eventum.log \
487         auth.log cli.log \
488         irc_bot_error.log irc_bot_smartirc.log \
489 ; do
490         test -f /var/log/%{name}/$a && continue
491         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
492 done
493
494 # run database update if configured
495 test -s %{_webappdir}/config.php && \
496 %{_appdir}/bin/upgrade.php || :
497
498 # nuke Smarty templates cache after upgrade
499 rm -f /var/cache/eventum/*.php
500
501 # Restart webserver on upgrade to get .mo translations reloaded.
502 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
503 %php_webserver_restart
504
505 %preun
506 if [ "$1" = "0" ]; then
507         # nuke cache
508         rm -f /var/cache/eventum/*.php 2>/dev/null || :
509 fi
510
511 %postun
512 if [ "$1" = "0" ]; then
513         %userremove %{name}
514         %groupremove %{name}
515 fi
516
517 %post setup
518 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
519 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
520
521 %postun setup
522 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
523         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
524         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
525 fi
526
527 %post irc
528 /sbin/chkconfig --add eventum-irc
529 %service eventum-irc restart "Eventum IRC Bot"
530
531 %preun irc
532 if [ "$1" = 0 ]; then
533         %service eventum-irc stop
534         /sbin/chkconfig --del eventum-irc
535 fi
536
537 %triggerin -- apache1 < 1.3.37-3, apache1-base
538 %webapp_register apache %{_webapp}
539
540 %triggerun -- apache1 < 1.3.37-3, apache1-base
541 %webapp_unregister apache %{_webapp}
542
543 %triggerin -- apache < 2.2.0, apache-base
544 %webapp_register httpd %{_webapp}
545
546 %triggerun -- apache < 2.2.0, apache-base
547 %webapp_unregister httpd %{_webapp}
548
549 %triggerin -- lighttpd
550 %webapp_register lighttpd %{_webapp}
551
552 %triggerun -- lighttpd
553 %webapp_unregister lighttpd %{_webapp}
554
555 %triggerpostun -- %{name} < 3.0.0-0.2
556 for f in /etc/cron.d/eventum-*; do
557         # crontabs moved to bin
558         %{__sed} -i -e '
559                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
560                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
561                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
562                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
563         ' $f
564 done
565
566 %files -f %{name}.lang
567 %defattr(644,root,root,755)
568 %attr(751,root,root) %dir %{_webappdir}
569 %attr(751,root,root) %dir %{_webappdir}/custom_field
570 %attr(751,root,root) %dir %{_webappdir}/templates
571 %attr(751,root,root) %dir %{_webappdir}/workflow
572 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
573 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
574 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
575 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
576 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
577 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
578 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
579 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
580
581 %dir %attr(711,root,http) /var/log/%{name}
582 %attr(620,root,http) %ghost /var/log/%{name}/*
583 %dir %attr(750,root,root) /var/log/archive/%{name}
584 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
585
586 %dir %{_appdir}
587 %{_appdir}/config
588
589 %dir %{_appdir}/bin
590 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
591 %attr(755,root,root) %{_appdir}/bin/upgrade.php
592
593 %{_appdir}/autoload.php
594 %{_appdir}/globals.php
595 %{_appdir}/init.php
596 %{_appdir}/phinx.php
597 %dir %{_appdir}/htdocs
598 %{_appdir}/htdocs/*.php
599 %{_appdir}/htdocs/*.ico
600 %{_appdir}/htdocs/ajax
601 %{_appdir}/htdocs/css
602 %{_appdir}/htdocs/customer
603 %{_appdir}/htdocs/images
604 %{_appdir}/htdocs/js
605 %{_appdir}/htdocs/manage
606 %{_appdir}/htdocs/reports
607 %{_appdir}/htdocs/rpc
608 %{_appdir}/htdocs/components
609 %{_appdir}/templates
610
611 %dir %{_appdir}/upgrade
612 %{_appdir}/upgrade/*.sql
613 %{_appdir}/upgrade/patches
614
615 %{_appdir}/res
616 %{_appdir}/src
617 %{_appdir}/vendor
618 %dir %{_appdir}/lib
619 %{_appdir}/lib/eventum
620 %exclude %{_appdir}/lib/eventum/class.monitor.php
621
622 %dir %{_libdir}
623
624 %{systemdtmpfilesdir}/%{name}.conf
625
626 %dir /var/lib/%{name}
627 %dir %attr(730,root,http) /var/run/%{name}
628 %dir %attr(730,root,http) /var/cache/%{name}
629
630 # saved mail copies
631 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
632 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
633 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
634
635 %files setup
636 %defattr(644,root,root,755)
637 %{_appdir}/htdocs/setup
638
639 %files doc
640 %defattr(644,root,root,755)
641 %doc docs/*
642 %{_examplesdir}/%{name}-%{version}
643
644 %files mail-queue
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
647 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
648 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
649
650 %files mail-download
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_appdir}/bin/download_emails.php
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
654
655 %files reminder
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
659
660 %files monitor
661 %defattr(644,root,root,755)
662 %{_appdir}/lib/eventum/class.monitor.php
663 %attr(755,root,root) %{_appdir}/bin/monitor.php
664 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
665
666 %files router-postfix
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/router-postfix
669
670 %files irc
671 %defattr(644,root,root,755)
672 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
673 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
674 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
675 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
676
677 %files cli
678 %defattr(644,root,root,755)
679 %doc cli/eventumrc
680 %attr(755,root,root) %{_bindir}/%{name}
681
682 %files sphinx
683 %defattr(644,root,root,755)
684 %{_webappdir}/sphinx.conf.php
685 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
686 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.080192 seconds and 4 git commands to generate.