]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
drop unsupported locale
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  285
7 #define         githash 72865b8
8 %define         php_min_version 5.3.3
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.1
14 Release:        %{?subver:0.%{subver}.}%{rel}
15 License:        GPL v2
16 Group:          Applications/WWW
17 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  8c9d1554923d6b59a29deb333792745d
19 #Source0:       %{name}-%{version}-%{subver}-g%{githash}.tar.gz
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source7:        %{name}-irc.php
27 Source8:        %{name}-irc.init
28 Source9:        %{name}-irc.sysconfig
29 Source10:       sphinx.crontab
30 Source13:       %{name}-router-postfix.sh
31 Source14:       %{name}.logrotate
32 Source15:       %{name}-lighttpd.conf
33 Source16:       http://www.isocra.com/images/updown2.gif
34 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
35 Source17:       %{name}.tmpfiles
36 #Patch0:                %{name}-lf.patch
37 Patch2:         %{name}-order.patch
38 #Patch3:                group-users.patch
39 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
40 # packaging patches that probably never go upstream
41 Patch100:       %{name}-paths.patch
42 Patch101:       %{name}-cvs-config.patch
43 Patch105:       %{name}-bot-reconnect.patch
44 Patch107:       %{name}-gettext.patch
45 # some tests
46 Patch200:       %{name}-fixed-nav.patch
47 URL:            http://eventum.mysql.org/
48 BuildRequires:  /usr/bin/php
49 BuildRequires:  gettext-devel
50 BuildRequires:  php(core) >= %{php_min_version}
51 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
52 BuildRequires:  rpmbuild(macros) >= 1.654
53 BuildRequires:  sed >= 4.0
54 Requires:       %{name}-base = %{version}-%{release}
55 Requires:       fonts-TTF-RedHat-liberation
56 Requires:       php(core) >= %{php_min_version}
57 Requires:       php(filter)
58 Requires:       php(iconv)
59 Requires:       php(imap)
60 Requires:       php(json)
61 Requires:       php(mbstring)
62 Requires:       php(mysqli)
63 Requires:       php(pcre)
64 Requires:       php(session)
65 Requires:       php-Smarty >= 3.1
66 Requires:       php-Smarty-plugin-gettext
67 Requires:       php-pear-DB
68 Requires:       php-pear-Date
69 Requires:       php-pear-Mail
70 Requires:       php-pear-Mail_Mime
71 Requires:       php-pear-Mail_mimeDecode
72 Requires:       php-pear-Math_Stats
73 Requires:       php-pear-Net_DIME
74 Requires:       php-pear-Net_SMTP
75 Requires:       php-pear-Net_Socket
76 Requires:       php-pear-Net_URL
77 Requires:       php-pear-Net_UserAgent_Detect
78 Requires:       php-pear-PEAR-core
79 Requires:       php-pear-Text_Diff
80 Requires:       php-pear-XML_RPC
81 Requires:       phplot >= 5.8.0
82 Requires:       webapps
83 Requires:       webserver(access)
84 Requires:       webserver(alias)
85 Requires:       webserver(indexfile)
86 Requires:       webserver(php) >= 4.2.0
87 Suggests:       localedb
88 Suggests:       php-pear-Net_LDAP2
89 Conflicts:      logrotate < 3.8.0
90 BuildArch:      noarch
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
94
95 # exclude optional php dependencies
96 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
97
98 %define         _noautoreq      %{_noautophp}
99
100 %define         _libdir         %{_prefix}/lib/%{name}
101 %define         _appdir         %{_datadir}/%{name}
102 %define         _smartydir      %{php_data_dir}/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs. Eventum is used by the MySQL AB Technical Support team, and
113 has allowed us to dramatically improve our response times.
114
115 %description -l pl.UTF-8
116 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
117 może być używany przez dział obsługi do śledzenia przychodzących żądań
118 obsługi technicznej albo przez zespół tworzący oprogramowanie do
119 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
120 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
121 reakcji.
122
123 %package base
124 Summary:        Eventum base package
125 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
126 Group:          Applications/WWW
127 Requires(postun):       /usr/sbin/groupdel
128 Requires(postun):       /usr/sbin/userdel
129 Requires(pre):  /bin/id
130 Requires(pre):  /usr/bin/getgid
131 Requires(pre):  /usr/sbin/groupadd
132 Requires(pre):  /usr/sbin/useradd
133 Provides:       group(eventum)
134 Provides:       user(eventum)
135
136 %description base
137 This package contains base directory structure for Eventum.
138
139 %description base -l pl.UTF-8
140 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
141
142 %package setup
143 Summary:        Eventum setup package
144 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
145 Group:          Applications/WWW
146 Requires:       %{name} = %{version}-%{release}
147
148 %description setup
149 Install this package to configure initial Eventum installation. You
150 should uninstall this package when you're done, as it considered
151 insecure to keep the setup files in place.
152
153 %description setup -l pl.UTF-8
154 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
155 pierwszej instalacji. Potem należy go odinstalować, jako że
156 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
157
158 %package mail-queue
159 Summary:        Eventum mail queue process
160 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
161 Group:          Applications/WWW
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       crondaemon
164
165 %description mail-queue
166 Beginning with the first release of Eventum, emails are not directly
167 sent out from the various scripts, but rather added to a mail queue
168 table that is processed by a cron job. If an email cannot be sent, it
169 will be marked as such in the mail queue log, and the cron job script
170 will re-try to send it again the next time it runs.
171
172 This package contains the cron job.
173
174 %description mail-queue -l pl.UTF-8
175 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
176 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
177 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
178 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
179 następnym razem.
180
181 Ten pakiet zawiera zadanie dla crona.
182
183 %package mail-download
184 Summary:        Eventum email download
185 Summary(pl.UTF-8):      Ściąganie poczty Eventum
186 Group:          Applications/WWW
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       crondaemon
189
190 %description mail-download
191 In order for Eventum's email integration feature to work, you need to
192 setup a cron job to run the script every so often.
193
194 This package contains the cron job.
195
196 %description mail-download -l pl.UTF-8
197 Aby integracja poczty elektronicznej w Eventum działała, trzeba
198 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
199 często.
200
201 Ten pakiet zawiera zadanie dla crona.
202
203 %package reminder
204 Summary:        Eventum Reminder System
205 Summary(pl.UTF-8):      System przypominania dla Eventum
206 Group:          Applications/WWW
207 Requires:       %{name} = %{version}-%{release}
208 Requires:       crondaemon
209
210 %description reminder
211 The reminder system was designed with the objective as serving as a
212 safe net for issues that need attention. Depending on what
213 configuration you create, you may have several reminders (or alerts)
214 be sent out whenever an issue needs attention, for whatever parameter
215 you may deem necessary.
216
217 This package contains the cron job.
218
219 %description reminder -l pl.UTF-8
220 System przypominania został zaprojektowany tak, aby służył jako
221 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
222 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
223 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
224 uważać za potrzebny.
225
226 Ten pakiet zawiera zadanie dla crona.
227
228 %package monitor
229 Summary:        Eventum Heartbeat Monitor
230 Summary(pl.UTF-8):      Monitor życia dla Eventum
231 Group:          Applications/WWW
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       crondaemon
234 Requires:       php(posix)
235
236 %description monitor
237 The heartbeat monitor is a feature designed for the administrator that
238 wants to be alerted whenever a common problem in Eventum is detected,
239 like the database server not being available anymore, or maybe when
240 the recommended permissions for certain configuration files are
241 changed.
242
243 Please note that before running the heartbeat monitor, you may need to
244 customize some of the checks to be appropriate for your own system,
245 particularly the permission and file checks on
246 Monitor::checkConfiguration().
247
248 This package contains the cron job.
249
250 %description monitor -l pl.UTF-8
251 Monitor życia to funkcjonalność zaprojektowana dla administratora
252 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
253 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
254 do plików konfiguracyjnych.
255
256 Należy zauważyć, że przed uruchomieniem tego monitora może być
257 konieczne dostosowanie niektórych testów do systemu, w szczególności
258 testów uprawnień i plików w Monitor::checkConfiguration().
259
260 Ten pakiet zawiera zadanie dla crona.
261
262 %package route-drafts
263 Summary:        Eventum Draft Routing
264 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
265 Group:          Applications/WWW
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       eventum(router)
268
269 %description route-drafts
270 The draft routing feature is used to automatically associate a thread
271 of drafts into an Eventum issue. By setting up Postfix to deliver
272 emails sent to a specific address (usually draft-<number>@<domain>) to
273 the above script, users are able to send drafts written in their mail
274 client to be stored in Eventum. These drafts will NOT broadcasted to
275 the notification list.
276
277 %description route-drafts -l pl.UTF-8
278 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
279 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
280 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
281 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
282 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
283 na listę powiadomień.
284
285 %package route-emails
286 Summary:        Eventum Email Routing
287 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
288 Group:          Applications/WWW
289 Requires:       %{name} = %{version}-%{release}
290 Requires:       eventum(router)
291
292 %description route-emails
293 The email routing feature is used to automatically associate a thread
294 of emails into an Eventum issue. By setting up Postfix to deliver
295 emails sent to a specific address (usually issue-<number>@<domain>) to
296 the above script, users are able to use their email clients to reply
297 to emails coming from Eventum, and those replies will be automatically
298 associated with the issue and broadcasted to the entire notification
299 list.
300
301 %description route-emails -l pl.UTF-8
302 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
303 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
304 aby dostarczał listy wysyłane na pewien adres (zwykle
305 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
306 używać klientów pocztowych do odpowiadania na listy przychodzące z
307 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
308 rozprowadzane do całej listy ogłoszeniowej.
309
310 %package route-notes
311 Summary:        Eventum Note Routing
312 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
313 Group:          Applications/WWW
314 Requires:       %{name} = %{version}-%{release}
315 Requires:       eventum(router)
316
317 %description route-notes
318 The note routing feature is used to automatically associate a thread
319 of notes into an Eventum issue. By setting up Postfix to deliver
320 emails sent to a specific address (usually note-<number>@<domain>) to
321 the above script, users are able to use their email clients to reply
322 to internal notes coming from Eventum, and those replies will be
323 automatically associated with the issue and broadcasted to the
324 notification list staff members.
325
326 %description route-notes -l pl.UTF-8
327 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
328 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
329 dostarczał listy wysyłane na pewien adres (zwykle
330 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
331 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
332 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
333 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
334
335 %package router-postfix
336 Summary:        Eventum Mail Routing - Postfix
337 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
338 Group:          Applications/Mail
339 Requires:       %{name} = %{version}-%{release}
340 Requires:       postfix
341 Provides:       eventum(router)
342 Obsoletes:      eventum(router)
343
344 %description router-postfix
345 This package provides way of routing notes and emails back to Eventum
346 via Postfix.
347
348 The Postfix configuration instructions you can find from
349 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
350
351 %description router-postfix -l pl.UTF-8
352 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
353 przez Postfiksa.
354
355 Opis konfiguracji Postfiksa można znaleźć pod adresem
356 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
357
358 %package irc
359 Summary:        Eventum IRC Notification Bot
360 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
361 Group:          Applications/WWW
362 Requires(post,preun):   /sbin/chkconfig
363 Requires:       %{name} = %{version}-%{release}
364 Requires:       php(sockets)
365 Requires:       php-pear-Net_SmartIRC
366 Requires:       rc-scripts >= 0.4.0.18
367
368 %description irc
369 The IRC notification bot is a nice feature for remote teams that want
370 to handle issues and want to have a quick and easy way to get simple
371 notifications. Right now the bot notifies of the following actions:
372 - New Issues
373 - Blocked emails
374 - Issues that got their assignment list changed
375
376 NOTE: You will need to manually edit the bot.php script to set your
377 appropriate preferences, like IRC server and channel that the bot
378 should join.
379
380 %description irc -l pl.UTF-8
381 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
382 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
383 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
384 następujących zdarzeniach:
385 - nowych sprawach
386 - zablokowanych listach
387 - sprawach, dla których zmieniła się lista powiązań
388
389 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
390 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
391
392 %package cli
393 Summary:        Eventum command-line interface
394 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
395 Group:          Applications/WWW
396 Requires:       %{name}-base = %{version}-%{release}
397 Requires:       php(core) >= %{php_min_version}
398 Requires:       php(phar)
399 Requires:       php-pear-XML_RPC
400
401 %description cli
402 The Eventum command-line interface allows you to access most of the
403 features of the web interface straight from your command shell.
404
405 %description cli -l pl.UTF-8
406 Interfejs linii poleceń Eventum pozwala na dostęp do większości
407 funkcji interfejsu WWW prosto z linii poleceń powłoki.
408
409 %package scm
410 Summary:        Eventum SCM integration
411 Summary(pl.UTF-8):      Integracja SCM dla Eventum
412 Group:          Applications/WWW
413 Requires:       php(core) >= %{php_min_version}
414 Requires:       php(json)
415 Requires:       php(pcre)
416 Requires:       php(spl)
417 Suggests:       cvs
418 Suggests:       git-core
419 Suggests:       php(openssl)
420 Suggests:       subversion
421
422 %description scm
423 This feature allows your software development teams to integrate your
424 Source Control Management system with your Issue Tracking System.
425
426 The integration is implemented in such a way that it will be forward
427 compatible with pretty much any SCM system, such as CVS.
428
429 For installation see
430 </eventum/help.php?topic=scm_integration_installation>.
431
432 %description scm -l pl.UTF-8
433 Ten pakiet pozwala zespołom programistów na integrację systemu
434 zarządzania źródłami (SCM - Source Control Management) z systemem
435 śledzenia spraw.
436
437 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
438 prawie każdym systemem SCM, jak np. CVS.
439
440 Szczegóły na temat instalacji można przeczytać pod
441 </eventum/help.php?topic=scm_integration_installation>.
442
443 %package sphinx
444 Summary:        Eventum Sphinx Search
445 Group:          Applications/WWW
446 Requires:       %{name} = %{version}-%{release}
447 Requires:       crondaemon
448 Requires:       sphinx
449
450 %description sphinx
451 Sphinx search integration for Eventum.
452
453 This package contains the cron job.
454
455 %prep
456 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
457
458 mv docs/examples .
459
460 # GPL v2
461 rm docs/COPYING
462
463 # bug fixes / features
464 #%patch0 -p1
465 %{?with_order:%patch2 -p1}
466 #%patch3 -p0
467 #%patch4 -p1
468
469 %{?with_order:cp -p %{SOURCE16} htdocs/images}
470
471 #%patch200 -p1
472
473 # produce default sphinx config
474 # must be run before paths.patch
475 %if 0
476 cat <<'EOF' > config/config.php
477 <?php
478 define('APP_SQL_DBTYPE', 'mysql');
479 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
480 define('APP_SQL_DBPORT', 3306);
481 define('APP_SQL_DBNAME', 'eventum');
482 define('APP_SQL_DBUSER', 'mysql');
483 define('APP_SQL_DBPASS', '');
484 define('APP_TABLE_PREFIX', 'eventum_');
485 EOF
486 php config/sphinx.conf.php > config/sphinx.conf
487 rm -f config/config.php
488 %endif
489
490 # packaging
491 %patch100 -p1
492 %patch101 -p1
493 %patch105 -p1
494 %patch107 -p1
495
496 %{__sed} -i -e "
497 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
498 " upgrade/{*/,}*.php
499
500 # remove backups from patching as we use globs to package files to buildroot
501 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
502
503 %build
504 %{__make} -C localization
505
506 %install
507 rm -rf $RPM_BUILD_ROOT
508 install -d \
509         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
510         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
511         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
512         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
513         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
514         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
515         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
516
517 %{__make} install-eventum install-cli install-irc install-scm install-localization \
518         sysconfdir=%{_webappdir} \
519         localedir=%{_localedir} \
520         DESTDIR=$RPM_BUILD_ROOT
521
522 # unsupported locale
523 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
524
525 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
526 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
527
528 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
529
530 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
531 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
532 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
533 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
534
535 install -d $RPM_BUILD_ROOT/etc/sphinx
536 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
537 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
538
539 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
540 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
541 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
542 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
543 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
544
545 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
546
547 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
548 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
549
550 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
551
552 # postfix router
553 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
554
555 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
556
557 %find_lang %{name}
558
559 # scm
560 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
561
562 %clean
563 rm -rf $RPM_BUILD_ROOT
564
565 %pre
566 %addusertogroup http %{name}
567
568 %post
569 # greate empty ghost files
570 for a in cli.log errors.log irc_bot.log login_attempts.log; do
571         if [ ! -f /var/log/%{name}/$a ]; then
572                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
573         fi
574 done
575
576 # run database update if configured
577 test -s %{_webappdir}/config.php && \
578 %{_appdir}/upgrade/update-database.php || :
579
580 # nuke Smarty templates cache after upgrade
581 rm -f /var/cache/eventum/*.php
582
583 # Restart webserver on upgrade to get .mo translations reloaded.
584 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
585 %php_webserver_restart
586
587 %preun
588 if [ "$1" = "0" ]; then
589         # nuke cache
590         rm -f /var/cache/eventum/*.php 2>/dev/null || :
591 fi
592
593 %pre base
594 %groupadd -P %{name}-base -g 146 %{name}
595 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
596
597 %postun base
598 if [ "$1" = "0" ]; then
599         %userremove %{name}
600         %groupremove %{name}
601 fi
602
603 %post setup
604 chmod 660 %{_webappdir}/{config,private_key}.php
605 chown root:http %{_webappdir}/{config,private_key}.php
606
607 %postun setup
608 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
609         chmod 640 %{_webappdir}/{config,private_key}.php
610         chown root:http %{_webappdir}/{config,private_key}.php
611 fi
612
613 %post irc
614 /sbin/chkconfig --add eventum-irc
615 %service eventum-irc restart "Eventum IRC Bot"
616
617 %preun irc
618 if [ "$1" = 0 ]; then
619         %service eventum-irc stop
620         /sbin/chkconfig --del eventum-irc
621 fi
622
623 %triggerin -- apache1 < 1.3.37-3, apache1-base
624 %webapp_register apache %{_webapp}
625
626 %triggerun -- apache1 < 1.3.37-3, apache1-base
627 %webapp_unregister apache %{_webapp}
628
629 %triggerin -- apache < 2.2.0, apache-base
630 %webapp_register httpd %{_webapp}
631
632 %triggerun -- apache < 2.2.0, apache-base
633 %webapp_unregister httpd %{_webapp}
634
635 %triggerin -- lighttpd
636 %webapp_register lighttpd %{_webapp}
637
638 %triggerun -- lighttpd
639 %webapp_unregister lighttpd %{_webapp}
640
641 %triggerpostun -- %{name} < 3.0.0-0.2
642 for f in /etc/cron.d/eventum-*; do
643         # crontabs moved to bin
644         %{__sed} -i -e '
645                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
646                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
647                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
648                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
649         ' $f
650 done
651
652 %files -f %{name}.lang
653 %defattr(644,root,root,755)
654 %doc docs/*
655 %attr(751,root,root) %dir %{_webappdir}
656 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
657 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
659 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
660 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
661 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
662 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
663
664 %dir %attr(731,root,http) /var/log/%{name}
665 %attr(620,root,http) %ghost /var/log/%{name}/*
666 %dir %attr(750,root,root) /var/log/archive/%{name}
667 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
668
669 %dir %{_appdir}/bin
670 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
671
672 %{_appdir}/autoload.php
673 %{_appdir}/init.php
674 %dir %{_appdir}/htdocs
675 %{_appdir}/htdocs/*.php
676 %{_appdir}/htdocs/*.ico
677 %{_appdir}/htdocs/ajax
678 %{_appdir}/htdocs/css
679 %{_appdir}/htdocs/customer
680 %{_appdir}/htdocs/images
681 %{_appdir}/htdocs/js
682 %{_appdir}/htdocs/manage
683 %{_appdir}/htdocs/misc
684 %{_appdir}/htdocs/reports
685 %{_appdir}/htdocs/rpc
686 %{_appdir}/htdocs/components
687 %{_appdir}/templates
688
689 %dir %{_appdir}/upgrade
690 %{_appdir}/upgrade/flush_compiled_templates.php
691 %{_appdir}/upgrade/*.sql
692 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
693 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
694 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
695 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
696 %{_appdir}/upgrade/patches
697
698 %dir %{_appdir}/lib
699 %{_appdir}/lib/eventum
700 %exclude %{_appdir}/lib/eventum/class.monitor.php
701
702 %{_examplesdir}/%{name}-%{version}
703
704 %{systemdtmpfilesdir}/%{name}.conf
705 %dir %attr(730,root,http) /var/run/%{name}
706 %dir %attr(730,root,http) /var/cache/%{name}
707
708 %files base
709 %defattr(644,root,root,755)
710 %attr(751,root,root) %dir %{_sysconfdir}
711 %dir %{_libdir}
712 %dir %{_appdir}
713 %dir /var/lib/%{name}
714 # saved mail copies
715 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
716 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
717 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
718
719 %files setup
720 %defattr(644,root,root,755)
721 %{_appdir}/htdocs/setup
722
723 %files mail-queue
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
726 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
727
728 %files mail-download
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_appdir}/bin/download_emails.php
731 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
732
733 %files reminder
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
737
738 %files monitor
739 %defattr(644,root,root,755)
740 %{_appdir}/lib/eventum/class.monitor.php
741 %attr(755,root,root) %{_appdir}/bin/monitor.php
742 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
743
744 %files route-drafts
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
747
748 %files route-emails
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_appdir}/bin/route_emails.php
751
752 %files route-notes
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_appdir}/bin/route_notes.php
755
756 %files router-postfix
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/router-postfix
759
760 %files irc
761 %defattr(644,root,root,755)
762 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
763 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
764 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
765 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
766
767 %files cli
768 %defattr(644,root,root,755)
769 %doc cli/eventumrc
770 %attr(755,root,root) %{_bindir}/%{name}
771
772 %files scm
773 %defattr(644,root,root,755)
774 %attr(751,root,root) %dir %{_sysconfdir}
775 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
776 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
777 %attr(755,root,root) %{_sbindir}/eventum-git-hook
778 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
779 %attr(755,root,root) %{_sbindir}/helpers.php
780
781 %files sphinx
782 %defattr(644,root,root,755)
783 %{_webappdir}/sphinx.conf.php
784 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
785 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.083225 seconds and 3 git commands to generate.