]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
use git snapshot 2.3.3-126-g42a2050
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 %define         php_min_version 5.1.2
13 %define         subver  126
14 %define         githash 42a2050
15 %define         rel             4.1
16 %include        /usr/lib/rpm/macros.php
17 Summary:        Eventum Issue / Bug tracking system
18 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
19 Name:           eventum
20 Version:        2.3.3
21 #Release:       %{rel}
22 Release:        %{rel}.%{subver}.g%{githash}
23 License:        GPL
24 Group:          Applications/WWW
25 #Source0:       http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
26 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
27 # Source0-md5:  166b934b2eccd6d70caa2202f44185b0
28 Source1:        %{name}-apache.conf
29 Source2:        %{name}-mail-queue.cron
30 Source3:        %{name}-mail-download.cron
31 Source4:        %{name}-reminder.cron
32 Source5:        %{name}-monitor.cron
33 Source6:        %{name}-cvs.php
34 Source7:        %{name}-irc.php
35 Source8:        %{name}-irc.init
36 Source9:        %{name}-irc.sysconfig
37 Source10:       sphinx.crontab
38 Source13:       %{name}-router-postfix.sh
39 Source14:       %{name}.logrotate
40 Source15:       %{name}-lighttpd.conf
41 Source16:       http://www.isocra.com/images/updown2.gif
42 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
43 Source17:       %{name}.tmpfiles
44 Patch0:         %{name}-lf.patch
45 Patch2:         %{name}-order.patch
46 Patch3:         group-users.patch
47 Patch4:         https://github.com/glensc/eventum/compare/cf_escape.patch
48 # Patch4-md5:   d3d7865b785ebe3b05b18e2005cf843c
49 # packaging patches that probably never go upstream
50 Patch100:       %{name}-paths.patch
51 Patch101:       %{name}-cvs-config.patch
52 Patch105:       %{name}-bot-reconnect.patch
53 Patch107:       %{name}-gettext.patch
54 # some tests
55 Patch200:       %{name}-fixed-nav.patch
56 URL:            http://eventum.mysql.org/
57 BuildRequires:  gettext-devel
58 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
59 BuildRequires:  rpmbuild(macros) >= 1.461
60 BuildRequires:  sed >= 4.0
61 Requires:       %{name}-base = %{version}-%{release}
62 Requires:       Smarty >= 2.6.10-4
63 Requires:       php(core) >= %{php_min_version}
64 Requires:       php-filter
65 Requires:       php-gd
66 Requires:       php-iconv
67 Requires:       php-imap
68 Requires:       php-json
69 Requires:       php-mbstring
70 Requires:       php-mysql
71 Requires:       php-pcre
72 Requires:       php-pear-DB
73 Requires:       php-pear-Date
74 Requires:       php-pear-Mail
75 Requires:       php-pear-Mail_Mime
76 Requires:       php-pear-Mail_mimeDecode
77 Requires:       php-pear-Math_Stats
78 Requires:       php-pear-Net_DIME
79 Requires:       php-pear-Net_SMTP
80 Requires:       php-pear-Net_Socket
81 Requires:       php-pear-Net_URL
82 Requires:       php-pear-Net_UserAgent_Detect
83 Requires:       php-pear-PEAR-core
84 Requires:       php-pear-Text_Diff
85 Requires:       php-pear-XML_RPC
86 Requires:       php-session
87 Requires:       smarty-gettext
88 Requires:       webapps
89 Requires:       webserver(access)
90 Requires:       webserver(alias)
91 Requires:       webserver(indexfile)
92 Requires:       webserver(php) >= 4.2.0
93 Suggests:       localedb
94 Suggests:       php-pear-Net_LDAP2
95 Conflicts:      logrotate < 3.8.0
96 BuildArch:      noarch
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define         _noautopear     pear(../init.php) pear(init.php) pear(/usr/share/eventum/init.php) pear(/etc/webapps/.*) pear(%{_appdir}/.*) pear(jpgraph_dir.php) pear(.*Smarty.class.php) pear(Services/JSON.php) pear(class.date_helper.php) pear(sphinxapi.php) pear(Net/LDAP2.php)
100
101 # exclude optional php dependencies
102 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
103
104 %define         _noautoreq      %{_noautophp} %{_noautopear}
105
106 %define         _libdir         %{_prefix}/lib/%{name}
107 %define         _appdir         %{_datadir}/%{name}
108 %define         _smartydir      %{php_data_dir}/Smarty
109 %define         _webapps        /etc/webapps
110 %define         _webapp         %{name}
111 %define         _webappdir      %{_webapps}/%{_webapp}
112 %define         _sysconfdir     /etc/%{name}
113
114 %description
115 Eventum is a user-friendly and flexible issue tracking system that can
116 be used by a support department to track incoming technical support
117 requests, or by a software development team to quickly organize tasks
118 and bugs. Eventum is used by the MySQL AB Technical Support team, and
119 has allowed us to dramatically improve our response times.
120
121 %description -l pl.UTF-8
122 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
123 może być używany przez dział obsługi do śledzenia przychodzących żądań
124 obsługi technicznej albo przez zespół tworzący oprogramowanie do
125 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
126 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
127 reakcji.
128
129 %package base
130 Summary:        Eventum base package
131 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
132 Group:          Applications/WWW
133 Requires(postun):       /usr/sbin/groupdel
134 Requires(postun):       /usr/sbin/userdel
135 Requires(pre):  /bin/id
136 Requires(pre):  /usr/bin/getgid
137 Requires(pre):  /usr/sbin/groupadd
138 Requires(pre):  /usr/sbin/useradd
139 Provides:       group(eventum)
140 Provides:       user(eventum)
141
142 %description base
143 This package contains base directory structure for Eventum.
144
145 %description base -l pl.UTF-8
146 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
147
148 %package setup
149 Summary:        Eventum setup package
150 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
151 Group:          Applications/WWW
152 Requires:       %{name} = %{version}-%{release}
153
154 %description setup
155 Install this package to configure initial Eventum installation. You
156 should uninstall this package when you're done, as it considered
157 insecure to keep the setup files in place.
158
159 %description setup -l pl.UTF-8
160 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
161 pierwszej instalacji. Potem należy go odinstalować, jako że
162 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
163
164 %package mail-queue
165 Summary:        Eventum mail queue process
166 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
167 Group:          Applications/WWW
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       crondaemon
170
171 %description mail-queue
172 Beginning with the first release of Eventum, emails are not directly
173 sent out from the various scripts, but rather added to a mail queue
174 table that is processed by a cron job. If an email cannot be sent, it
175 will be marked as such in the mail queue log, and the cron job script
176 will re-try to send it again the next time it runs.
177
178 This package contains the cron job.
179
180 %description mail-queue -l pl.UTF-8
181 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
182 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
183 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
184 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
185 następnym razem.
186
187 Ten pakiet zawiera zadanie dla crona.
188
189 %package mail-download
190 Summary:        Eventum email download
191 Summary(pl.UTF-8):      Ściąganie poczty Eventum
192 Group:          Applications/WWW
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       crondaemon
195
196 %description mail-download
197 In order for Eventum's email integration feature to work, you need to
198 setup a cron job to run the script every so often.
199
200 This package contains the cron job.
201
202 %description mail-download -l pl.UTF-8
203 Aby integracja poczty elektronicznej w Eventum działała, trzeba
204 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
205 często.
206
207 Ten pakiet zawiera zadanie dla crona.
208
209 %package reminder
210 Summary:        Eventum Reminder System
211 Summary(pl.UTF-8):      System przypominania dla Eventum
212 Group:          Applications/WWW
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       crondaemon
215
216 %description reminder
217 The reminder system was designed with the objective as serving as a
218 safe net for issues that need attention. Depending on what
219 configuration you create, you may have several reminders (or alerts)
220 be sent out whenever an issue needs attention, for whatever parameter
221 you may deem necessary.
222
223 This package contains the cron job.
224
225 %description reminder -l pl.UTF-8
226 System przypominania został zaprojektowany tak, aby służył jako
227 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
228 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
229 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
230 uważać za potrzebny.
231
232 Ten pakiet zawiera zadanie dla crona.
233
234 %package monitor
235 Summary:        Eventum Heartbeat Monitor
236 Summary(pl.UTF-8):      Monitor życia dla Eventum
237 Group:          Applications/WWW
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       crondaemon
240 Requires:       php-posix
241
242 %description monitor
243 The heartbeat monitor is a feature designed for the administrator that
244 wants to be alerted whenever a common problem in Eventum is detected,
245 like the database server not being available anymore, or maybe when
246 the recommended permissions for certain configuration files are
247 changed.
248
249 Please note that before running the heartbeat monitor, you may need to
250 customize some of the checks to be appropriate for your own system,
251 particularly the permission and file checks on
252 Monitor::checkConfiguration().
253
254 This package contains the cron job.
255
256 %description monitor -l pl.UTF-8
257 Monitor życia to funkcjonalność zaprojektowana dla administratora
258 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
259 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
260 do plików konfiguracyjnych.
261
262 Należy zauważyć, że przed uruchomieniem tego monitora może być
263 konieczne dostosowanie niektórych testów do systemu, w szczególności
264 testów uprawnień i plików w Monitor::checkConfiguration().
265
266 Ten pakiet zawiera zadanie dla crona.
267
268 %package route-drafts
269 Summary:        Eventum Draft Routing
270 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
271 Group:          Applications/WWW
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       eventum(router)
274
275 %description route-drafts
276 The draft routing feature is used to automatically associate a thread
277 of drafts into an Eventum issue. By setting up Postfix to deliver
278 emails sent to a specific address (usually draft-<number>@<domain>) to
279 the above script, users are able to send drafts written in their mail
280 client to be stored in Eventum. These drafts will NOT broadcasted to
281 the notification list.
282
283 %description route-drafts -l pl.UTF-8
284 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
285 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
286 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
287 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
288 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
289 na listę powiadomień.
290
291 %package route-emails
292 Summary:        Eventum Email Routing
293 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
294 Group:          Applications/WWW
295 Requires:       %{name} = %{version}-%{release}
296 Requires:       eventum(router)
297
298 %description route-emails
299 The email routing feature is used to automatically associate a thread
300 of emails into an Eventum issue. By setting up Postfix to deliver
301 emails sent to a specific address (usually issue-<number>@<domain>) to
302 the above script, users are able to use their email clients to reply
303 to emails coming from Eventum, and those replies will be automatically
304 associated with the issue and broadcasted to the entire notification
305 list.
306
307 %description route-emails -l pl.UTF-8
308 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
309 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
310 aby dostarczał listy wysyłane na pewien adres (zwykle
311 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
312 używać klientów pocztowych do odpowiadania na listy przychodzące z
313 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
314 rozprowadzane do całej listy ogłoszeniowej.
315
316 %package route-notes
317 Summary:        Eventum Note Routing
318 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
319 Group:          Applications/WWW
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       eventum(router)
322
323 %description route-notes
324 The note routing feature is used to automatically associate a thread
325 of notes into an Eventum issue. By setting up Postfix to deliver
326 emails sent to a specific address (usually note-<number>@<domain>) to
327 the above script, users are able to use their email clients to reply
328 to internal notes coming from Eventum, and those replies will be
329 automatically associated with the issue and broadcasted to the
330 notification list staff members.
331
332 %description route-notes -l pl.UTF-8
333 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
334 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
335 dostarczał listy wysyłane na pewien adres (zwykle
336 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
337 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
338 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
339 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
340
341 %package router-postfix
342 Summary:        Eventum Mail Routing - Postfix
343 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
344 Group:          Applications/Mail
345 Requires:       %{name} = %{version}-%{release}
346 Requires:       postfix
347 Provides:       eventum(router)
348 Obsoletes:      eventum(router)
349
350 %description router-postfix
351 This package provides way of routing notes and emails back to Eventum
352 via Postfix.
353
354 The Postfix configuration instructions you can find from
355 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
356
357 %description router-postfix -l pl.UTF-8
358 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
359 przez Postfiksa.
360
361 Opis konfiguracji Postfiksa można znaleźć pod adresem
362 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
363
364 %package irc
365 Summary:        Eventum IRC Notification Bot
366 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
367 Group:          Applications/WWW
368 Requires(post,preun):   /sbin/chkconfig
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       php-pear-Net_SmartIRC
371 Requires:       php-sockets
372 Requires:       rc-scripts >= 0.4.0.18
373
374 %description irc
375 The IRC notification bot is a nice feature for remote teams that want
376 to handle issues and want to have a quick and easy way to get simple
377 notifications. Right now the bot notifies of the following actions:
378 - New Issues
379 - Blocked emails
380 - Issues that got their assignment list changed
381
382 NOTE: You will need to manually edit the bot.php script to set your
383 appropriate preferences, like IRC server and channel that the bot
384 should join.
385
386 %description irc -l pl.UTF-8
387 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
388 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
389 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
390 następujących zdarzeniach:
391 - nowych sprawach
392 - zablokowanych listach
393 - sprawach, dla których zmieniła się lista powiązań
394
395 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
396 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
397
398 %package cli
399 Summary:        Eventum command-line interface
400 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
401 Group:          Applications/WWW
402 Requires:       %{name}-base = %{version}-%{release}
403 Requires:       php(core) >= %{php_min_version}
404 Requires:       php-cli
405 Requires:       php-pear-XML_RPC
406
407 %description cli
408 The Eventum command-line interface allows you to access most of the
409 features of the web interface straight from your command shell.
410
411 %description cli -l pl.UTF-8
412 Interfejs linii poleceń Eventum pozwala na dostęp do większości
413 funkcji interfejsu WWW prosto z linii poleceń powłoki.
414
415 %package scm
416 Summary:        Eventum SCM integration
417 Summary(pl.UTF-8):      Integracja SCM dla Eventum
418 Group:          Applications/WWW
419 Requires:       %{name}-base = %{version}-%{release}
420 Requires:       php(core) >= %{php_min_version}
421 Requires:       php-cli
422 Requires:       php-pcre
423
424 %description scm
425 This feature allows your software development teams to integrate your
426 Source Control Management system with your Issue Tracking System.
427
428 The integration is implemented in such a way that it will be forward
429 compatible with pretty much any SCM system, such as CVS.
430
431 For installation see
432 </eventum/help.php?topic=scm_integration_installation>.
433
434 %description scm -l pl.UTF-8
435 Ten pakiet pozwala zespołom programistów na integrację systemu
436 zarządzania źródłami (SCM - Source Control Management) z systemem
437 śledzenia spraw.
438
439 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
440 prawie każdym systemem SCM, jak np. CVS.
441
442 Szczegóły na temat instalacji można przeczytać pod
443 </eventum/help.php?topic=scm_integration_installation>.
444
445 %package sphinx
446 Summary:        Eventum Sphinx Search
447 Group:          Applications/WWW
448 Requires:       %{name} = %{version}-%{release}
449 Requires:       crondaemon
450 Requires:       sphinx
451
452 %description sphinx
453 Sphinx search integration for Eventum.
454
455 This package contains the cron job.
456
457 %prep
458 %setup -q -n %{name}-%{version}-%{subver}-g%{githash}
459
460 # GPL v2
461 rm docs/COPYING
462
463 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
464 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
465 rm upgrade/flush_compiled_templates.php
466 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
467
468 # bug fixes / features
469 %patch0 -p1
470 %{?with_order:%patch2 -p1}
471 %patch3 -p0
472 %patch4 -p1
473
474 cp -p %{SOURCE16} htdocs/images
475
476 #%patch200 -p1
477
478 # produce default sphinx config
479 # must be run before paths.patch
480 cat <<'EOF' > config/config.php
481 <?php
482 define('APP_SQL_DBTYPE', 'mysql');
483 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
484 define('APP_SQL_DBPORT', 3306);
485 define('APP_SQL_DBNAME', 'eventum');
486 define('APP_SQL_DBUSER', 'mysql');
487 define('APP_SQL_DBPASS', '');
488 define('APP_TABLE_PREFIX', 'eventum_');
489 EOF
490 php config/sphinx.conf.php > config/sphinx.conf
491 rm -f config/config.php
492
493 # packaging
494 %patch100 -p1
495 %patch101 -p1
496 %patch105 -p1
497 %patch107 -p1
498
499 %{__sed} -i -e "
500 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
501 " upgrade/{*/,}*.php
502
503 # remove backups from patching as we use globs to package files to buildroot
504 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
505
506 %build
507 %{__make} -C localization
508
509 %install
510 rm -rf $RPM_BUILD_ROOT
511 install -d \
512         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
513         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
514         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
515         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
516         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
517         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
518         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
519
520 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
521         sysconfdir=%{_webappdir} \
522         DESTDIR=$RPM_BUILD_ROOT
523
524 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
525
526 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
527 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
528 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
529 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
530
531 install -d $RPM_BUILD_ROOT/etc/sphinx
532 cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
533 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
534
535 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
536 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
537 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
538 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
539 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
540
541 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
542
543 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
544 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
545
546 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
547
548 # postfix router
549 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
550
551 install %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
552
553 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
554
555 %find_lang %{name}
556
557 # scm
558 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
559
560 # old compat
561 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
562 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
563
564 # skip pear for cli
565 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
566 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
567
568 %clean
569 rm -rf $RPM_BUILD_ROOT
570
571 %pre
572 %addusertogroup http %{name}
573
574 %post
575 # greate empty ghost files
576 for a in cli.log errors.log irc_bot.log login_attempts.log; do
577         if [ ! -f /var/log/%{name}/$a ]; then
578                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
579         fi
580 done
581
582 # database update
583 %{_appdir}/upgrade/update-database.php || :
584
585 # nuke Smarty templates cache after upgrade
586 rm -f /var/cache/eventum/*.php
587
588 # Restart webserver on upgrade to get .mo translations reloaded.
589 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
590 %php_webserver_restart
591
592 %preun
593 if [ "$1" = "0" ]; then
594         # nuke cache
595         rm -f /var/cache/eventum/*.php 2>/dev/null || :
596 fi
597
598 %pre base
599 %groupadd -P %{name}-base -g 146 %{name}
600 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
601
602 %postun base
603 if [ "$1" = "0" ]; then
604         %userremove %{name}
605         %groupremove %{name}
606 fi
607
608 %post setup
609 chmod 660 %{_webappdir}/{config,private_key}.php
610 chown root:http %{_webappdir}/{config,private_key}.php
611
612 %postun setup
613 if [ "$1" = "0" ]; then
614         chmod 640 %{_webappdir}/{config,private_key}.php
615         chown root:http %{_webappdir}/{config,private_key}.php
616 fi
617
618 %post irc
619 /sbin/chkconfig --add eventum-irc
620 %service eventum-irc restart "Eventum IRC Bot"
621
622 %preun irc
623 if [ "$1" = 0 ]; then
624         %service eventum-irc stop
625         /sbin/chkconfig --del eventum-irc
626 fi
627
628 %triggerin -- apache1 < 1.3.37-3, apache1-base
629 %webapp_register apache %{_webapp}
630
631 %triggerun -- apache1 < 1.3.37-3, apache1-base
632 %webapp_unregister apache %{_webapp}
633
634 %triggerin -- apache < 2.2.0, apache-base
635 %webapp_register httpd %{_webapp}
636
637 %triggerun -- apache < 2.2.0, apache-base
638 %webapp_unregister httpd %{_webapp}
639
640 %triggerin -- lighttpd
641 %webapp_register lighttpd %{_webapp}
642
643 %triggerun -- lighttpd
644 %webapp_unregister lighttpd %{_webapp}
645
646 %triggerpostun -- %{name} < 2.2-2.57
647 # switching eventum->http user
648 chgrp http %{_webappdir}/config.php
649 chgrp http %{_webappdir}/private_key.php
650 chgrp http %{_webappdir}/setup.php
651 chgrp http /var/log/%{name}/*
652 # update crontab user
653 for a in /etc/cron.d/eventum-*; do
654         [ -f "$a" ] || continue
655         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
656         rm -f $a.rpmtmp
657
658         # crontabs moved to crons subdir
659         %{__sed} -i -e '
660                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
661                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
662                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
663                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
664         ' $a
665 done
666
667 %files -f %{name}.lang
668 %defattr(644,root,root,755)
669 %doc docs/* htdocs/setup/schema.sql
670 %attr(751,root,root) %dir %{_webappdir}
671 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
672 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
673 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
674 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
675 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
676 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
677 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
678
679 %dir %attr(731,root,http) /var/log/%{name}
680 %attr(620,root,http) %ghost /var/log/%{name}/*
681 %dir %attr(750,root,root) /var/log/archive/%{name}
682 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
683
684 %dir %{_appdir}/crons
685 %{_appdir}/init.php
686 %dir %{_appdir}/htdocs
687 %{_appdir}/htdocs/*.php
688 %{_appdir}/htdocs/*.ico
689 %{_appdir}/htdocs/css
690 %{_appdir}/htdocs/customer
691 %{_appdir}/htdocs/images
692 %{_appdir}/htdocs/js
693 %{_appdir}/htdocs/manage
694 %{_appdir}/htdocs/reports
695 %{_appdir}/htdocs/rpc
696 %{_appdir}/htdocs/misc
697 %if %{with order}
698 %{_appdir}/htdocs/ajax
699 %endif
700 %{_appdir}/templates
701
702 %dir %{_appdir}/upgrade
703 %{_appdir}/upgrade/init.php
704 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
705 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
706 %dir %{_appdir}/upgrade/v*
707 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
708 %{_appdir}/upgrade/patches
709
710 %dir %{_appdir}/lib
711 %{_appdir}/lib/eventum
712 %{_appdir}/lib/jpgraph
713 %exclude %{_appdir}/lib/eventum/class.monitor.php
714 %{systemdtmpfilesdir}/%{name}.conf
715 %dir %attr(730,root,http) /var/run/%{name}
716 %dir %attr(730,root,http) /var/cache/%{name}
717
718 %files base
719 %defattr(644,root,root,755)
720 %attr(751,root,root) %dir %{_sysconfdir}
721 %dir %{_libdir}
722 %dir %{_appdir}
723 %dir /var/lib/%{name}
724 # saved mail copies
725 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
726 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
727 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
728
729 %files setup
730 %defattr(644,root,root,755)
731 %{_appdir}/htdocs/setup
732
733 %files mail-queue
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
737
738 %files mail-download
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_appdir}/crons/download_emails.php
741 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
742
743 %files reminder
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_appdir}/crons/check_reminders.php
746 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
747
748 %files monitor
749 %defattr(644,root,root,755)
750 %{_appdir}/lib/eventum/class.monitor.php
751 %attr(755,root,root) %{_appdir}/crons/monitor.php
752 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
753
754 %files route-drafts
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_appdir}/route_drafts.php
757
758 %files route-emails
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_appdir}/route_emails.php
761
762 %files route-notes
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_appdir}/route_notes.php
765
766 %files router-postfix
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/router-postfix
769
770 %files irc
771 %defattr(644,root,root,755)
772 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
773 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
774 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
775 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
776
777 %files cli
778 %defattr(644,root,root,755)
779 %doc cli/eventumrc
780 %attr(755,root,root) %{_bindir}/%{name}
781 %{_appdir}/cli
782
783 %files scm
784 %defattr(644,root,root,755)
785 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
786 %attr(755,root,root) %{_libdir}/process_cvs_commits
787 %attr(755,root,root) %{_libdir}/process_svn_commits
788 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
789 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
790
791 %files sphinx
792 %defattr(644,root,root,755)
793 %{_webappdir}/sphinx.conf.php
794 %attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
795 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.553562 seconds and 3 git commands to generate.