]> git.pld-linux.org Git - packages/eventum-scm.git/blob - eventum-scm.spec
9b9909660229773e41ae879c05280d5e155bcd70
[packages/eventum-scm.git] / eventum-scm.spec
1 %define         php_min_version 5.3.7
2 Summary:        Eventum SCM integration
3 Summary(pl.UTF-8):      Integracja SCM dla Eventum
4 Name:           eventum-scm
5 Version:        3.1.3
6 Release:        1
7 License:        GPL v2+
8 Group:          Networking/Utilities
9 Source0:        https://github.com/eventum/scm/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  f89c97f1986407125f866c313c53cbd5
11 Patch0:         paths.patch
12 URL:            https://github.com/eventum/scm
13 BuildRequires:  /usr/bin/php
14 BuildRequires:  php(core) >= %{php_min_version}
15 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
16 BuildRequires:  rpmbuild(macros) >= 1.654
17 BuildRequires:  sed >= 4.0
18 Requires:       php(core) >= %{php_min_version}
19 Requires:       php(json)
20 Requires:       php(pcre)
21 Requires:       php(spl)
22 Suggests:       cvs
23 Suggests:       git-core
24 Suggests:       php(openssl)
25 Suggests:       subversion
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _libdir         %{_prefix}/lib
30
31 %description
32 This feature allows your software development teams to integrate your
33 Source Control Management system with your Issue Tracking System.
34
35 The integration is implemented in such a way that it will be forward
36 compatible with pretty much any SCM system, such as CVS.
37
38 For installation see
39 </eventum/help.php?topic=scm_integration_installation>.
40
41 %description -l pl.UTF-8
42 Ten pakiet pozwala zespołom programistów na integrację systemu
43 zarządzania źródłami (SCM - Source Control Management) z systemem
44 śledzenia spraw.
45
46 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
47 prawie każdym systemem SCM, jak np. CVS.
48
49 Szczegóły na temat instalacji można przeczytać pod
50 </eventum/help.php?topic=scm_integration_installation>.
51
52 %prep
53 %setup -qc
54 mv scm-*/* .
55 %patch0 -p1
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}}
60 cp -p helpers.php $RPM_BUILD_ROOT%{_libdir}/eventum-scm-helpers.php
61 for a in eventum-*-hook.php; do
62         f=${a%.php}
63         install -p $a $RPM_BUILD_ROOT%{_sbindir}/$f
64 done
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README.md CHANGELOG.md
72 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
73 %attr(755,root,root) %{_sbindir}/eventum-git-hook
74 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
75 %{_libdir}/eventum-scm-helpers.php
This page took 0.064662 seconds and 2 git commands to generate.