]> git.pld-linux.org Git - packages/eventum-scm.git/blob - eventum-scm.spec
3317eb40d3630ca4b72982077c8c72a25f0b609c
[packages/eventum-scm.git] / eventum-scm.spec
1 %define         php_min_version 5.3.7
2 %include        /usr/lib/rpm/macros.php
3 Summary:        Eventum SCM integration
4 Summary(pl.UTF-8):      Integracja SCM dla Eventum
5 Name:           eventum-scm
6 Version:        3.1.0
7 Release:        1
8 License:        GPL v2+
9 Group:          Networking/Utilities
10 Source0:        https://github.com/eventum/scm/archive/v%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  71a3b74d645ee6f56a9fa94207cba558
12 #Source0:       https://github.com/eventum/scm/archive/7e9e15c/%{name}-%{version}.tar.gz
13 Patch0:         paths.patch
14 URL:            https://github.com/eventum/scm
15 BuildRequires:  /usr/bin/php
16 BuildRequires:  php(core) >= %{php_min_version}
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 BuildRequires:  rpmbuild(macros) >= 1.654
19 BuildRequires:  sed >= 4.0
20 Requires:       php(core) >= %{php_min_version}
21 Requires:       php(json)
22 Requires:       php(pcre)
23 Requires:       php(spl)
24 Suggests:       cvs
25 Suggests:       git-core
26 Suggests:       php(openssl)
27 Suggests:       subversion
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _libdir         %{_prefix}/lib
32
33 %description
34 This feature allows your software development teams to integrate your
35 Source Control Management system with your Issue Tracking System.
36
37 The integration is implemented in such a way that it will be forward
38 compatible with pretty much any SCM system, such as CVS.
39
40 For installation see
41 </eventum/help.php?topic=scm_integration_installation>.
42
43 %description -l pl.UTF-8
44 Ten pakiet pozwala zespołom programistów na integrację systemu
45 zarządzania źródłami (SCM - Source Control Management) z systemem
46 śledzenia spraw.
47
48 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
49 prawie każdym systemem SCM, jak np. CVS.
50
51 Szczegóły na temat instalacji można przeczytać pod
52 </eventum/help.php?topic=scm_integration_installation>.
53
54 %prep
55 %setup -qc
56 mv scm-*/* .
57 %patch0 -p1
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}}
62 cp -p helpers.php $RPM_BUILD_ROOT%{_libdir}/eventum-scm-helpers.php
63 for a in eventum-*-hook.php; do
64         f=${a%.php}
65         install -p $a $RPM_BUILD_ROOT%{_sbindir}/$f
66 done
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc README.md CHANGELOG.md
74 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
75 %attr(755,root,root) %{_sbindir}/eventum-git-hook
76 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
77 %{_libdir}/eventum-scm-helpers.php
This page took 0.120556 seconds and 2 git commands to generate.