]> git.pld-linux.org Git - packages/electron.git/blob - electron.spec
try build from source as per build instructions
[packages/electron.git] / electron.spec
1 # TODO:
2 # - build from source (the process and deps look like hell)
3 #   https://github.com/atom/electron/blob/v0.36.0/docs/development/build-instructions-linux.md
4 # NOTES:
5 # - space considerations: ~25GiB for build
6 #
7
8 Summary:        Framework cross-platform desktop applications using JavaScript, HTML and CSS
9 Name:           electron
10 Version:        0.36.0
11 Release:        0.1
12 License:        MIT, BSD
13 Group:          Applications
14 URL:            https://github.com/atom/electron
15 BuildRequires:  git-core
16 BuildRequires:  npm
17 ExclusiveArch:  %{ix86} %{x8664}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _noautoprovfiles        %{_libdir}/%{name}
21 %define         _noautoreq              libnode.so libnotify.so
22
23 %description
24 The Electron framework lets you write cross-platform desktop
25 applications using JavaScript, HTML and CSS. It is based on Node.js
26 and Chromium and is used in the Atom editor.
27
28 %prep
29 %setup -qcT
30 git clone https://github.com/atom/electron.git -b v%{version} --depth 1 .
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 # make install repeatable
36 rm -f debug*.list
37
38 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}}
39 cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
40 ln -s %{_libdir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
41
42 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/LICENSE*
43 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/libgcrypt*
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc LICENSE*
51 %attr(755,root,root) %{_bindir}/%{name}
52 %dir %{_libdir}/%{name}
53 %{_libdir}/%{name}/locales
54 %{_libdir}/%{name}/resources
55 %attr(755,root,root) %{_libdir}/%{name}/electron
56 %attr(755,root,root) %{_libdir}/%{name}/libnode.so
57 %attr(755,root,root) %{_libdir}/%{name}/libnotify.so.4
58 %{_libdir}/%{name}/content_shell.pak
59 %{_libdir}/%{name}/icudtl.dat
60 %{_libdir}/%{name}/natives_blob.bin
61 %{_libdir}/%{name}/snapshot_blob.bin
62 %{_libdir}/%{name}/version
This page took 0.093466 seconds and 4 git commands to generate.