]> git.pld-linux.org Git - packages/electron.git/blob - electron.spec
new package
[packages/electron.git] / electron.spec
1
2 # TODO:
3 #       - build from source (the process and deps look like hell)
4
5 Summary:        Framework cross-platform desktop applications using JavaScript, HTML and CSS
6 Name:           electron
7 Version:        0.36.0
8 Release:        0.1
9 License:        MIT, BSD
10 Group:          Applications
11 #Source0:       https://github.com/atom/electron/archive/v%{version}/%{name}-%{version}.tar.gz
12 ## Source0-md5: 0c20e4676d7aef091521c9264d58939a
13 Source1:        https://github.com/atom/electron/releases/download/v%{version}/%{name}-v%{version}-linux-ia32.zip
14 # Source1-md5:  1272f2a7330341f86cd8be1cce14afc9
15 Source2:        https://github.com/atom/electron/releases/download/v%{version}/%{name}-v%{version}-linux-x64.zip
16 # Source2-md5:  1c77028a12330b4883fe93eea82c0b63
17 URL:            https://github.com/atom/electron
18 BuildRequires:  unzip
19 ExclusiveArch:  %{ix86} %{x8664}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _noautoprovfiles        %{_libdir}/%{name}
23 %define         _noautoreq              libnode.so libnotify.so
24
25 %description
26 The Electron framework lets you write cross-platform desktop
27 applications using JavaScript, HTML and CSS. It is based on Node.js
28 and Chromium and is used in the Atom editor.
29
30 %prep
31 %setup -qcT
32
33 %ifarch %{ix86}
34 unzip %{SOURCE1}
35 %endif
36 %ifarch %{x8664}
37 unzip %{SOURCE2}
38 %endif
39
40 %build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 # make install repeatable
46 rm -f debug*.list 2>/dev/null || :
47
48 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}}
49 cp -a * $RPM_BUILD_ROOT%{_libdir}/%{name}
50
51 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/LICENSE*
52 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/libgcrypt*
53
54 ln -sf %{_libdir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc LICENSE*
62 %attr(755,root,root) %{_bindir}/%{name}
63 %dir %{_libdir}/%{name}
64 %{_libdir}/%{name}/locales
65 %{_libdir}/%{name}/resources
66 %attr(755,root,root) %{_libdir}/%{name}/electron
67 %attr(755,root,root) %{_libdir}/%{name}/libnode.so
68 %attr(755,root,root) %{_libdir}/%{name}/libnotify.so.4
69 %{_libdir}/%{name}/content_shell.pak
70 %{_libdir}/%{name}/icudtl.dat
71 %{_libdir}/%{name}/natives_blob.bin
72 %{_libdir}/%{name}/snapshot_blob.bin
73 %{_libdir}/%{name}/version
This page took 0.067367 seconds and 4 git commands to generate.