]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
dfeb5e3c0c4c0db05e0d01ac0660fa5e1abb74e0
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_without  python          # with python support
6 %bcond_without  pthread         # build with Posix threads support
7 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
8 %bcond_with     lock_reason     # with lock_reason patch
9 #
10 Summary:        A client compatible with Gadu-Gadu
11 Summary(de.UTF-8):      Ein Cliente kompatibel mit Gadu-Gadu
12 Summary(es.UTF-8):      Un cliente compatible con Gadu-Gadu
13 Summary(it.UTF-8):      Un cliente compatibile con Gadu-Gadu
14 Summary(pl.UTF-8):      Klient kompatybilny z Gadu-Gadu
15 Name:           ekg
16 Version:        1.7
17 Release:        4
18 Epoch:          4
19 License:        GPL v2
20 Group:          Applications/Communications
21 Source0:        http://ekg.chmurka.net/%{name}-%{version}.tar.gz
22 # Source0-md5:  2aa92b56517fdf09d75519a105772b74
23 Source1:        %{name}.conf
24 Patch0:         %{name}-LDFLAGS.patch
25 Patch1:         %{name}-lock_reason.patch
26 Patch2:         %{name}-external_libgadu.patch
27 URL:            http://ekg.chmurka.net/
28 BuildRequires:  %{_bindir}/perl
29 %{?with_aspell:BuildRequires:   aspell-devel}
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  libgadu-devel >= 4:1.7.0
33 %{?with_voip:BuildRequires:     libgsm-devel}
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  ncurses-devel
36 BuildRequires:  openssl-devel >= 0.9.7d
37 %if %{with python}
38 BuildRequires:  python
39 BuildRequires:  python-devel
40 %endif
41 BuildRequires:  readline-devel
42 BuildRequires:  zlib-devel
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
47 client for UNIX systems. Gadu-Gadu is an instant messaging program,
48 very popular in Poland.
49
50 EKG features include:
51   - irssi-like ncurses interface
52   - sending and receiving files
53   - voice conversations
54   - launching shell commands on certain events
55   - reading input from pipe
56   - python scripting support
57   - speech synthesis (using an external program)
58   - encryption support
59
60 Please note that the program is not internationalized and all messages
61 are in Polish (although the commands are in English).
62
63 %description -l de.UTF-8
64 Ein Cliente kompatibel mit Gadu-Gadu.
65
66 %description -l es.UTF-8
67 Un cliente compatible con Gadu-Gadu.
68
69 %description -l it.UTF-8
70 Un cliente compatibile con Gadu-Gadu.
71
72 %description -l pl.UTF-8
73 EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
74 klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
75 Polsce komunikator internetowy.
76
77 Możliwości EKG:
78   - interfejs użytkownika podobny do irssi,
79   - wysyłanie i odbieranie plików,
80   - rozmowy głosowe,
81   - uruchamianie poleceń powłoki w określonych sytuacjach,
82   - wczytywanie wejścia z potoku,
83   - wsparcie dla skryptów w języku Python,
84   - synteza mowy (z użyciem zewnętrznego programu),
85   - wsparcie dla szyfrowania.
86
87 Program nie jest umiędzynarodowiony i wszystkie komunikaty są po
88 polsku (jednak komendy są w języku angielskim).
89
90 %prep
91 %setup -q
92 %patch0 -p0
93 %if %{with lock_reason}
94 %patch1 -p1
95 %endif
96 %patch2 -p0
97
98 %build
99 %{__aclocal} -I m4
100 %{__autoheader}
101 %{__autoconf}
102 %configure \
103         CFLAGS_LIBGADU="%{rpmcflags}" \
104         --enable-dynamic \
105         --enable-shared \
106         --enable-static \
107 %if %{with pthread}
108         --with-pthread \
109 %else
110         --without-pthread \
111 %endif
112         --without-bind \
113         %{?with_python:--with-python} \
114         %{!?with_voip:--without-libgsm} \
115         %{?with_aspell:--enable-aspell} \
116         %{?with_ioctl_daemon:--enable-ioctld}
117
118 %{__make}
119
120 %if %{with ioctl_daemon}
121 %{__make} -C src ioctld
122 %endif
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_sysconfdir}
127
128 %{__make} install install-ekl2 \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
132
133 # For libgadu-devel
134
135 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
136 rm -rf examples/CVS
137
138 %if %{with ioctl_daemon}
139 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
140 %endif
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files
146 %defattr(644,root,root,755)
147 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
148 %{?with_aspell:%doc docs/slownik.txt}
149 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
150 %attr(755,root,root) %{_bindir}/e*
151 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
152 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
153 %{_datadir}/ekg
154 %{_mandir}/man1/*
155 %lang(pl) %{_mandir}/pl/man1/*
This page took 0.029966 seconds and 2 git commands to generate.