]> git.pld-linux.org Git - packages/eggdrop.git/blob - eggdrop.spec
- added three new encryption modules.
[packages/eggdrop.git] / eggdrop.spec
1 Summary:        Eggdrop is an IRC bot, written in C
2 Summary(pl):    Eggdrop jest botem IRC napisanym w C
3 Name:           eggdrop
4 Version:        1.6.13
5 Release:        4
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/%{name}%{version}.tar.gz
9 # PLD docs - information about changes.
10 Source1:        http://pld.mysza.eu.org/sources/%{name}-README.PLD.en
11 Source2:        http://pld.mysza.eu.org/sources/%{name}-README.PLD.pl
12 # In order to unify filenames, following language packs and third-party modules were 
13 # repackaged. Some files were renamed, but none modified. Original archives can be 
14 # found by looking at http://www.egghelp.org/
15 Source10:       %{name}-language-danish.tar.gz
16 Source11:       %{name}-language-finnish.tar.gz
17 Source12:       %{name}-language-italian.tar.gz
18 Source13:       %{name}-language-norwegian.tar.gz
19 Source14:       %{name}-language-portuguese.tar.gz
20 Source15:       %{name}-language-portuguese_br.tar.gz
21 Source16:       %{name}-language-romanian.tar.gz
22 # Additional modules taken from various places
23 Source20:       %{name}-module-away-1.0.tar.gz
24 Source21:       %{name}-module-botnetop-1.0.1.tar.gz
25 Source22:       %{name}-module-fakebotnet-1.3.tar.gz
26 Source23:       %{name}-module-gseen-1.1.0.tar.gz
27 Source24:       %{name}-module-irctree-1.1.tar.gz
28 Source25:       %{name}-module-megahal-2.5.tar.gz
29 Source26:       %{name}-module-stats-1.3.3dev1.tar.gz
30 Source27:       %{name}-module-idea-1.0.0.tar.gz
31 Source28:       %{name}-module-twofish-1.0.tar.gz
32 Source29:       %{name}-module-rijndael-1.0.tar.gz
33 Patch0:         %{name}-FHS.patch
34 # Unofficial IPv6 patch
35 Patch1:         http://www.egghelp.org/files/patches/%{name}%{version}+ipv6.patch.gz
36 # Adds IPv6 variables to config file
37 Patch2:         %{name}%{version}+ipv6_config.patch
38 # Adds additional docs
39 Patch3:         %{name}-doc_makefile.patch
40 # Multilevel sharing patch - now it is possible to create *secure* multilevel
41 # botnets, each bot will only accept changes to userlist from bot that acts as 
42 # hub to him, and rejects changes from leaves
43 Patch4:         %{name}%{version}-multilevel_sharing.patch.gz
44 # Unlinkedby patch - when unlinking bot from botnet, adds nickname of a person
45 # that issues .unlink command to a broadcasted message
46 Patch5:         %{name}%{version}-unlinkedby.patch
47 URL:            http://www.eggheads.org/
48 BuildRequires:  tcl-devel
49 Requires:       tcl
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
54 this is probably not whatever you're looking for! Eggdrop, being a
55 bot, sits on a channel and takes protective measures: to keep the
56 channel from being taken over (in the few ways that anything CAN), to
57 recognize banished users or sites and reject them, to recognize
58 privileged users and let them gain ops, etc. Eggdrop also contains
59 many modules and scripts, for example for sending files.
60
61 %description -l pl
62 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, bêd±c botem jest na
63 kanale i zajmuje siê jego ochron±: zabezpieczeniem przed przejêciem,
64 nadawaniem odpowiednich przywilejów zarejestrowanym u¿ytkownikom,
65 pilnowanie tzw. banów itp. Eggdrop poza tymi funkcjami posiada tak¿e
66 wiele dodatków, jak przesy³anie plików czy inne skrypty dla rozrywki.
67
68 %prep
69 %setup -q -n %{name}%{version} -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a20 -a21 -a22 -a23 -a24 -a25 -a26 -a27 -a28 -a29
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p0
73 %patch3 -p0
74 %patch4 -p1
75 %patch5 -p1
76
77 %build
78 CFLAGS="%{rpmcflags}"; export CFLAGS
79 ./configure
80 %{__make} config
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/modules,%{_datadir}/%{name},%{_mandir}/man1,%{_datadir}/%{name}/{help,scripts,language},%{_datadir}/doc/%{name}-%{version}}
86
87 %{__make} DESTDIR="$RPM_BUILD_ROOT" install
88
89 cp $RPM_BUILD_ROOT/%{name}-%{version} $RPM_BUILD_ROOT%{_bindir}/%{name}
90
91 cp %{SOURCE1} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}/README.PLD.en
92 cp %{SOURCE2} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}/README.PLD.pl
93
94 find $RPM_BUILD_ROOT/doc -type f | egrep -v "(\.html$|\.htm$)" | xargs gzip -9nf
95 gzip -9nf $RPM_BUILD_ROOT/README $RPM_BUILD_ROOT/%{name}.conf 
96
97 cp $RPM_BUILD_ROOT/doc/man1/%{name}.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1.gz
98 rm -r $RPM_BUILD_ROOT/doc/man1
99
100 cp -a $RPM_BUILD_ROOT/*.gz \
101         $RPM_BUILD_ROOT/doc/* \
102         $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}/
103
104 cp -a $RPM_BUILD_ROOT/doc/modules $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
105
106 cp -a $RPM_BUILD_ROOT/text/* \
107         $RPM_BUILD_ROOT/help/ \
108         $RPM_BUILD_ROOT/scripts/ \
109         $RPM_BUILD_ROOT/language/ \
110         $RPM_BUILD_ROOT%{_datadir}/%{name}/
111
112 cp -a $RPM_BUILD_ROOT/modules/* \
113         $RPM_BUILD_ROOT%{_libdir}/%{name}/modules/
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc %{_datadir}/doc/%{name}-%{version}
121 %attr(755,root,root) %{_bindir}/%{name}
122 %dir %{_libdir}/%{name}
123 %dir %{_libdir}/%{name}/modules
124 %attr(755,root,root) %{_libdir}/%{name}/modules/*.so
125 %{_datadir}/%{name}
126 %{_mandir}/man1/%{name}.1*
This page took 0.076435 seconds and 4 git commands to generate.