]> git.pld-linux.org Git - packages/eggdrop.git/blob - eggdrop.spec
- fix use of some _*dir macros
[packages/eggdrop.git] / eggdrop.spec
1 Summary:        Eggdrop is an IRC bot, written in C
2 Summary(pl):    Eggdrop jest botem IRC napisanym w C
3 Name:           eggdrop
4 Version:        1.6.13
5 Release:        4
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/%{name}%{version}.tar.gz
9 # PLD docs - information about changes.
10 Source1:        http://pld.mysza.eu.org/sources/%{name}-README.PLD.en
11 Source2:        http://pld.mysza.eu.org/sources/%{name}-README.PLD.pl
12 # In order to unify filenames, following language packs and third-party modules were 
13 # repackaged. Some files were renamed, but none modified. Original archives can be 
14 # found by looking at http://www.egghelp.org/
15 Source10:       %{name}-language-danish.tar.gz
16 Source11:       %{name}-language-finnish.tar.gz
17 Source12:       %{name}-language-italian.tar.gz
18 Source13:       %{name}-language-norwegian.tar.gz
19 Source14:       %{name}-language-portuguese.tar.gz
20 Source15:       %{name}-language-portuguese_br.tar.gz
21 Source16:       %{name}-language-romanian.tar.gz
22 # Additional modules taken from various places
23 Source20:       %{name}-module-away-1.0.tar.gz
24 Source21:       %{name}-module-botnetop-1.0.1.tar.gz
25 Source22:       %{name}-module-fakebotnet-1.3.tar.gz
26 Source23:       %{name}-module-gseen-1.1.0.tar.gz
27 Source24:       %{name}-module-irctree-1.1.tar.gz
28 Source25:       %{name}-module-megahal-2.5.tar.gz
29 Source26:       %{name}-module-stats-1.3.3dev1.tar.gz
30 Source27:       %{name}-module-idea-1.0.0.tar.gz
31 Source28:       %{name}-module-twofish-1.0.tar.gz
32 Source29:       %{name}-module-rijndael-1.0.tar.gz
33 Patch0:         %{name}-FHS.patch
34 # Unofficial IPv6 patch
35 Patch1:         http://www.egghelp.org/files/patches/%{name}%{version}+ipv6.patch.gz
36 # Adds IPv6 variables to config file
37 Patch2:         %{name}%{version}+ipv6_config.patch
38 # Adds additional docs
39 Patch3:         %{name}-doc_makefile.patch
40 # Multilevel sharing patch - now it is possible to create *secure* multilevel
41 # botnets, each bot will only accept changes to userlist from bot that acts as 
42 # hub to him, and rejects changes from leaves
43 Patch4:         %{name}%{version}-multilevel_sharing.patch.gz
44 # Unlinkedby patch - when unlinking bot from botnet, adds nickname of a person
45 # that issues .unlink command to a broadcasted message
46 Patch5:         %{name}%{version}-unlinkedby.patch
47 URL:            http://www.eggheads.org/
48 BuildRequires:  tcl-devel
49 Requires:       tcl
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
54 this is probably not whatever you're looking for! Eggdrop, being a
55 bot, sits on a channel and takes protective measures: to keep the
56 channel from being taken over (in the few ways that anything CAN), to
57 recognize banished users or sites and reject them, to recognize
58 privileged users and let them gain ops, etc. Eggdrop also contains
59 many modules and scripts, for example for sending files.
60 Here is the list of new features as opposed to vanilla eggdrop:
61 * Built-in IPv6 support
62 * Additional modules, including:
63   - away
64   - botnetop
65   - fakebotnet
66   - gseen
67   - irctree
68   - megahal
69   - stats
70   - three new encryption modules: idea, twofish, rijndael
71 * Additional language packs:
72   - dannish
73   - finnish
74   - italian
75   - norwegian
76   - portuguese
77   - brazillian portuguese
78   - romanian
79 * Multilevel sharing and unlinkedby patches were applied
80 For more information, see README.PLD.en file located under
81 %{_datadir}/doc/%{name}-%{version}
82
83 %description -l pl
84 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, bêd±c botem jest na
85 kanale i zajmuje siê jego ochron±: zabezpieczeniem przed przejêciem,
86 nadawaniem odpowiednich przywilejów zarejestrowanym u¿ytkownikom,
87 pilnowanie tzw. banów itp. Eggdrop poza tymi funkcjami posiada tak¿e
88 wiele dodatków, jak przesy³anie plików czy inne skrypty dla rozrywki.
89 Oto lista nowych mo¿liwo¶ci w odró¿nieniu od 'czystego' eggdropa:
90 * Wbudowane wsparcie dla IPv6
91 * Dodatkowe modu³y, takie jak:
92   - away
93   - botnetop
94   - fakebotnet
95   - gseen
96   - irctree
97   - megahal
98   - stats
99   - trzy nowe modu³y szyfruj±ce: idea, twofish, rijndael
100 * Dodatkowe 
101   - duñski
102   - fiñski
103   - w³oski
104   - norweski
105   - portugalski
106   - brazylijska odmiana portugalskiego
107   - rumuñski
108 * Zaaplikowano ³aty multilevel sharing oraz unlinkedby
109 Wiêcej informacji znajdziesz w pliku README.PLD.pl znajduj±cym siê w 
110 katalogu %{_datadir}/doc/%{name}-%{version}
111
112 %prep
113 %setup -q -n %{name}%{version} -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a20 -a21 -a22 -a23 -a24 -a25 -a26 -a27 -a28 -a29
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p0
117 %patch3 -p0
118 %patch4 -p1
119 %patch5 -p1
120
121 %build
122 CFLAGS="%{rpmcflags}"; export CFLAGS
123 # There is no sense in using configure macro, as the eggdrop makes no use
124 # of provided settings, or at least of those given with --*dir options
125 ./configure
126 %{__make} config
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/modules,%{_datadir}/%{name},%{_mandir}/man1,%{_datadir}/%{name}/{help,scripts,language},%{_datadir}/doc/%{name}-%{version}}
132
133 %{__make} DESTDIR="$RPM_BUILD_ROOT" install
134
135 mv $RPM_BUILD_ROOT/%{name}-%{version} $RPM_BUILD_ROOT%{_bindir}/%{name}
136
137 cp %{SOURCE1} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/README.PLD.en
138 cp %{SOURCE2} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/README.PLD.pl
139
140 find $RPM_BUILD_ROOT/doc -type f | egrep -v "(\.html$|\.htm$)" | xargs gzip -9nf
141 gzip -9nf $RPM_BUILD_ROOT/README $RPM_BUILD_ROOT/%{name}.conf 
142
143 cp $RPM_BUILD_ROOT/doc/man1/%{name}.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1.gz
144 rm -r $RPM_BUILD_ROOT/doc/man1
145
146 cp -a $RPM_BUILD_ROOT/*.gz \
147         $RPM_BUILD_ROOT/doc/* \
148         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/
149
150 cp -a $RPM_BUILD_ROOT/doc/modules $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
151
152 cp -a $RPM_BUILD_ROOT/text/* \
153         $RPM_BUILD_ROOT/help/ \
154         $RPM_BUILD_ROOT/scripts/ \
155         $RPM_BUILD_ROOT/language/ \
156         $RPM_BUILD_ROOT%{_datadir}/%{name}/
157
158 cp -a $RPM_BUILD_ROOT/modules/* \
159         $RPM_BUILD_ROOT%{_libdir}/%{name}/modules/
160
161 # These are only to make /usr/lib/rpm/check-files happy(ier)
162 # Is this somehow ugly?
163 for i in modules modules-%{version} text help scripts language doc logs eggdrop.conf.gz README.gz; do
164         rm -rf $RPM_BUILD_ROOT/$i
165 done
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %files
171 %defattr(644,root,root,755)
172 %doc %{_datadir}/doc/%{name}-%{version}
173 %attr(755,root,root) %{_bindir}/%{name}
174 %dir %{_libdir}/%{name}
175 %dir %{_libdir}/%{name}/modules
176 %attr(755,root,root) %{_libdir}/%{name}/modules/*.so
177 %{_datadir}/%{name}
178 %{_mandir}/man1/%{name}.1*
This page took 0.149636 seconds and 4 git commands to generate.