]> git.pld-linux.org Git - packages/ecore.git/blob - ecore.spec
- ecore-desktop enabled
[packages/ecore.git] / ecore.spec
1 #
2 # TODO:
3 # - why directfb does not build?
4 # - fill imf summary and desc.
5 #
6 # Conditional build:
7 %bcond_without  static_libs     # don't build static library
8 %bcond_with     xcb             # XCB instead of Xlib
9 #
10 %define         eet_ver 0.9.10.038
11
12 Summary:        Enlightened Core X interface library
13 Summary(pl.UTF-8):      Biblioteka interfejsu X Enlightened Core
14 Name:           ecore
15 Version:        0.9.9.043
16 Release:        1
17 License:        BSD
18 Group:          X11/Libraries
19 Source0:        http://download.enlightenment.org/snapshots/2008-05-19/%{name}-%{version}.tar.bz2
20 # Source0-md5:  3d328b276556045c3d169ea4980d1aaf
21 Patch0:         %{name}-tslib.patch
22 Patch1:         %{name}-link.patch
23 URL:            http://enlightenment.org/p.php?p=about/libs/ecore
24 BuildRequires:  DirectFB-devel >= 0.9.16
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  curl-devel
28 BuildRequires:  eet-devel >= %{eet_ver}
29 BuildRequires:  evas-devel >= %{version}
30 BuildRequires:  libtool
31 BuildRequires:  openssl-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  tslib-devel
34 %if %{with xcb}
35 BuildRequires:  libxcb-devel
36 BuildRequires:  xcb-util-devel
37 %else
38 BuildRequires:  xorg-lib-libXScrnSaver-devel
39 BuildRequires:  xorg-lib-libXcursor-devel
40 BuildRequires:  xorg-lib-libXdamage-devel
41 BuildRequires:  xorg-lib-libXext-devel
42 BuildRequires:  xorg-lib-libXfixes-devel
43 BuildRequires:  xorg-lib-libXinerama-devel
44 BuildRequires:  xorg-lib-libXp-devel
45 BuildRequires:  xorg-lib-libXrandr-devel
46 BuildRequires:  xorg-lib-libXrender-devel
47 %endif
48 Requires:       evas >= %{version}
49 Obsoletes:      ecore-libs
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %undefine       __cxx
53
54 %description
55 Ecore is the event/X abstraction layer that makes doing selections,
56 Xdnd, general X stuff, event loops, timeouts and idle handlers fast,
57 optimized, and convenient. It's a separate library so anyone can make
58 use of the work put into Ecore to make this job easy for applications.
59
60 %description -l pl.UTF-8
61 Ecore to warstwa abstrakcji zdarzeń/X, która powoduje, że dokonywanie
62 zaznaczeń, Xdnd, ogólne operacje X, pętle zdarzeń, obsługa timeoutów i
63 bezczynności są szybkie, zoptymalizowane i wygodne. Jest to wydzielona
64 biblioteka, więc każdy może skorzystać z pracy włożonej w Ecore do
65 ułatwienia swojej pracy przy aplikacjach.
66
67 %package con
68 Summary:        Ecore Connection Library
69 Summary(pl.UTF-8):      Biblioteka połączeń Ecore
70 Group:          Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Conflicts:      ecore-libs
73
74 %description con
75 Ecore Connection Library.
76
77 %description con -l pl.UTF-8
78 Biblioteka połączeń Ecore.
79
80 %package config
81 Summary:        Ecore Enlightened Property Library
82 Summary(pl.UTF-8):      Biblioteka właściwości Ecore
83 Group:          Libraries
84 Requires:       %{name}-ipc = %{version}-%{release}
85 Requires:       evas-devel >= %{version}
86 Requires:       eet-devel >= %{eet_ver}
87 Conflicts:      ecore-libs
88
89 %description config
90 Ecore Enlightened Property Library.
91
92 %description config -l pl.UTF-8
93 Biblioteka właściwości Ecore.
94
95 %package desktop
96 Summary:        Ecore freedesktop.org .desktop, icon, menu parsing Library
97 Summary(pl.UTF-8):      Biblioteka przetwarzania plików .desktop, ikon i menu
98 Group:          X11/Libraries
99 Requires:       %{name}-file = %{version}-%{release}
100 Conflicts:      ecore-libs
101
102 %description desktop
103 Ecore freedesktop.org .desktop, icon, menu parsing Library.
104
105 %description desktop -l pl.UTF-8
106 Biblioteka przetwarzania plików .desktop, ikon i menu.
107
108 %package directfb
109 Summary:        Ecore frame buffer system functions
110 Summary(pl.UTF-8):      Funkcje systemowe framebuffera Ecore
111 Group:          Libraries
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       DirectFB >= 0.9.16
114 Conflicts:      ecore-libs
115
116 %description directfb
117 Ecore frame buffer system functions.
118
119 %description directfb -l pl.UTF-8
120 Funkcje systemowe framebuffera Ecore.
121
122 %package evas
123 Summary:        Ecore Evas Wrapper Library
124 Summary(pl.UTF-8):      Biblioteka Ecore Evas Wrapper
125 Group:          Libraries
126 #Requires:      %{name}-directfb = %{version}-%{release}
127 Requires:       %{name}-fb = %{version}-%{release}
128 Requires:       %{name}-x = %{version}-%{release}
129 Requires:       evas >= %{version}
130 Conflicts:      ecore-libs
131
132 %description evas
133 Ecore Evas Wrapper Library.
134
135 %description evas -l pl.UTF-8
136 Biblioteka Ecore Evas Wrapper.
137
138 %package fb
139 Summary:        Ecore frame buffer system functions
140 Summary(pl.UTF-8):      Funkcje systemowe framebuffera Ecore
141 Group:          Libraries
142 Requires:       %{name} = %{version}-%{release}
143 Conflicts:      ecore-libs
144
145 %description fb
146 Ecore frame buffer system functions.
147
148 %description fb -l pl.UTF-8
149 Funkcje systemowe framebuffera Ecore.
150
151 %package file
152 Summary:        Ecore File Library
153 Summary(pl.UTF-8):      Biblioteka Ecore File
154 Group:          Libraries
155 Requires:       %{name} = %{version}-%{release}
156 Conflicts:      ecore-libs
157
158 %description file
159 Ecore File Library.
160
161 %description file -l pl.UTF-8
162 Biblioteka Ecore File.
163
164 %package imf
165 Summary:        Ecore imf functions
166 #Summary(pl.UTF-8):     Funkcje imf Ecore
167 Group:          Libraries
168 Requires:       %{name}-con = %{version}-%{release}
169 Conflicts:      ecore-libs
170
171 %description imf
172 Ecore imf functions.
173
174 #%description imf -l pl.UTF-8
175 #Funkcje imf Ecore.
176
177 %package ipc
178 Summary:        Ecore inter-process communication functions
179 Summary(pl.UTF-8):      Funkcje komunikacji międzyprocesowej Ecore
180 Group:          Libraries
181 Requires:       %{name}-con = %{version}-%{release}
182 Conflicts:      ecore-libs
183
184 %description ipc
185 Ecore inter-process communication functions.
186
187 %description ipc -l pl.UTF-8
188 Funkcje komunikacji międzyprocesowej Ecore.
189
190 %package job
191 Summary:        Ecore job dealing functions
192 Summary(pl.UTF-8):      Funkcje obsługi zadań Ecore
193 Group:          Libraries
194 Requires:       %{name} = %{version}-%{release}
195 Conflicts:      ecore-libs
196
197 %description job
198 Ecore job dealing functions.
199
200 %description job -l pl.UTF-8
201 Funkcje obsługi zadań Ecore.
202
203 %package txt
204 Summary:        Ecore text encoding conversion functions
205 Summary(pl.UTF-8):      Funkcje konwersji kodowania tekstu Ecore
206 Group:          Libraries
207 Requires:       %{name} = %{version}-%{release}
208 Conflicts:      ecore-libs
209
210 %description txt
211 Ecore text encoding conversion functions.
212
213 %description txt -l pl.UTF-8
214 Funkcje konwersji kodowania tekstu Ecore.
215
216 %package x
217 Summary:        Ecore functions for dealing with the X Window System
218 Summary(pl.UTF-8):      Funkcje Ecore do obsługi X Window System
219 Group:          X11/Libraries
220 Requires:       %{name}-txt = %{version}-%{release}
221 Conflicts:      ecore-libs
222
223 %description x
224 Ecore functions for dealing with the X Window System.
225
226 %description x -l pl.UTF-8
227 Funkcje Ecore do obsługi X Window System.
228
229 %package devel
230 Summary:        Ecore header files
231 Summary(pl.UTF-8):      Pliki nagłówkowe Ecore
232 Group:          Development/Libraries
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       %{name}-con = %{version}-%{release}
235 # + openssl-devel curl-devel
236 Requires:       %{name}-config = %{version}-%{release}
237 # + eet-devel >= 0.9.10.038
238 #Requires:      %{name}-dbus = %{version}-%{release}
239 Requires:       %{name}-desktop = %{version}-%{release}
240 #Requires:      %{name}-directfb = %{version}-%{release}
241 # + DirectFB-devel >= 0.9.16
242 Requires:       %{name}-evas = %{version}-%{release}
243 # + evas-devel >= %{version}
244 Requires:       %{name}-fb = %{version}-%{release}
245 # + tslib-devel
246 Requires:       %{name}-file = %{version}-%{release}
247 # + curl-devel
248 Requires:       %{name}-imf = %{version}-%{release}
249 Requires:       %{name}-ipc = %{version}-%{release}
250 Requires:       %{name}-job = %{version}-%{release}
251 Requires:       %{name}-txt = %{version}-%{release}
252 Requires:       %{name}-x = %{version}-%{release}
253 %if %{with xcb}
254 # + libxcb-devel xcb-util-devel
255 %else
256 # + xorg-lib-libXScrnSaver-devel xorg-lib-libXcursor-devel xorg-lib-libXdamage-devel xorg-lib-libXext-devel xorg-lib-libXfixes-devel xorg-lib-libXinerama-devel xorg-lib-libXp-devel xorg-lib-libXrandr-devel xorg-lib-libXrender-devel
257 %endif
258
259 %description devel
260 Ecore development files.
261
262 %description devel -l pl.UTF-8
263 Pliki programistyczne Ecore.
264
265 %package static
266 Summary:        Static Ecore libraries
267 Summary(pl.UTF-8):      Statyczne biblioteki Ecore
268 Group:          Development/Libraries
269 Requires:       %{name}-devel = %{version}-%{release}
270
271 %description static
272 Static Ecore libraries.
273
274 %description static -l pl.UTF-8
275 Statyczne biblioteki Ecore.
276
277 %prep
278 %setup -q
279 #%patch0 -p1
280 #%patch1 -p1
281
282 %build
283 %{__libtoolize}
284 %{__aclocal} -I m4
285 %{__autoconf}
286 %{__autoheader}
287 %{__automake}
288 %configure \
289         %{!?with_static_libs:--disable-static} \
290         --enable-ecore-txt      \
291         --enable-ecore-x        \
292         %{?with_xcb:--enable-ecore-x-xcb}       \
293         --enable-ecore-job      \
294         --enable-ecore-fb       \
295         --enable-ecore-desktop  \
296         --enable-ecore-evas     \
297         --enable-ecore-evas-xrender \
298         --enable-ecore-evas-dfb \
299         --enable-ecore-evas-fb  \
300         --enable-ecore-evas-buffer \
301         --enable-ecore-con      \
302         --enable-openssl        \
303         --enable-ecore-ipc      \
304         --enable-ecore-config   \
305         --enable-ecore-file     \
306         --enable-inotify        \
307         --enable-poll           \
308         --enable-curl
309
310 %{__make}
311
312 %install
313 rm -rf $RPM_BUILD_ROOT
314 %{__make} install \
315         DESTDIR=$RPM_BUILD_ROOT
316
317 %clean
318 rm -rf $RPM_BUILD_ROOT
319
320 %post   -p /sbin/ldconfig
321 %postun -p /sbin/ldconfig
322 %post   con     -p /sbin/ldconfig
323 %postun con     -p /sbin/ldconfig
324 %post   config  -p /sbin/ldconfig
325 %postun config  -p /sbin/ldconfig
326 %post   directfb -p /sbin/ldconfig
327 %postun directfb -p /sbin/ldconfig
328 %post   desktop -p /sbin/ldconfig
329 %postun desktop -p /sbin/ldconfig
330 %post   evas    -p /sbin/ldconfig
331 %postun evas    -p /sbin/ldconfig
332 %post   fb      -p /sbin/ldconfig
333 %postun fb      -p /sbin/ldconfig
334 %post   file    -p /sbin/ldconfig
335 %postun file    -p /sbin/ldconfig
336 %post   imf     -p /sbin/ldconfig
337 %postun imf     -p /sbin/ldconfig
338 %post   ipc     -p /sbin/ldconfig
339 %postun ipc     -p /sbin/ldconfig
340 %post   job     -p /sbin/ldconfig
341 %postun job     -p /sbin/ldconfig
342 %post   txt     -p /sbin/ldconfig
343 %postun txt     -p /sbin/ldconfig
344 %post   x       -p /sbin/ldconfig
345 %postun x       -p /sbin/ldconfig
346
347 %files
348 %defattr(644,root,root,755)
349 %doc AUTHORS COPYING COPYING-PLAIN README
350 %attr(755,root,root) %{_libdir}/libecore.so.*
351
352 %files con
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_libdir}/libecore_con.so.*
355
356 %files config
357 %defattr(644,root,root,755)
358 %attr(755,root,root) %{_bindir}/ecore_config
359 %attr(755,root,root) %{_libdir}/libecore_config.so.*
360
361 #%files directfb
362 #%defattr(644,root,root,755)
363 #%attr(755,root,root) %{_libdir}/libecore_directfb.so.*
364
365 %files desktop
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_libdir}/libecore_desktop.so.*
368
369 %files evas
370 %defattr(644,root,root,755)
371 %attr(755,root,root) %{_libdir}/libecore_evas.so.*
372
373 %files fb
374 %defattr(644,root,root,755)
375 %attr(755,root,root) %{_libdir}/libecore_fb.so.*
376
377 %files file
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_libdir}/libecore_file.so.*
380
381 %files imf
382 %defattr(644,root,root,755)
383 %attr(755,root,root) %{_libdir}/libecore_imf.so.*
384 %attr(755,root,root) %{_libdir}/libecore_imf_evas.so.*
385
386 %files ipc
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_libdir}/libecore_ipc.so.*
389
390 %files job
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_libdir}/libecore_job.so.*
393
394 %files txt
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_libdir}/libecore_txt.so.*
397
398 %files x
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/libecore_x.so.*
401
402 %files devel
403 %defattr(644,root,root,755)
404 #%attr(755,root,root) %{_bindir}/ecore-config
405 %attr(755,root,root) %{_libdir}/libecore.so
406 %{_libdir}/libecore.la
407 %{_includedir}/Ecore.h
408 %{_pkgconfigdir}/ecore.pc
409 # modules
410 %attr(755,root,root) %{_libdir}/libecore_*.so
411 %{_libdir}/libecore_*.la
412 %{_includedir}/Ecore_*.h
413 %{_pkgconfigdir}/ecore-*.pc
414
415 %if %{with static_libs}
416 %files static
417 %defattr(644,root,root,755)
418 %{_libdir}/libecore.a
419 # modules
420 %{_libdir}/libecore_*.a
421 %endif
This page took 0.142289 seconds and 4 git commands to generate.