]> git.pld-linux.org Git - packages/dyncall.git/blob - dyncall.spec
- new
[packages/dyncall.git] / dyncall.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # manual.pdf
4 #
5 Summary:        A Generic Dynamic FFI package
6 Summary(pl.UTF-8):      Ogólny pakiet do dynamicznych wywołań obcych funkcji (FFI)
7 Name:           dyncall
8 Version:        1.1
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://dyncall.org/download
13 Source0:        https://dyncall.org/r%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  db7dab95f721dc1c0c513a7e4ab28345
15 #Patch0:        %{name}-what.patch
16 URL:            https://dyncall.org/
17 BuildRequires:  cmake >= 2.6
18 %if %{with doc}
19 BuildRequires:  texlive-format-pdflatex
20 BuildRequires:  texlive-latex
21 BuildRequires:  texlive-latex-moreverb
22 # for html
23 #BuildRequires: texlive-tex4ht
24 %endif
25 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 ia64 mips mips64 ppc ppc64 sh sparc sparcv9 sparc64
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 dyncall is a low-level toolkit providing a portable abstraction for
30 handling native code dynamically at run time.
31
32 It comprises three independent components, available as C libraries,
33 namely:
34 - 'dyncall' for making function calls,
35 - 'dyncallback' for writing generic callback handlers, and
36 - 'dynload' for loading code.
37
38 %description -l pl.UTF-8
39 dyncall to zestaw niskopoziomowych narzędzi z przenośną abstrakcją
40 dynamicznej obsługi kodu natywnego w czasie uruchomienia.
41
42 Obejmuje trzy niezależne komponenty, dostępne jako biblioteki C:
43 - dyncall do wywołań funkcji
44 - dyncallback do pisania generycznej obsługi wywołań zwrotnych
45 - dynload do ładowania kodu
46
47 %package doc
48 Summary:        Documentation for dyncall libraries
49 Summary(pl.UTF-8):      Dokumentacja bibliotek dyncall
50 Group:          Documentation
51 %if "%{_rpmversion}" >= "4.6"
52 BuildArch:      noarch
53 %endif
54
55 %description doc
56 Documentation for dyncall libraries.
57
58 %description doc -l pl.UTF-8
59 Dokumentacja bibliotek dyncall.
60
61 %prep
62 %setup -q
63
64 %build
65 install -d build
66 cd build
67 %cmake ..
68
69 %{__make}
70 cd ..
71
72 %if %{with doc}
73 cd doc/manual
74 %{__make} -f Makefile.generic pdf
75
76 # TODO: html (but broken even with SHELL=/bin/bash)
77 %endif
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS BUGS ChangeLog LICENSE README ToDo
91 %{_libdir}/libdyncall_s.a
92 %{_libdir}/libdyncallback_s.a
93 %{_libdir}/libdynload_s.a
94 %{_includedir}/dyncall*.h
95 %{_includedir}/dynload.h
96
97 %if %{with doc}
98 %files doc
99 %defattr(644,root,root,755)
100 %doc doc/manual/manual.pdf
101 %endif
This page took 0.104404 seconds and 3 git commands to generate.