]> git.pld-linux.org Git - packages/drbd-utils.git/blob - drbd-utils.spec
rel 4; add missing suids
[packages/drbd-utils.git] / drbd-utils.spec
1 Summary:        Setup tools and scripts for DRBD
2 Summary(pl.UTF-8):      Narzędzie konfiguracyjne i skrypty dla DRBD
3 Summary(pt_BR.UTF-8):   Utilitários para gerenciar dispositivos DRBD
4 Name:           drbd-utils
5 Version:        8.9.7
6 Release:        4
7 License:        GPL v2+
8 Group:          Applications/System
9 Source0:        http://www.drbd.org/download/drbd/utils/%{name}-%{version}.tar.gz
10 # Source0-md5:  f2216346f8e77f352fb306ab357a8484
11 URL:            http://www.drbd.org/
12 BuildRequires:  bison
13 BuildRequires:  flex
14 BuildRequires:  rpmbuild(macros) >= 1.671
15 BuildRequires:  udev-core
16 Requires(pre):  /usr/bin/getgid
17 Requires(pre):  /usr/sbin/groupadd
18 Requires(postun):       /usr/sbin/groupdel
19 Requires:       udev-core
20 Provides:       group(haclient)
21 Obsoletes:      drbd-udev
22 Obsoletes:      drbdsetup
23 Obsoletes:      drbdsetup8
24 Conflicts:      drbdsetup
25 Conflicts:      drbdsetup24
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Setup tool and init scripts for DRBD.
30
31 %description -l pl.UTF-8
32 Narzędzie konfiguracyjne i skrypty startowe dla DRBD.
33
34 %package -n resource-agents-drbd
35 Summary:        DRBD resource agents for a cluster setup
36 Group:          Daemons
37 Requires:       drbd-utils = %{version}-%{release}
38 Requires:       resource-agents
39
40 %description -n resource-agents-drbd
41 DRBD resource agents for a cluster setup.
42
43 %package -n bash-completion-drbd
44 Summary:        bash-completion for drbd
45 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń dla drbd
46 Group:          Applications/Shells
47 Requires:       bash-completion
48 %if "%{_rpmversion}" >= "5"
49 BuildArch:      noarch
50 %endif
51
52 %description -n bash-completion-drbd
53 This package provides bash-completion for drbd.
54
55 %description -n bash-completion-drbd -l pl.UTF-8
56 Ten pakiet dostarcza bashowe uzupełnianie poleceń dla drbd.
57
58 %package -n drbd-xen
59 Summary:        Xen block device management script for DRBD
60 Group:          Applications/System
61 Requires:       drbd-utils = %{version}-%{release}
62 Requires:       xen
63
64 %description -n drbd-xen
65 This package contains a Xen block device helper script for DRBD,
66 capable of promoting and demoting DRBD resources as necessary.
67
68 %prep
69 %setup -q
70
71 %build
72 %configure \
73         --with-initscripttype=systemd \
74         --with-udev \
75         --with-xen \
76         --with-pacemaker \
77         --with-bashcompletion
78
79 %{__make} tools \
80         KVER=dummy \
81         CC="%{__cc}" \
82         OPTCFLAGS="%{rpmcflags}" \
83         LDFLAGS="%{rpmldflags}"
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{/sbin,%{_mandir}/man{5,8},%{_sysconfdir}} \
88 $RPM_BUILD_ROOT%{_sysconfdir}/ha.d/resource.d \
89         $RPM_BUILD_ROOT/var/lib/drbd
90
91 %{__make} install \
92         DRBD_ENABLE_UDEV=1 \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # Hack for borked make install
96 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/drbd-overview.8
97 ln -s drbd-overview-9.0.8 $RPM_BUILD_ROOT%{_mandir}/man8/drbd-overview.8
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %pre
103 %groupadd -g 60 haclient
104
105 %post
106 export NORESTART="yes"
107 %systemd_post drbd.service
108
109 %preun
110 %systemd_preun drbd.service
111
112 %postun
113 if [ "$1" = "0" ]; then
114         %groupremove haclient
115 fi
116 %systemd_reload
117
118 %files
119 %defattr(644,root,root,755)
120 /sbin/*
121 %attr(755,root,root) %{_sbindir}/drbdadm
122 %attr(4754,root,haclient) %{_sbindir}/drbdsetup
123 %attr(4754,root,haclient) %{_sbindir}/drbdmeta
124 %dir %{_sysconfdir}/drbd.d
125 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/drbd.conf
126 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/drbd.d/global_common.conf
127 %{systemdunitdir}/drbd.service
128 %{_mandir}/man[58]/*
129 /lib/udev/rules.d/65-drbd.rules
130 %dir /lib/drbd
131 %attr(755,root,root) /lib/drbd/drbd
132 %attr(4754,root,haclient) /lib/drbd/drbdadm-*
133 %attr(4754,root,haclient) /lib/drbd/drbdsetup-*
134 %{systemdtmpfilesdir}/drbd.conf
135 %dir %{_prefix}/lib/drbd
136 %attr(755,root,root) %{_prefix}/lib/drbd/*
137 %attr(755,root,root) %{_sbindir}/drbd-overview
138 %attr(750,root,root) %dir /var/lib/drbd
139
140 %files -n resource-agents-drbd
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_sysconfdir}/ha.d/resource.d/drbddisk
143 %attr(755,root,root) %{_sysconfdir}/ha.d/resource.d/drbdupper
144 %dir %{_prefix}/lib/ocf/resource.d/linbit
145 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/linbit/*
146
147 %files -n bash-completion-drbd
148 %defattr(644,root,root,755)
149 /etc/bash_completion.d/drbdadm
150
151 %files -n drbd-xen
152 %defattr(644,root,root,755)
153 %{_sysconfdir}/xen/scripts/block-drbd
This page took 0.079716 seconds and 3 git commands to generate.