]> git.pld-linux.org Git - packages/dragonbox.git/blob - dragonbox.spec
- new
[packages/dragonbox.git] / dragonbox.spec
1 Summary:        Dragonbox float-to-string conversion algorithm implementation
2 Summary(pl.UTF-8):      Implementacja algorytmu Dragonbox do zamiany liczb zmiennoprzecinkowych na łańcuchy znaków
3 Name:           dragonbox
4 Version:        1.1.3
5 Release:        1
6 License:        Apache v2.0 with LLVM Exceptions or Boost v1.0
7 Group:          Development/Libraries
8 #Source0Download: https://github.com/jk-jeon/dragonbox/releases
9 Source0:        https://github.com/jk-jeon/dragonbox/archive/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  889dc00db9612c6949a4ccf8115e0e6a
11 URL:            https://github.com/jk-jeon/dragonbox
12 BuildRequires:  cmake >= 3.14
13 BuildRequires:  rpmbuild(macros) >= 1.605
14 BuildRequires:  libstdc++-devel >= 6:7
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This library is a reference implementation of Dragonbox in C++.
19
20 Dragonbox is a float-to-string conversion algorithm based on a
21 beautiful algorithm Schubfach
22 <https://drive.google.com/open?id=1luHhyQF9zKlM8yJ1nebU0OgVYhfC6CBN>,
23 developed by Raffaello Giulietti in 2017-2018.
24
25 %description -l pl.UTF-8
26 Ta biblioteka to referencyjna implementacja algorytmu Dragonbox w C++.
27
28 Dragonbox to algorytm konwersji liczb zmiennoprzecinkowych na łańcuchy
29 znaków oparty na pięknym algorytmie Schubfach
30 <https://drive.google.com/open?id=1luHhyQF9zKlM8yJ1nebU0OgVYhfC6CBN>,
31 stworzonym przez Raffaello Giulietti w 2017-2018.
32
33 %package devel
34 Summary:        Dragonbox float-to-string conversion algorithm implementation
35 Summary(pl.UTF-8):      Implementacja algorytmu Dragonbox do zamiany liczb zmiennoprzecinkowych na łańcuchy znaków
36 Group:          Development/Libraries
37 Requires:       libstdc++-devel >= 6:7
38
39 %description devel
40 This library is a reference implementation of Dragonbox in C++.
41
42 Dragonbox is a float-to-string conversion algorithm based on a
43 beautiful algorithm Schubfach
44 <https://drive.google.com/open?id=1luHhyQF9zKlM8yJ1nebU0OgVYhfC6CBN>,
45 developed by Raffaello Giulietti in 2017-2018.
46
47 %description devel -l pl.UTF-8
48 Ta biblioteka to referencyjna implementacja algorytmu Dragonbox w C++.
49
50 Dragonbox to algorytm konwersji liczb zmiennoprzecinkowych na łańcuchy
51 znaków oparty na pięknym algorytmie Schubfach
52 <https://drive.google.com/open?id=1luHhyQF9zKlM8yJ1nebU0OgVYhfC6CBN>,
53 stworzonym przez Raffaello Giulietti w 2017-2018.
54
55 %prep
56 %setup -q
57
58 %build
59 %cmake -B build
60
61 %{__make} -C build
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} -C build install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files devel
73 %defattr(644,root,root,755)
74 %doc LICENSE-Apache2-LLVM LICENSE-Boost README.md
75 %{_libdir}/libdragonbox_to_chars.a
76 %{_includedir}/dragonbox-%{version}
77 %{_libdir}/cmake/dragonbox-%{version}
This page took 0.074651 seconds and 3 git commands to generate.