]> git.pld-linux.org Git - packages/draco.git/blob - draco.spec
- new; system-gtest patch from Fedora
[packages/draco.git] / draco.spec
1 Summary:        Draco 3D graphics compression library
2 Summary(pl.UTF-8):      Draco - biblioteka kompresji grafiki 3D
3 Name:           draco
4 Version:        1.5.6
5 Release:        1
6 License:        Apache v2.0
7 Group:          Libraries
8 #Source0Download: https://github.com/google/draco/releases
9 Source0:        https://github.com/google/draco/archive/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  dbe3a9e286ee5b79016470349d78b2a3
11 Patch0:         %{name}-system-gtest.patch
12 URL:            https://github.com/google/draco
13 BuildRequires:  cmake >= 3.12
14 BuildRequires:  gtest-devel
15 BuildRequires:  libstdc++-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Draco is a library for compressing and decompressing 3D geometric
20 meshes and point clouds. It is intended to improve the storage and
21 transmission of 3D graphics.
22
23 Draco was designed and built for compression efficiency and speed. The
24 code supports compressing points, connectivity information, texture
25 coordinates, color information, normals, and any other generic
26 attributes associated with geometry. With Draco, applications using 3D
27 graphics can be significantly smaller without compromising visual
28 fidelity. For users, this means apps can now be downloaded faster, 3D
29 graphics in the browser can load quicker, and VR and AR scenes can now
30 be transmitted with a fraction of the bandwidth and rendered quickly.
31
32 Draco is released as C++ source code that can be used to compress 3D
33 graphics as well as C++ and Javascript decoders for the encoded data.
34
35 %description -l pl.UTF-8
36 Draco to biblioteka do kompresji i dekompresji trójwymiarowych siatek
37 geometrycznych i chmur punktów. Ma za zadanie usprawnić przechowywanie
38 i transmisję grafiki 3D.
39
40 Biblioteka została zaprojektowana z myślą o wydajności kompresji i
41 szybkości. Kod obsługuje kompresję punktów, informacji o połączeniach,
42 współrzędnych tekstur, informacji o kolorach, wektorów normalnych oraz
43 dowolnych innych atrybutów związnych z geometrią. Przy użyciu Draco
44 aplikacje wykorzystujące grafikę 3D mogą być znacząco mniejsze bez
45 poświęcania doznań wizualnych. Dla użytkowników oznacza to, że
46 aplikacje mogą być pobrane szybciej, grafika 3D w przeglądarce może
47 ładować się szybciej, a sceny VR i AR mogą być przesyłane z mniejszym
48 zużyciem sieci i szybko renderowane.
49
50 Draco zawiera kod C++ do kompresji grafiki 3D oraz dekodery w C++ i
51 Javascripcie.
52
53 %package devel
54 Summary:        Header files for draco library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki draco
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description devel
60 Header files for draco library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki draco.
64
65 %package static
66 Summary:        Static draco library
67 Summary(pl.UTF-8):      Statyczna biblioteka draco
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static draco library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka draco.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 install -d build
83 cd build
84 %cmake ..
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} -C build install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__mv} $RPM_BUILD_ROOT%{_bindir}/draco_decoder{-%{version},}
95 %{__mv} $RPM_BUILD_ROOT%{_bindir}/draco_encoder{-%{version},}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS README.md
106 %attr(755,root,root) %{_bindir}/draco_decoder
107 %attr(755,root,root) %{_bindir}/draco_encoder
108 %attr(755,root,root) %{_libdir}/libdraco.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libdraco.so.8
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libdraco.so
114 %{_includedir}/draco
115 %{_pkgconfigdir}/draco.pc
116 %{_datadir}/cmake/draco
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libdraco.a
This page took 0.036445 seconds and 3 git commands to generate.