]> git.pld-linux.org Git - packages/doxygen.git/blob - doxygen.spec
76e6c02973413ce18fa6c77a68d9265966526350
[packages/doxygen.git] / doxygen.spec
1 #
2 # Conditional build:
3 %bcond_without  qt      # without doxywizard (qt-based)
4 #
5 Summary:        Doxygen is the documentation system for C/C++
6 Summary(es.UTF-8):      Doxygen es el sistema de documentación para C/C++
7 Summary(pl.UTF-8):      System dokumentowania dla C/C++
8 Summary(pt_BR.UTF-8):   Um sistema de documentação para C/C++
9 Summary(ru.UTF-8):      Система документирования для C та C++
10 Summary(uk.UTF-8):      Система документування для C та C++
11 Name:           doxygen
12 Version:        1.8.8
13 Release:        1
14 Epoch:          1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
18 # Source0-md5:  0cbe6912fcac302a984bfcfb9231fec9
19 Patch0:         %{name}-qt-dirs.patch
20 URL:            http://www.doxygen.org/
21 %{?with_qt:BuildRequires:       QtGui-devel >= 4.3}
22 %{?with_qt:BuildRequires:       QtXml-devel >= 4.3}
23 BuildRequires:  bison
24 BuildRequires:  flex
25 BuildRequires:  ghostscript
26 BuildRequires:  ghostscript-fonts-std
27 BuildRequires:  libpng-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  perl-base
30 %{?with_qt:BuildRequires:       qt4-build >= 4.3}
31 %{?with_qt:BuildRequires:       qt4-qmake >= 4.3}
32 BuildRequires:  texlive-latex
33 BuildRequires:  texlive-pdftex
34 # I don't know what is the exact names in TI, please correct
35 %if "%{pld_release}" == "th"
36 Suggests:       texlive-fonts-larm
37 Suggests:       texlive-latex-cyrillic
38 Suggests:       texlive-latex-extend
39 Suggests:       texlive-makeindex
40 %endif
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 # because of qt
44 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
45
46 %description
47 Doxygen is a documentation system for C, C++ and IDL. It can generate
48 an on-line class browser (in HTML) and/or an off-line reference manual
49 (in LaTeX) from a set of documented source files. There is also
50 support for generating man pages and for converting the generated
51 output into Postscript, hyperlinked PDF or compressed HTML. The
52 documentation is extracted directly from the sources.
53
54 Doxygen can also be configured to extract the code-structure from
55 undocumented source files. This can be very useful to quickly find
56 your way in large source distributions.
57
58 %description -l es.UTF-8
59 Doxygen es un sistema de documentación para C, C++ e IDL. Es capaz de
60 generar un navegador on-line entre clases (en HTML) y-o un manual
61 off-line de referencia (en LaTeX) a partir de un conjunto de ficheros
62 de código fuente documentados. También hay soporte para generar
63 páginas man y para convertir la generada salida an Postscript, PDF con
64 hiperenlaces o HTML comprimido. La documentación se extrae
65 directamente de los fuentes.
66
67 Doxygen puede también ser configurado a extraer la estructura del
68 código de código fuente que carece de documentación. Eso puede ser muy
69 útil para orientarse rápidamente en distribuciones grandes de código
70 fuente.
71
72 %description -l pl.UTF-8
73 Doxygen to system dokumentowania dla C, C++ i IDL. Może generować
74 dokumentację klas on-line (w HTML-u) lub podręcznik off-line (w
75 LaTeXu) z zestawu udokumentowanych plików źródłowych. Ma także
76 możliwość generowania stron man i konwersji na Postscript, PDF z
77 hiperłączami oraz skompresowany HTML. Dokumentacja jest wyciągana
78 bezpośrednio ze źródeł.
79
80 Doxygen może być skonfigurowany także do wyciągania struktury kodu z
81 nieudokumentowanych plików źródłowych. Może być to przydatne do
82 szybkiego odnalezienia się w dużych źródłach.
83
84 %description -l pt_BR.UTF-8
85 Doxygen é uma sistema de documentação para C e C++ que gera um class
86 browser on-line (em HTML) e/ou um manual de referencia off-line (em
87 LaTeX) a partir de um conjunto de fontes documentados. A documentação
88 é extraida diretamente a partir dos fontes.
89
90 %description -l ru.UTF-8
91 Doxygen - это система документирования для C, C++ и IDL. Она может
92 создать онлайновый броузер классов (в HTML) и/или оффлайновый
93 справочник (в LaTeX) из набора документированных файлов. Есть также
94 поддержка создания man-страниц и конвертации сгенерированного вывода в
95 Postscript, PDF с гиперссылками и компрессированный HTML. Документация
96 извлекается непосредственно из исходных файлов.
97
98 Doxygen можно также сконфигурировать для получения структуры кода из
99 нелокументированных исходных файлов. Это может быть очень полезным для
100 того, чтобы бысто разобраться в большом проекте.
101
102 %description -l uk.UTF-8
103 Doxygen - це система документування для C, C++ та IDL. Вона може
104 створити онлайновий броузер класів (в HTML) та/чи оффлайновий довідник
105 (в LaTeX) з набору документованих вихідних файлів. Є також підтримка
106 для створення man-сторінок та конвертації згенерованого виводу в
107 Postscript, PDF з гіперлінками та компресований HTML. Документація
108 видобувається безпосердньо з вихідних файлів.
109
110 Doxygen можна також зконфігурувати для отримання структури коду з
111 недокументованих вихідних файлів. Це може бути дуже корисним для того,
112 щоб швидко розібратися у великому проекті.
113
114 %package doxywizard
115 Summary:        A GUI front-end for creating and editing configuration files
116 Summary(es.UTF-8):      Un front-end GUI para crear y editar ficheros de configuración
117 Summary(pl.UTF-8):      GUI do tworzenia i edycji plików konfiguracyjnych
118 Summary(pt_BR.UTF-8):   Wizard gráfico para o Doxygen
119 Group:          X11/Applications
120 Requires:       %{name} = %{epoch}:%{version}-%{release}
121
122 %description doxywizard
123 Doxywizard is a GUI front-end for creating and editing configuration
124 files that are used by doxygen.
125
126 %description doxywizard -l es.UTF-8
127 Doxywizard es un front-end GUI para crear y editar los ficheros de
128 configuración que son usados por doxygen.
129
130 %description doxywizard -l pl.UTF-8
131 Doxywizard to frontend z graficznym interfejsem do tworzenia i edycji
132 plików konfiguracyjnych używanych przez doxygen.
133
134 %description doxywizard -l pt_BR.UTF-8
135 Wizard gráfico para o Doxygen.
136
137 %prep
138 %setup -q
139 %patch0 -p1
140
141 %build
142 # don't change it to %%configure, not autoconf-generated!
143 ./configure \
144         --prefix %{_prefix} \
145         --perl %{__perl} \
146         --install %{_bindir}/install \
147         %{?with_qt:--with-doxywizard}
148
149 %{__make} \
150         CC="%{__cc}" \
151         CXX="%{__cxx}" \
152         LINK="%{__cxx}" \
153         QMAKE="%{_bindir}/qmake-qt4" \
154         QTDIR="%{_prefix}" \
155         CFLAGS="%{rpmcflags}" \
156         CXXFLAGS="%{rpmcxxflags} -DQT_LITE_UNICODE -DNODEBUG" \
157         LFLAGS="%{rpmldflags}"
158
159 %{__make} docs
160 #%%{__make} pdf
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %files
172 %defattr(644,root,root,755)
173 %doc html examples README.md
174 %attr(755,root,root) %{_bindir}/doxygen
175 %{_mandir}/man1/doxygen.1*
176
177 %if %{with qt}
178 %files doxywizard
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_bindir}/doxywizard
181 %{_mandir}/man1/doxywizard.1*
182 %endif
This page took 0.046344 seconds and 2 git commands to generate.