]> git.pld-linux.org Git - packages/doxygen.git/blob - doxygen.spec
backport fixes for flex 2.6
[packages/doxygen.git] / doxygen.spec
1 #
2 # Conditional build:
3 %bcond_without  qt      # without doxywizard (qt-based)
4 #
5 Summary:        Doxygen is the documentation system for C/C++
6 Summary(es.UTF-8):      Doxygen es el sistema de documentación para C/C++
7 Summary(pl.UTF-8):      System dokumentowania dla C/C++
8 Summary(pt_BR.UTF-8):   Um sistema de documentação para C/C++
9 Summary(ru.UTF-8):      Система документирования для C та C++
10 Summary(uk.UTF-8):      Система документування для C та C++
11 Name:           doxygen
12 Version:        1.8.8
13 Release:        2
14 Epoch:          1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
18 # Source0-md5:  0cbe6912fcac302a984bfcfb9231fec9
19 Patch0:         %{name}-qt-dirs.patch
20 Patch1:         flex2.6.patch
21 URL:            http://www.doxygen.org/
22 %{?with_qt:BuildRequires:       QtGui-devel >= 4.3}
23 %{?with_qt:BuildRequires:       QtXml-devel >= 4.3}
24 BuildRequires:  bison
25 BuildRequires:  flex
26 BuildRequires:  ghostscript
27 BuildRequires:  ghostscript-fonts-std
28 BuildRequires:  libpng-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  perl-base
31 %{?with_qt:BuildRequires:       qt4-build >= 4.3}
32 %{?with_qt:BuildRequires:       qt4-qmake >= 4.3}
33 BuildRequires:  texlive-latex
34 BuildRequires:  texlive-pdftex
35 # I don't know what is the exact names in TI, please correct
36 %if "%{pld_release}" == "th"
37 Suggests:       texlive-fonts-larm
38 Suggests:       texlive-latex-cyrillic
39 Suggests:       texlive-latex-extend
40 Suggests:       texlive-latex-wasysym
41 Suggests:       texlive-makeindex
42 %endif
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 # because of qt
46 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
47
48 %description
49 Doxygen is a documentation system for C, C++ and IDL. It can generate
50 an on-line class browser (in HTML) and/or an off-line reference manual
51 (in LaTeX) from a set of documented source files. There is also
52 support for generating man pages and for converting the generated
53 output into Postscript, hyperlinked PDF or compressed HTML. The
54 documentation is extracted directly from the sources.
55
56 Doxygen can also be configured to extract the code-structure from
57 undocumented source files. This can be very useful to quickly find
58 your way in large source distributions.
59
60 %description -l es.UTF-8
61 Doxygen es un sistema de documentación para C, C++ e IDL. Es capaz de
62 generar un navegador on-line entre clases (en HTML) y-o un manual
63 off-line de referencia (en LaTeX) a partir de un conjunto de ficheros
64 de código fuente documentados. También hay soporte para generar
65 páginas man y para convertir la generada salida an Postscript, PDF con
66 hiperenlaces o HTML comprimido. La documentación se extrae
67 directamente de los fuentes.
68
69 Doxygen puede también ser configurado a extraer la estructura del
70 código de código fuente que carece de documentación. Eso puede ser muy
71 útil para orientarse rápidamente en distribuciones grandes de código
72 fuente.
73
74 %description -l pl.UTF-8
75 Doxygen to system dokumentowania dla C, C++ i IDL. Może generować
76 dokumentację klas on-line (w HTML-u) lub podręcznik off-line (w
77 LaTeXu) z zestawu udokumentowanych plików źródłowych. Ma także
78 możliwość generowania stron man i konwersji na Postscript, PDF z
79 hiperłączami oraz skompresowany HTML. Dokumentacja jest wyciągana
80 bezpośrednio ze źródeł.
81
82 Doxygen może być skonfigurowany także do wyciągania struktury kodu z
83 nieudokumentowanych plików źródłowych. Może być to przydatne do
84 szybkiego odnalezienia się w dużych źródłach.
85
86 %description -l pt_BR.UTF-8
87 Doxygen é uma sistema de documentação para C e C++ que gera um class
88 browser on-line (em HTML) e/ou um manual de referencia off-line (em
89 LaTeX) a partir de um conjunto de fontes documentados. A documentação
90 é extraida diretamente a partir dos fontes.
91
92 %description -l ru.UTF-8
93 Doxygen - это система документирования для C, C++ и IDL. Она может
94 создать онлайновый броузер классов (в HTML) и/или оффлайновый
95 справочник (в LaTeX) из набора документированных файлов. Есть также
96 поддержка создания man-страниц и конвертации сгенерированного вывода в
97 Postscript, PDF с гиперссылками и компрессированный HTML. Документация
98 извлекается непосредственно из исходных файлов.
99
100 Doxygen можно также сконфигурировать для получения структуры кода из
101 нелокументированных исходных файлов. Это может быть очень полезным для
102 того, чтобы бысто разобраться в большом проекте.
103
104 %description -l uk.UTF-8
105 Doxygen - це система документування для C, C++ та IDL. Вона може
106 створити онлайновий броузер класів (в HTML) та/чи оффлайновий довідник
107 (в LaTeX) з набору документованих вихідних файлів. Є також підтримка
108 для створення man-сторінок та конвертації згенерованого виводу в
109 Postscript, PDF з гіперлінками та компресований HTML. Документація
110 видобувається безпосердньо з вихідних файлів.
111
112 Doxygen можна також зконфігурувати для отримання структури коду з
113 недокументованих вихідних файлів. Це може бути дуже корисним для того,
114 щоб швидко розібратися у великому проекті.
115
116 %package doxywizard
117 Summary:        A GUI front-end for creating and editing configuration files
118 Summary(es.UTF-8):      Un front-end GUI para crear y editar ficheros de configuración
119 Summary(pl.UTF-8):      GUI do tworzenia i edycji plików konfiguracyjnych
120 Summary(pt_BR.UTF-8):   Wizard gráfico para o Doxygen
121 Group:          X11/Applications
122 Requires:       %{name} = %{epoch}:%{version}-%{release}
123
124 %description doxywizard
125 Doxywizard is a GUI front-end for creating and editing configuration
126 files that are used by doxygen.
127
128 %description doxywizard -l es.UTF-8
129 Doxywizard es un front-end GUI para crear y editar los ficheros de
130 configuración que son usados por doxygen.
131
132 %description doxywizard -l pl.UTF-8
133 Doxywizard to frontend z graficznym interfejsem do tworzenia i edycji
134 plików konfiguracyjnych używanych przez doxygen.
135
136 %description doxywizard -l pt_BR.UTF-8
137 Wizard gráfico para o Doxygen.
138
139 %prep
140 %setup -q
141 %patch0 -p1
142 %patch1 -p1
143
144 %build
145 # don't change it to %%configure, not autoconf-generated!
146 ./configure \
147         --prefix %{_prefix} \
148         --perl %{__perl} \
149         --install %{_bindir}/install \
150         %{?with_qt:--with-doxywizard}
151
152 %{__make} \
153         CC="%{__cc}" \
154         CXX="%{__cxx}" \
155         LINK="%{__cxx}" \
156         QMAKE="%{_bindir}/qmake-qt4" \
157         QTDIR="%{_prefix}" \
158         CFLAGS="%{rpmcflags}" \
159         CXXFLAGS="%{rpmcxxflags} -DQT_LITE_UNICODE -DNODEBUG" \
160         LFLAGS="%{rpmldflags}"
161
162 %{__make} docs
163 #%%{__make} pdf
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %files
175 %defattr(644,root,root,755)
176 %doc html examples README.md
177 %attr(755,root,root) %{_bindir}/doxygen
178 %{_mandir}/man1/doxygen.1*
179
180 %if %{with qt}
181 %files doxywizard
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/doxywizard
184 %{_mandir}/man1/doxywizard.1*
185 %endif
This page took 0.048362 seconds and 3 git commands to generate.