]> git.pld-linux.org Git - packages/dokuwiki.git/blob - dokuwiki.spec
- initial spec
[packages/dokuwiki.git] / dokuwiki.spec
1 Summary:        PHP-based Wiki webapplication
2 Name:           dokuwiki
3 Version:        20070626b
4 Release:        0.1
5 License:        GPL v2
6 Group:          Applications/WWW
7 Source0:        http://www.splitbrain.org/_media/projects/dokuwiki/%{name}-2007-06-26b.tgz
8 # Source0-md5:  84e9b5e8e617658bb0264aa3836f23b3
9 URL:            http://phpwiki.sourceforge.net/
10 BuildRequires:  rpmbuild(macros) >= 1.268
11 Requires:       webapps
12 Requires:       webserver(php) >= 4.0.6
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _webapps        /etc/webapps
17 %define         _webapp         %{name}
18 %define         _sysconfdir     %{_webapps}/%{_webapp}
19 %define         _appdir         %{_datadir}/%{_webapp}
20
21 %description
22 DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at
23 creating documentation of any kind. It is targeted at developer teams,
24 workgroups and small companies. It has a simple but powerful syntax
25 which makes sure the datafiles remain readable outside the Wiki and
26 eases the creation of structured texts. All data is stored in plain
27 text files – no database is required.
28
29 %prep
30 %setup -q -n %{name}-2007-06-26b
31
32 cat > apache.conf <<EOF
33 Alias /%{_webapp} %{_appdir}
34 <Directory %{_appdir}/>
35 Deny from all
36 Allow from 127.0.0.1
37 </Directory>
38 EOF
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir},/var/lib/%{name}}
43
44 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
45 cp -a bin conf data inc lib $RPM_BUILD_ROOT%{_appdir}
46 #cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}
47 install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
48 install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %triggerin -- apache1 < 1.3.37-3, apache1-base
54 %webapp_register apache %{_webapp}
55
56 %triggerun -- apache1 < 1.3.37-3, apache1-base
57 %webapp_unregister apache %{_webapp}
58
59 %triggerin -- apache < 2.2.0, apache-base
60 %webapp_register httpd %{_webapp}
61
62 %triggerun -- apache < 2.2.0, apache-base
63 %webapp_unregister httpd %{_webapp}
64
65 %files
66 %defattr(644,root,root,755)
67 %doc COPYING README VERSION
68 %dir %attr(750,root,http) %{_sysconfdir}
69 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
70 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
71 %attr(670,root,http) %{_appdir}
72 %dir %attr(770,root,http) /var/lib/%{name}
This page took 0.083561 seconds and 4 git commands to generate.