]> git.pld-linux.org Git - projects/template-specs.git/blob - dokuwiki-plugin.spec
- updated
[projects/template-specs.git] / dokuwiki-plugin.spec
1 %define         plugin          PLUGIN_NAME
2 Summary:        DokuWiki PLUGIN_NAME plugin
3 Summary(pl.UTF-8):      Wtyczka PLUGIN_NAME dla DokuWiki
4 Name:           dokuwiki-plugin-%{plugin}
5 Version:        -
6 Release:        0.1
7 License:        GPL v2
8 Group:          Applications/WWW
9 Source0:        -
10 # Source0-md5:  -
11 Source1:        dokuwiki-find-lang.sh
12 URL:            http://wiki.splitbrain.org/plugin:PLUGIN_NAME
13 Requires:       dokuwiki >= 20061106
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         dokuconf        /etc/webapps/dokuwiki
18 %define         dokudir /usr/share/dokuwiki
19 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
20
21 %description
22 Plugin for DokuWiki.
23
24 %description -l pl.UTF-8
25 Wtyczka dla DokuWiki
26
27 %prep
28 %setup -q -n %{plugin}
29 if [ $(cat VERSION | tr -d -) != %{version} ]; then
30         : %%{version} mismatch, should be: $(cat VERSION | tr -d -)
31         exit 1
32 fi
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{plugindir}
37 cp -a . $RPM_BUILD_ROOT%{plugindir}
38 rm -f $RPM_BUILD_ROOT%{plugindir}/{CREDITS,changelog}
39 rm -f $RPM_BUILD_ROOT%{plugindir}/{COPYING,README,VERSION}
40
41 # find locales
42 sh %{SOURCE1} %{name}.lang
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 # force css cache refresh
49 if [ -f %{dokuconf}/local.php ]; then
50         touch %{dokuconf}/local.php
51 fi
52
53 %files -f %{name}.lang
54 %defattr(644,root,root,755)
55 %doc README CREDITS changelog
56 %dir %{plugindir}
57 %{plugindir}/*.php
58 %{plugindir}/*.css
59 %{plugindir}/conf
60 %{plugindir}/images
This page took 0.154291 seconds and 4 git commands to generate.