]> git.pld-linux.org Git - packages/docker-ce.git/blob - docker-ce.spec
correct bash-completion epoch
[packages/docker-ce.git] / docker-ce.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4 %bcond_with     vim                     # build vim syntax package (bundled in vim 7.4.979-2)
5 %bcond_with     doc                     # build manual pages
6
7 # TODO: drop P docker when docker-compose updated to use docker(engine) dep
8
9 # NOTES
10 # - https://github.com/docker/docker-ce/releases
11 # - https://github.com/moby/moby/blob/master/project/PACKAGERS.md#build-dependencies
12
13 # v1.0.0-rc10
14 %define runc_commit dc9208a
15 # v1.3.9
16 %define containerd_commit ea765ab
17 # v0.8.0-dev.2-1075-g1b91bc94
18 %define libnetwork_commit 55e924b
19 #define subver -rc2
20 Summary:        Docker CE: the open-source application container engine
21 Name:           docker-ce
22 # Using Docker-CE, Stay on Stable channel
23 # https://docs.docker.com/engine/installation/
24 Version:        19.03.14
25 Release:        2
26 License:        Apache v2.0
27 Group:          Applications/System
28 # https://github.com/docker/docker-ce/releases
29 #Source0:       https://github.com/docker/docker-ce/archive/v%{version}-ce%{subver}/%{name}-%{version}-ce%{subver}.tar.gz
30 Source0:        https://github.com/docker/docker-ce/archive/v%{version}/%{name}-%{version}.tar.gz
31 # Source0-md5:  f932ff952a0411223a90baaf5b829883
32 Source1:        https://github.com/opencontainers/runc/archive/%{runc_commit}/runc-%{runc_commit}.tar.gz
33 # Source1-md5:  b593d63c7df5a27fba615afcf411762f
34 Source2:        https://github.com/containerd/containerd/archive/%{containerd_commit}/containerd-%{containerd_commit}.tar.gz
35 # Source2-md5:  c5cee10a5fb8f6e1d5e186912725a052
36 Source3:        https://github.com/docker/libnetwork/archive/%{libnetwork_commit}/libnetwork-%{libnetwork_commit}.tar.gz
37 # Source3-md5:  a54f3443dbf78696e2470d6657fa03c1
38 Source4:        https://github.com/krallin/tini/archive/v0.18.0/tini-0.18.0.tar.gz
39 # Source4-md5:  cc3b205a1b83b8e6ed6892fc5e8ef2c3
40 Source5:        dockerd.sh
41 Source7:        docker.init
42 Source8:        docker.sysconfig
43 Patch0:         systemd.patch
44 URL:            https://www.docker.com/community-edition/
45 BuildRequires:  btrfs-progs-devel >= 3.16.1
46 BuildRequires:  cmake
47 BuildRequires:  device-mapper-devel >= 2.02.89
48 BuildRequires:  glibc-static
49 BuildRequires:  golang >= 1.12
50 BuildRequires:  libseccomp-devel >= 2.3
51 BuildRequires:  rpm-build >= 4.6
52 BuildRequires:  rpmbuild(macros) >= 1.644
53 BuildRequires:  sqlite3-devel >= 3.7.9
54 BuildRequires:  xxd
55 Requires(post,preun):   /sbin/chkconfig
56 Requires(postun):       /usr/sbin/groupdel
57 Requires(pre):  /usr/bin/getgid
58 Requires(pre):  /usr/sbin/groupadd
59 Requires:       ca-certificates
60 Requires:       iproute2 >= 3.5
61 Requires:       iptables
62 Requires:       libseccomp >= 2.3
63 Requires:       rc-scripts >= 0.4.0.10
64 Requires:       systemd-units >= 38
65 Requires:       tar >= 1:1.26
66 Requires:       uname(release) >= 3.8
67 Requires:       xz
68 Suggests:       docker-credential-helpers
69 Suggests:       git-core >= 1.7
70 Suggests:       libcgroup
71 Suggests:       xz >= 1:4.9
72 Provides:       docker = %{version}
73 Provides:       docker(engine) = %{version}
74 Provides:       group(docker)
75 Obsoletes:      docker < 18.0
76 Obsoletes:      lxc-docker < 1.1.1
77 # only runs on x64 hosts for now:
78 # https://github.com/docker/docker/issues/136
79 # https://github.com/docker/docker/issues/611
80 ExclusiveArch:  %{x8664} aarch64
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         bash_compdir    %{_datadir}/bash-completion/completions
84 %define         zsh_compdir     %{_datadir}/zsh/site-functions
85 %define         _vimdatadir             %{_datadir}/vim
86 %define         _libexecdir             %{_prefix}/lib
87
88 # binary stripped or something
89 %define         _enable_debug_packages 0
90
91 %description
92 Docker is an open source project to pack, ship and run any application
93 as a lightweight container
94
95 Docker containers are both hardware-agnostic and platform-agnostic.
96 This means that they can run anywhere, from your laptop to the largest
97 EC2 compute instance and everything in between - and they don't
98 require that you use a particular language, framework or packaging
99 system. That makes them great building blocks for deploying and
100 scaling web apps, databases and backend services without depending on
101 a particular stack or provider.
102
103 Docker is an open-source implementation of the deployment engine which
104 powers dotCloud, a popular Platform-as-a-Service. It benefits directly
105 from the experience accumulated over several years of large-scale
106 operation and support of hundreds of thousands of applications and
107 databases.
108
109 %package -n bash-completion-%{name}
110 Summary:        bash-completion for Docker
111 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla Dockera
112 Group:          Applications/Shells
113 Requires:       %{name}
114 Requires:       bash-completion >= 1:2.0
115 Obsoletes:      bash-completion-lxc-docker < 1.1.1
116 BuildArch:      noarch
117
118 %description -n bash-completion-%{name}
119 This package provides bash-completion for Docker.
120
121 %description -n bash-completion-%{name} -l pl.UTF-8
122 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
123
124 %package -n zsh-completion-%{name}
125 Summary:        zsh completion for Docker
126 Summary(pl.UTF-8):      Uzupełnianie parametrów w zsh dla poleceń Dockera
127 Group:          Applications/Shells
128 Requires:       %{name}
129 BuildArch:      noarch
130
131 %description -n zsh-completion-%{name}
132 This package provides zsh completion for Docker.
133
134 %description -n zsh-completion-%{name} -l pl.UTF-8
135 Pakiet ten dostarcza uzupełnianie w zsh dla poleceń Dockera.
136
137 %package -n vim-syntax-%{name}
138 Summary:        Vim syntax: Docker
139 Group:          Applications/Editors/Vim
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       vim-rt >= 4:7.2.170
142 Obsoletes:      vim-syntax-lxc-docker < 1.1.1
143 BuildArch:      noarch
144
145 %description -n vim-syntax-%{name}
146 This plugin provides syntax highlighting in Dockerfile.
147
148 %prep
149 %setup -q -n %{name}-%{version}%{?subver} -a1 -a2 -a3 -a4
150
151 mv runc-%{runc_commit}* runc
152 mv runc/vendor runc/src
153 ln -s ../../.. runc/src/github.com/opencontainers/runc
154
155 mv containerd-%{containerd_commit}* containerd
156 mv containerd/vendor containerd/src
157 ln -s ../../.. containerd/src/github.com/containerd/containerd
158
159 mv libnetwork-%{libnetwork_commit}* libnetwork
160 install -d libnetwork/gopath
161 mv libnetwork/vendor libnetwork/gopath/src
162 ln -s ../../../.. libnetwork/gopath/src/github.com/docker/libnetwork
163
164 mv tini-* tini
165
166 install -d components/cli/.gopath/src/github.com/docker
167 ln -s ../../../.. components/cli/.gopath/src/github.com/docker/cli
168
169 %patch0 -p1 -d components/engine
170
171 %build
172 grep -rhE "=%{runc_commit}|=%{containerd_commit}|=%{libnetwork_commit}" $(pwd)/components/engine/hack/dockerfile/install/
173
174 export VERSION=%{version}-ce # for `docker version`
175 export GITCOMMIT="PLD-Linux/%{version}" # for cli
176 export DOCKER_GITCOMMIT="PLD-Linux/%{version}" # for engine
177 export GO111MODULE=off
178
179 # build runc
180 sed -i -e 's,shell git,shell false,' runc/Makefile
181 GOPATH=$(pwd)/runc \
182 %{__make} -C runc \
183         COMMIT=$RUNC_COMMIT
184 ./runc/runc -v
185
186 # build containerd
187 GOPATH=$(pwd)/containerd \
188 %{__make} -C containerd \
189         GIT_COMMIT=$CONTAINERD_COMMIT
190
191 # build docker-proxy
192 cd libnetwork
193 GOPATH=$(pwd)/gopath \
194 go build -ldflags="-linkmode=external" \
195         -o docker-proxy \
196         github.com/docker/libnetwork/cmd/proxy
197 cd ..
198
199 # build docker-init
200 cd tini
201 cmake .
202 %{__make}
203
204 # docker cli
205 cd ../components/cli
206 GOPATH=$(pwd)/.gopath \
207 DISABLE_WARN_OUTSIDE_CONTAINER=1 \
208 %{__make} dynbinary
209 ./build/docker -v
210
211 cd ../engine
212 AUTO_GOPATH=1 \
213 bash -x hack/make.sh dynbinary
214 ./bundles/dynbinary-daemon/dockerd -v
215 %if %{with doc}
216 man/md2man-all.sh
217 %endif
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man1,/etc/{rc.d/init.d,sysconfig},%{systemdunitdir}} \
222         $RPM_BUILD_ROOT%{_sysconfdir}/docker \
223         $RPM_BUILD_ROOT%{_libexecdir} \
224         $RPM_BUILD_ROOT/var/lib/docker/{containers,execdriver,graph,image,init,network,swarm,tmp,trust,vfs,volumes}
225
226 # docker-cli
227 install -p components/cli/build/docker $RPM_BUILD_ROOT%{_bindir}/docker
228
229 # runc
230 install -p runc/runc $RPM_BUILD_ROOT%{_sbindir}/runc
231
232 # containerd
233 install -p containerd/bin/containerd $RPM_BUILD_ROOT%{_sbindir}/containerd
234 install -p containerd/bin/containerd-shim $RPM_BUILD_ROOT%{_sbindir}/containerd-shim
235 install -p containerd/bin/ctr $RPM_BUILD_ROOT%{_sbindir}/ctr
236
237 # docker-proxy
238 install -p libnetwork/docker-proxy $RPM_BUILD_ROOT%{_sbindir}/docker-proxy
239
240 # docker-init
241 install -p tini/tini $RPM_BUILD_ROOT%{_sbindir}/docker-init
242
243 # dockerd
244 cd components/engine
245 install -p bundles/dynbinary-daemon/dockerd $RPM_BUILD_ROOT%{_sbindir}/dockerd
246 cp -p contrib/init/systemd/docker.service $RPM_BUILD_ROOT%{systemdunitdir}
247 cp -p contrib/init/systemd/docker.socket $RPM_BUILD_ROOT%{systemdunitdir}
248 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
249 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_libexecdir}/dockerd
250 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/docker
251
252 # install udev rules
253 install -d $RPM_BUILD_ROOT/lib/udev/rules.d
254 cp -p contrib/udev/80-docker.rules $RPM_BUILD_ROOT/lib/udev/rules.d
255
256 # vim syntax
257 %if %{with vim}
258 install -d $RPM_BUILD_ROOT%{_vimdatadir}
259 cp -a contrib/syntax/vim/* $RPM_BUILD_ROOT%{_vimdatadir}
260 %{__rm} $RPM_BUILD_ROOT%{_vimdatadir}/{LICENSE,README.md}
261 %endif
262
263 # bash and zsh completion
264 cd ../cli/contrib/completion
265 install -d $RPM_BUILD_ROOT%{bash_compdir}
266 cp -p bash/docker $RPM_BUILD_ROOT%{bash_compdir}
267 install -d $RPM_BUILD_ROOT%{zsh_compdir}
268 cp -p zsh/_docker $RPM_BUILD_ROOT%{zsh_compdir}
269
270 %pre
271 %groupadd -g 296 docker
272
273 %post
274 /sbin/chkconfig --add docker
275 %service -n docker restart
276 %systemd_post docker.service
277
278 %preun
279 if [ "$1" = "0" ]; then
280         %service -q docker stop
281         /sbin/chkconfig --del docker
282 fi
283 %systemd_preun docker.service
284
285 %postun
286 if [ "$1" = "0" ]; then
287         %groupremove docker
288 fi
289 %systemd_reload
290
291 %triggerun -- docker < 17.0
292 # Prevent preun from docker from working
293 chmod a-x /etc/rc.d/init.d/docker
294
295 %triggerpostun -- docker < 17.0
296 # Restore what triggerun removed
297 chmod 754 /etc/rc.d/init.d/docker
298 # reinstall docker init.d links, which could be different
299 /sbin/chkconfig --del docker
300 /sbin/chkconfig --add docker
301
302 %clean
303 rm -rf $RPM_BUILD_ROOT
304
305 %files
306 %defattr(644,root,root,755)
307 %doc components/engine/{README.md,CHANGELOG.md,CONTRIBUTING.md,LICENSE,AUTHORS,NOTICE,MAINTAINERS}
308 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/docker
309 %attr(754,root,root) /etc/rc.d/init.d/docker
310 %dir %{_sysconfdir}/docker
311 %attr(755,root,root) %{_bindir}/docker
312 %attr(755,root,root) %{_sbindir}/containerd
313 %attr(755,root,root) %{_sbindir}/ctr
314 %attr(755,root,root) %{_sbindir}/containerd-shim
315 %attr(755,root,root) %{_sbindir}/docker-init
316 %attr(755,root,root) %{_sbindir}/docker-proxy
317 %attr(755,root,root) %{_sbindir}/runc
318 %attr(755,root,root) %{_sbindir}/dockerd
319 %attr(755,root,root) %{_libexecdir}/dockerd
320 %{systemdunitdir}/docker.service
321 %{systemdunitdir}/docker.socket
322 /lib/udev/rules.d/80-docker.rules
323
324 %dir %attr(700,root,root) /var/lib/docker
325 %dir %attr(700,root,root) /var/lib/docker/containers
326 %dir %attr(700,root,root) /var/lib/docker/execdriver
327 %dir %attr(700,root,root) /var/lib/docker/graph
328 %dir %attr(700,root,root) /var/lib/docker/image
329 %dir %attr(700,root,root) /var/lib/docker/init
330 %dir %attr(700,root,root) /var/lib/docker/network
331 %dir %attr(700,root,root) /var/lib/docker/swarm
332 %dir %attr(700,root,root) /var/lib/docker/tmp
333 %dir %attr(700,root,root) /var/lib/docker/trust
334 %dir %attr(700,root,root) /var/lib/docker/vfs
335 %dir %attr(700,root,root) /var/lib/docker/volumes
336
337 %files -n bash-completion-%{name}
338 %defattr(644,root,root,755)
339 %{bash_compdir}/docker
340
341 %files -n zsh-completion-%{name}
342 %defattr(644,root,root,755)
343 %{zsh_compdir}/_docker
344
345 %if %{with vim}
346 %files -n vim-syntax-%{name}
347 %defattr(644,root,root,755)
348 %doc components/engine/contrib/syntax/vim/{README.md,LICENSE}
349 %{_vimdatadir}/doc/dockerfile.txt
350 %{_vimdatadir}/ftdetect/dockerfile.vim
351 %{_vimdatadir}/syntax/dockerfile.vim
352 %endif
This page took 0.093602 seconds and 3 git commands to generate.