]> git.pld-linux.org Git - packages/dnssec-tools.git/blob - dnssec-tools.spec
- added glibc-2.25 patch from arch (deal with glibc after some DNSSEC bits removal...
[packages/dnssec-tools.git] / dnssec-tools.spec
1 # TODO:
2 #       - fix linking, it should link with just built, not with system, libs
3 #
4 # Conditional build:
5 %bcond_without  qt      # Qt-based GUI tools
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        DNSSEC tools
9 Summary(pl.UTF-8):      Narzędzia DNSSEC
10 Name:           dnssec-tools
11 Version:        2.2
12 Release:        8
13 License:        BSD
14 Group:          Applications/Networking
15 Source0:        http://www.dnssec-tools.org/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  ceb39b4d2376bfc4aa22f73846c11789
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-qt.patch
19 Patch2:         glibc-2.25.patch
20 URL:            http://www.dnssec-tools.org/
21 BuildRequires:  openssl-devel
22 BuildRequires:  perl-ExtUtils-MakeMaker
23 BuildRequires:  perl-Net-DNS
24 BuildRequires:  perl-Net-DNS-SEC
25 BuildRequires:  perl-TimeDate
26 BuildRequires:  perl-base
27 BuildRequires:  perl-devel >= 1:5.8.0
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 %if %{with qt}
30 BuildRequires:  Qt5Core-devel >= 5
31 BuildRequires:  Qt5Declarative-devel >= 5
32 BuildRequires:  Qt5Gui-devel >= 5
33 BuildRequires:  Qt5Network-devel >= 5
34 BuildRequires:  Qt5Qml-devel >= 5
35 BuildRequires:  Qt5Quick-devel >= 5
36 BuildRequires:  Qt5Svg-devel >= 5
37 BuildRequires:  Qt5Widgets-devel >= 5
38 BuildRequires:  Qt5Xml-devel >= 5
39 BuildRequires:  qt5-qmake >= 5
40 %endif
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       perl-%{name} = %{version}-%{release}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The goal of the DNSSEC-Tools project is to create a set of tools,
47 patches, applications, wrappers, extensions, and plugins that will
48 help ease the deployment of DNSSEC-related technologies.
49
50 %description -l pl.UTF-8
51 Celem projektu DNSSEC-Tools jest stworzenie zbioru narzędzi, łatek,
52 aplikacji, wrapperów, rozszerzeń i wtyczek pomagających przy wdrażaniu
53 technologii związanych z DNSSEC.
54
55 %package gui
56 Summary:        DNSSEC tools with GUI
57 Summary(pl.UTF-8):      Narzędzia DNSSEC z GUI
58 Group:          X11/Applications
59 Requires:       %{name}-libs = %{version}-%{release}
60
61 %description gui
62 DNSSEC tools with Qt-based GUI: dnssec-check, dnssec-nodes,
63 dnssec-system-tray and lookup.
64
65 %description gui -l pl.UTF-8
66 Narzędzia DNSSEC z opartym na Qt graficznym interfejsem użytkownika:
67 dnssec-check, dnssec-nodes, dnssec-system-tray oraz lookup.
68
69 %package libs
70 Summary:        DNSSEC libraries
71 Summary(pl.UTF-8):      Biblioteki DNSSEC
72 Group:          Libraries
73
74 %description libs
75 DNSSEC libraries.
76
77 %description libs -l pl.UTF-8
78 Biblioteki DNSSEC.
79
80 %package devel
81 Summary:        Header files for DNSSEC libraries
82 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNSSEC
83 Group:          Development/Libraries
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       openssl-devel
86
87 %description devel
88 Header files for DNSSEC libraries.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe bibliotek DNSSEC.
92
93 %package static
94 Summary:        Static DNSSEC libraries
95 Summary(pl.UTF-8):      Statyczne biblioteki DNSSEC
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static DNSSEC libraries.
101
102 %description static -l pl.UTF-8
103 Statyczne biblioteki DNSSEC.
104
105 %package -n perl-%{name}
106 Summary:        Perl modules supporting DNSSEC
107 Summary(pl.UTF-8):      Moduły Perla wspierające DNSSEC
108 Group:          Development/Languages/Perl
109 Requires:       %{name}-libs = %{version}-%{release}
110 Requires:       perl-Net-DNS
111 Requires:       perl-Net-DNS-SEC
112
113 %description -n perl-%{name}
114 Perl modules supporting DNSSEC.
115
116 %description -n perl-%{name} -l pl.UTF-8
117 Moduły Perla wspierające DNSSEC.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124
125 %build
126 %configure \
127         ac_cv_lib_nsl_inet_ntop=no \
128         --disable-bind-checks \
129         --with-dlv \
130         --with-ipv6 \
131         --with-nsec3 \
132         --with-perl-build-args='INSTALLDIRS=vendor'
133 %{__make} -j1
134
135 %if %{with qt}
136 cd validator/apps
137 for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
138         cd $d
139         qmake-qt5 \
140                 PREFIX=%{_prefix} \
141                 QMAKE_CXX="%{__cxx}" \
142                 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
143                 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
144         %{__make}
145         cd ..
146 done
147 %endif
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 %{__make} -j1 install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 %if %{with qt}
155 for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
156         %{__make} install -C validator/apps/$d \
157                 DESTDIR=$RPM_BUILD_ROOT \
158                 INSTALL_ROOT=$RPM_BUILD_ROOT
159 done
160
161 # omitted from make install
162 install -Dp validator/apps/dnssec-check/images/dnssec-check-32x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/dnssec-check.png
163 install -Dp validator/apps/dnssec-check/images/dnssec-check-48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/dnssec-check.png
164 install -Dp validator/apps/dnssec-check/images/dnssec-check-64x64.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/64x64/apps/dnssec-check.png
165 install -Dp validator/apps/dnssec-check/images/dnssec-check-512.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/512x512/apps/dnssec-check.png
166 install -Dp validator/apps/dnssec-check/images/dnssec-check.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/dnssec-check.svg
167 sed -e 's,^Exec=.*,Exec=%{_bindir}/dnssec-check,' validator/apps/dnssec-check/dnssec-check.desktop >$RPM_BUILD_ROOT%{_desktopdir}/dnssec-check.desktop
168 %endif
169
170 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DNS/SEC/examples.pl \
171         $RPM_BUILD_ROOT%{_mandir}/man3/Net::DNS::SEC::examples.3pm
172 find $RPM_BUILD_ROOT%{perl_vendorarch}/auto -name .packlist | xargs -r %{__rm}
173 find $RPM_BUILD_ROOT%{perl_vendorarch} -name '*.pod' | xargs -r %{__rm}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   libs -p /sbin/ldconfig
179 %postun libs -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 %doc COPYING ChangeLog NEWS README
184 %attr(755,root,root) %{_bindir}/blinkenlights
185 %attr(755,root,root) %{_bindir}/bubbles
186 %attr(755,root,root) %{_bindir}/buildrealms
187 %attr(755,root,root) %{_bindir}/check-zone-expiration
188 %attr(755,root,root) %{_bindir}/cleanarch
189 %attr(755,root,root) %{_bindir}/cleankrf
190 %attr(755,root,root) %{_bindir}/convertar
191 %attr(755,root,root) %{_bindir}/dnspktflow
192 %attr(755,root,root) %{_bindir}/donuts
193 %attr(755,root,root) %{_bindir}/donutsd
194 %attr(755,root,root) %{_bindir}/drawvalmap
195 %attr(755,root,root) %{_bindir}/dt-danechk
196 %attr(755,root,root) %{_bindir}/dt-getaddr
197 %attr(755,root,root) %{_bindir}/dt-gethost
198 %attr(755,root,root) %{_bindir}/dt-getname
199 %attr(755,root,root) %{_bindir}/dt-getquery
200 %attr(755,root,root) %{_bindir}/dt-getrrset
201 %attr(755,root,root) %{_bindir}/dt-libval_check_conf
202 %attr(755,root,root) %{_bindir}/dt-validate
203 %attr(755,root,root) %{_bindir}/dtck
204 %attr(755,root,root) %{_bindir}/dtconf
205 %attr(755,root,root) %{_bindir}/dtconfchk
206 %attr(755,root,root) %{_bindir}/dtdefs
207 %attr(755,root,root) %{_bindir}/dtinitconf
208 %attr(755,root,root) %{_bindir}/dtrealms
209 %attr(755,root,root) %{_bindir}/expchk
210 %attr(755,root,root) %{_bindir}/fixkrf
211 %attr(755,root,root) %{_bindir}/genkrf
212 %attr(755,root,root) %{_bindir}/getdnskeys
213 %attr(755,root,root) %{_bindir}/getds
214 %attr(755,root,root) %{_bindir}/grandvizier
215 %attr(755,root,root) %{_bindir}/keyarch
216 %attr(755,root,root) %{_bindir}/keymod
217 %attr(755,root,root) %{_bindir}/krfcheck
218 %attr(755,root,root) %{_bindir}/lights
219 %attr(755,root,root) %{_bindir}/lsdnssec
220 %attr(755,root,root) %{_bindir}/lskrf
221 %attr(755,root,root) %{_bindir}/lsrealm
222 %attr(755,root,root) %{_bindir}/lsroll
223 %attr(755,root,root) %{_bindir}/maketestzone
224 %attr(755,root,root) %{_bindir}/mapper
225 %attr(755,root,root) %{_bindir}/realmchk
226 %attr(755,root,root) %{_bindir}/realmctl
227 %attr(755,root,root) %{_bindir}/realminit
228 %attr(755,root,root) %{_bindir}/realmset
229 %attr(755,root,root) %{_bindir}/rollchk
230 %attr(755,root,root) %{_bindir}/rollctl
231 %attr(755,root,root) %{_bindir}/rollerd
232 %attr(755,root,root) %{_bindir}/rollinit
233 %attr(755,root,root) %{_bindir}/rolllog
234 %attr(755,root,root) %{_bindir}/rollrec-editor
235 %attr(755,root,root) %{_bindir}/rollset
236 %attr(755,root,root) %{_bindir}/signset-editor
237 %attr(755,root,root) %{_bindir}/tachk
238 %attr(755,root,root) %{_bindir}/timetrans
239 %attr(755,root,root) %{_bindir}/trustman
240 %attr(755,root,root) %{_bindir}/zonesigner
241 %dir %{_sysconfdir}/dnssec-tools
242 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/dnssec-tools.conf
243 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/validator-testcases
244 %{_datadir}/%{name}
245 %{_mandir}/man1/blinkenlights.1p*
246 %{_mandir}/man1/buildrealms.1p*
247 %{_mandir}/man1/bubbles.1p*
248 %{_mandir}/man1/check-zone-expiration.1p*
249 %{_mandir}/man1/cleanarch.1p*
250 %{_mandir}/man1/cleankrf.1p*
251 %{_mandir}/man1/convertar.1p*
252 %{_mandir}/man1/dnspktflow.1p*
253 %{_mandir}/man1/dnssec-tools.1*
254 %{_mandir}/man1/donuts.1p*
255 %{_mandir}/man1/donutsd.1p*
256 %{_mandir}/man1/drawvalmap.1p*
257 %{_mandir}/man1/dt-danechk.1*
258 %{_mandir}/man1/dt-libval_check_conf.1*
259 %{_mandir}/man1/dt-getaddr.1*
260 %{_mandir}/man1/dt-gethost.1*
261 %{_mandir}/man1/dt-getname.1*
262 %{_mandir}/man1/dt-getquery.1*
263 %{_mandir}/man1/dt-getrrset.1*
264 %{_mandir}/man1/dt-validate.1*
265 %{_mandir}/man1/dtck.1p*
266 %{_mandir}/man1/dtconf.1p*
267 %{_mandir}/man1/dtconfchk.1p*
268 %{_mandir}/man1/dtdefs.1p*
269 %{_mandir}/man1/dtinitconf.1p*
270 %{_mandir}/man1/dtrealms.1p*
271 %{_mandir}/man1/expchk.1p*
272 %{_mandir}/man1/fixkrf.1p*
273 %{_mandir}/man1/genkrf.1p*
274 %{_mandir}/man1/getdnskeys.1p*
275 %{_mandir}/man1/getds.1p*
276 %{_mandir}/man1/grandvizier.1p*
277 %{_mandir}/man1/keyarch.1p*
278 %{_mandir}/man1/keymod.1p*
279 %{_mandir}/man1/krfcheck.1p*
280 %{_mandir}/man1/lights.1p*
281 %{_mandir}/man1/lsdnssec.1p*
282 %{_mandir}/man1/lskrf.1p*
283 %{_mandir}/man1/lsrealm.1p*
284 %{_mandir}/man1/lsroll.1p*
285 %{_mandir}/man1/maketestzone.1p*
286 %{_mandir}/man1/mapper.1p*
287 %{_mandir}/man1/realmchk.1p*
288 %{_mandir}/man1/realmctl.1p*
289 %{_mandir}/man1/realminit.1p*
290 %{_mandir}/man1/realmset.1p*
291 %{_mandir}/man1/rollchk.1p*
292 %{_mandir}/man1/rollctl.1p*
293 %{_mandir}/man1/rollerd.1p*
294 %{_mandir}/man1/rollinit.1p*
295 %{_mandir}/man1/rolllog.1p*
296 %{_mandir}/man1/rollrec-editor.1p*
297 %{_mandir}/man1/rollset.1p*
298 %{_mandir}/man1/signset-editor.1p*
299 %{_mandir}/man1/tachk.1p*
300 %{_mandir}/man1/timetrans.1p*
301 %{_mandir}/man1/trustman.1p*
302 %{_mandir}/man1/zonesigner.1p*
303
304 %if %{with qt}
305 %files gui
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_bindir}/dnssec-check
308 %attr(755,root,root) %{_bindir}/dnssec-nodes
309 %attr(755,root,root) %{_bindir}/dnssec-system-tray
310 %attr(755,root,root) %{_bindir}/lookup
311 %{_desktopdir}/dnssec-check.desktop
312 %{_desktopdir}/dnssec-nodes.desktop
313 %{_desktopdir}/lookup.desktop
314 %{_iconsdir}/hicolor/48x48/apps/lookup.png
315 %{_iconsdir}/hicolor/*x*/apps/dnssec-check.png
316 %{_iconsdir}/hicolor/scalable/apps/dnssec-check.svg
317 %{_pixmapsdir}/lookup.xpm
318 %endif
319
320 %files libs
321 %defattr(644,root,root,755)
322 %attr(755,root,root) %{_libdir}/libsres.so.*.*.*
323 %attr(755,root,root) %ghost %{_libdir}/libsres.so.15
324 %attr(755,root,root) %{_libdir}/libval-threads.so.*.*.*
325 %attr(755,root,root) %ghost %{_libdir}/libval-threads.so.15
326 %attr(755,root,root) %{_libdir}/libval_shim.so.*.*.*
327 %attr(755,root,root) %ghost %{_libdir}/libval_shim.so.15
328
329 %files devel
330 %defattr(644,root,root,755)
331 %attr(755,root,root) %{_bindir}/libval-config
332 %attr(755,root,root) %{_libdir}/libsres.so
333 %attr(755,root,root) %{_libdir}/libval-threads.so
334 %attr(755,root,root) %{_libdir}/libval_shim.so
335 %{_libdir}/libsres.la
336 %{_libdir}/libval-threads.la
337 %{_libdir}/libval_shim.la
338 %{_includedir}/validator
339 %{_mandir}/man3/dnsval.conf.3*
340 %{_mandir}/man3/dnsval_conf*.3*
341 %{_mandir}/man3/libsres.3*
342 %{_mandir}/man3/libval.3*
343 %{_mandir}/man3/libval_async.3*
344 %{_mandir}/man3/libval_shim.3*
345 %{_mandir}/man3/p_ac_status.3*
346 %{_mandir}/man3/p_dane_error.3*
347 %{_mandir}/man3/p_val_status.3*
348 %{_mandir}/man3/resolv_conf_*.3*
349 %{_mandir}/man3/root_hints_*.3*
350 %{_mandir}/man3/val_*.3*
351
352 %files static
353 %defattr(644,root,root,755)
354 %{_libdir}/libsres.a
355 %{_libdir}/libval-threads.a
356 %{_libdir}/libval_shim.a
357
358 %files -n perl-%{name}
359 %defattr(644,root,root,755)
360 %dir %{perl_vendorarch}/Net/DNS
361 %dir %{perl_vendorarch}/Net/DNS/SEC
362 %{perl_vendorarch}/Net/DNS/SEC/Tools
363 %{perl_vendorarch}/Net/DNS/SEC/Validator.pm
364 %{perl_vendorarch}/Net/DNS/SEC/defines.pl
365 %{perl_vendorarch}/Net/DNS/ZoneFile
366 %{perl_vendorarch}/Net/addrinfo.pm
367 %dir %{perl_vendorarch}/auto/Net/DNS
368 %dir %{perl_vendorarch}/auto/Net/DNS/SEC
369 %{perl_vendorarch}/auto/Net/DNS/SEC/Tools
370 %dir %{perl_vendorarch}/auto/Net/DNS/SEC/Validator
371 %{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.so
372 %dir %{perl_vendorarch}/auto/Net/addrinfo
373 %attr(755,root,root) %{perl_vendorarch}/auto/Net/addrinfo/addrinfo.so
374 %{perl_vendorlib}/Net/DNS/SEC/Tools
375 %{_mandir}/man3/Net::DNS::SEC::Tools::*.3pm*
376 %{_mandir}/man3/Net::DNS::SEC::Validator.3pm*
377 %{_mandir}/man3/Net::DNS::ZoneFile::Fast.3pm*
378 %{_mandir}/man3/Net::addrinfo.3pm*
This page took 0.095233 seconds and 3 git commands to generate.