]> git.pld-linux.org Git - packages/denemo.git/blob - denemo.spec
ea0c239179b5e00be67400d1d93a2a85921572f1
[packages/denemo.git] / denemo.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # ALSA support
4 %bcond_without  aubio           # AUBIO support
5 %bcond_without  evince          # Evince support
6 %bcond_without  fluidsynth      # Fluidsynth support
7 %bcond_with     gtk2            # GTK+ 2.x instead of 3.x
8 %bcond_without  jack            # JACK support
9 %bcond_without  portaudio       # PortAudio support
10 %bcond_without  portmidi        # PortMIDI support
11 %bcond_without  rubberband      # Rubberband support
12
13 Summary:        GTK+ frontend for GNU lilypond
14 Summary(pl.UTF-8):      Frontend GTK+ na GNU lilypond
15 Name:           denemo
16 Version:        2.4.0
17 Release:        1
18 License:        GPL v3+
19 Group:          X11/Applications/Sound
20 Source0:        https://ftp.gnu.org/gnu/denemo/%{name}-%{version}.tar.gz
21 # Source0-md5:  c34962fd3d7037f578aa473dc6ab9c48
22 Patch0:         %{name}-fontsdir.patch
23 URL:            http://www.denemo.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 1.0.0}
25 %{?with_aubio:BuildRequires:    aubio-devel >= 0.4.0}
26 BuildRequires:  autoconf >= 2.59
27 BuildRequires:  automake
28 %if %{with evince}
29 %if %{with gtk2}
30 BuildRequires:  evince-devel >= 2.32
31 BuildRequires:  evince-devel < 3
32 %else
33 BuildRequires:  evince-devel >= 3.0
34 %endif
35 %endif
36 %{?with_fluidsynth:BuildRequires:       fluidsynth-devel >= 1.0.8}
37 %{?with_portaudio:BuildRequires:        fftw3-devel >= 3.1.2}
38 BuildRequires:  fontconfig-devel >= 2.2.0
39 BuildRequires:  gettext-tools >= 0.18
40 BuildRequires:  glib2-devel >= 1:2.30
41 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.6.0}
42 %{!?with_gtk2:BuildRequires:    gtk+3-devel >= 3.0.0}
43 BuildRequires:  gtk-doc >= 1.14
44 %{?with_gtk2:BuildRequires:     gtksourceview2-devel >= 2.0}
45 %{!?with_gtk2:BuildRequires:    gtksourceview3-devel >= 3.0}
46 BuildRequires:  guile-devel >= 2.2
47 BuildRequires:  intltool >= 0.35.0
48 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel >= 0.102.0}
49 BuildRequires:  librsvg-devel >= 2.0
50 BuildRequires:  libsmf-devel >= 1.3
51 BuildRequires:  libsndfile-devel >= 1.0
52 BuildRequires:  libstdc++-devel
53 BuildRequires:  libxml2-devel >= 2.3.10
54 BuildRequires:  pkgconfig
55 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
56 %{?with_portmidi:BuildRequires: portmidi-devel}
57 %{?with_rubberband:BuildRequires:       rubberband-devel >= 1.0.8}
58 BuildRequires:  xorg-lib-libX11-devel
59 Requires:       lilypond >= 2.6
60 Obsoletes:      denemo-devel < 2
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Denemo is a graphical music notation program written in C with GTK+.
65
66 It is intended to be used in conjunction with GNU Lilypond
67 (<http://lilypond.org/>), but is adaptable to other
68 computer-music-related purposes as well.
69
70 %description -l pl.UTF-8
71 Denemo to program do graficznej notacji muzycznej używający GTK+.
72
73 Jest przeznaczony do używania z GNU Lilypond (<http://lilypond.org/>),
74 ale może być zaadaptowany do innych celów związanych z muzyką.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79
80 %build
81 %{__intltoolize}
82 %{__aclocal} -I build
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 CFLAGS="%{rpmcflags} %{?debug:-DDEBUG}"
87 %configure \
88         %{?with_alsa:--enable-alsa} \
89         %{!?with_aubio:--disable-aubio} \
90         %{!?with_evince:--disable-evince} \
91         %{!?with_fluidsynth:--disable-fluidsynth} \
92         %{?with_gtk2:--enable-gtk2} \
93         %{!?with_gtk2:--enable-gtk3} \
94         %{?with_jack:--enable-jack} \
95         %{!?with_portaudio:--disable-portaudio} \
96         %{!?with_portmidi:--disable-portmidi} \
97         %{!?with_rubberband:--disable-rubberband}
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS docs/{DESIGN*,GOALS,TODO}
115 %attr(755,root,root) %{_bindir}/annotator
116 %attr(755,root,root) %{_bindir}/cairo_svg2path
117 %attr(755,root,root) %{_bindir}/denemo
118 %attr(755,root,root) %{_bindir}/denemo_file_update
119 %attr(755,root,root) %{_bindir}/generate_source
120 %attr(755,root,root) %{_bindir}/pageswitcher
121 %attr(755,root,root) %{_bindir}/pageturner
122 %attr(755,root,root) %{_bindir}/twopageturner
123 %{_datadir}/appdata/denemo.appdata.xml
124 %{_datadir}/denemo
125 %{_fontsdir}/denemo
126 %{_desktopdir}/denemo.desktop
127 %{_pixmapsdir}/denemo.png
This page took 0.069984 seconds and 2 git commands to generate.