]> git.pld-linux.org Git - packages/deltarpm.git/blob - deltarpm.spec
- relase 3
[packages/deltarpm.git] / deltarpm.spec
1 %define         subver  20110223
2 %define         rel             3
3 Summary:        Create deltas between rpms
4 Summary(pl.UTF-8):      Generowanie różnic między pakietami rpm
5 Name:           deltarpm
6 Version:        3.6
7 Release:        0.%{subver}git.%{rel}
8 License:        BSD
9 Group:          Base
10 Source0:        http://pkgs.fedoraproject.org/repo/pkgs/deltarpm/%{name}-git-%{subver}.tar.bz2/70f8884be63614ca7c3fc888cf20ebc8/deltarpm-git-%{subver}.tar.bz2
11 # Source0-md5:  70f8884be63614ca7c3fc888cf20ebc8
12 Patch0:         %{name}-3.4-no-skip-doc.patch
13 Patch1:         %{name}-3.4-pld.patch
14 Patch2:         %{name}-rpm5.patch
15 URL:            http://www.novell.com/products/linuxpackages/opensuse/deltarpm.html
16 BuildRequires:  bzip2-devel
17 BuildRequires:  popt-devel
18 BuildRequires:  python-devel
19 BuildRequires:  rpm-devel
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.219
22 BuildRequires:  xz-devel
23 BuildRequires:  zlib-static
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A deltarpm contains the difference between an old and a new version of
28 a rpm, which makes it possible to recreate the new rpm from the
29 deltarpm and the old one. You don't have to have a copy of the old
30 rpm, deltarpms can also work with installed rpms.
31
32 %description -l pl.UTF-8
33 Deltarpm zawiera różnice pomiędzy starą i nową wersją pakietu rpm,
34 pozwalając na stworzenie nowej wersji na podstawie delty i starej
35 wersji. Nie jest konieczne posiadanie kopii starego pakietu rpm,
36 deltarpm obsługuje także już zainstalowane pakiety.
37
38 %package -n drpmsync
39 Summary:        Sync a file tree with deltarpms
40 Group:          Base
41 Requires:       %{name} = %{version}-%{release}
42 Suggests:       deltaiso
43
44 %description -n drpmsync
45 This package contains a tool to sync a file tree with deltarpms.
46
47 %package -n deltaiso
48 Summary:        Create deltas between isos containing rpms
49 Group:          Base
50 Requires:       %{name} = %{version}-%{release}
51
52 %description -n deltaiso
53 This package contains tools for creating and using deltasisos, a
54 difference between an old and a new iso containing rpms.
55
56 %package -n python-deltarpm
57 Summary:        Python bindings for deltarpm
58 Group:          Base
59 # does not require base package
60
61 %description -n python-deltarpm
62 This package contains python bindings for deltarpm.
63
64 %prep
65 %setup -q -n %{name}-git-%{subver}
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69
70 %{__sed} -i -e 's/python3//' Makefile
71
72 %build
73 %{__make} CC="%{__cc}" CFLAGS="%{rpmcflags} -I/usr/include/rpm" \
74         bindir=%{_bindir} libdir=%{_libdir} mandir=%{_mandir} prefix=%{_prefix} \
75         zlibbundled='' zlibldflags='-lz' zlibcppflags=''
76
77 %{__make} CC="%{__cc}" CFLAGS="%{rpmcflags}" \
78         bindir=%{_bindir} libdir=%{_libdir} mandir=%{_mandir} prefix=%{_prefix} \
79         zlibbundled='' zlibldflags='-lz' zlibcppflags='' \
80         python
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
88 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
89 %py_postclean
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc LICENSE.BSD README
97 %attr(755,root,root) %{_bindir}/applydeltarpm
98 %attr(755,root,root) %{_bindir}/combinedeltarpm
99 %attr(755,root,root) %{_bindir}/makedeltarpm
100 %attr(755,root,root) %{_bindir}/rpmdumpheader
101 %{_mandir}/man8/applydeltarpm.8*
102 %{_mandir}/man8/combinedeltarpm.8*
103 %{_mandir}/man8/makedeltarpm.8*
104
105 %files -n deltaiso
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_bindir}/applydeltaiso
108 %attr(755,root,root) %{_bindir}/fragiso
109 %attr(755,root,root) %{_bindir}/makedeltaiso
110 %{_mandir}/man8/applydeltaiso*
111 %{_mandir}/man8/makedeltaiso*
112
113 %files -n drpmsync
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_bindir}/drpmsync
116 %{_mandir}/man8/drpmsync*
117
118 %files -n python-deltarpm
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{py_sitedir}/_deltarpmmodule.so
121 %{py_sitedir}/deltarpm.py[co]
This page took 0.085988 seconds and 3 git commands to generate.