]> git.pld-linux.org Git - packages/dee.git/blob - dee.spec
- pl, separated vala binding
[packages/dee.git] / dee.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library build
4 #
5 Summary:        Model to synchronize multiple instances over DBus
6 Summary(pl.UTF-8):      Model synchronizacji wielu instancji poprzez DBus
7 Name:           dee
8 Version:        1.0.14
9 Release:        3
10 # GPLv3-licensed tests and examples are in the tarball, but not installed
11 License:        LGPL v3
12 Group:          Libraries
13 Source0:        http://launchpad.net/dee/1.0/%{version}/+download/%{name}-%{version}.tar.gz
14 # Source0-md5:  473b4181e26538af0fb753255da7945c
15 URL:            https://launchpad.net/dee
16 BuildRequires:  dbus-glib-devel
17 BuildRequires:  glib2-devel >= 1:2.26
18 BuildRequires:  gobject-introspection-devel >= 0.10.2
19 BuildRequires:  gtk-doc >= 1.8
20 BuildRequires:  libicu-devel >= 4.6
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 # not needed for releases
24 #BuildRequires: vala
25 Requires:       glib2 >= 1:2.26
26 Requires:       libicu >= 4.6
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Libdee is a library that uses DBus to provide objects allowing you to
31 create Model-View-Controller type programs across DBus. It also
32 consists of utility objects which extend DBus allowing for
33 peer-to-peer discoverability of known objects without needing a
34 central registrar.
35
36 %description -l pl.UTF-8
37 Libdee to biblioteka wykorzystująca DBus w celu zapewnienia obiektów
38 pozwalających na tworzenie programów typu model-widok-kontroler
39 poprzez DBus. Składa się z obiektów narzędziowych rozszerzających DBus
40 o możliwość widzenia znanych obiektów w komunikacji peer-to-peer bez
41 potrzeby centralnego rejestru.
42
43 %package devel
44 Summary:        Development files for libdee
45 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libdee
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.26
49 Requires:       libicu-devel >= 4.6
50
51 %description devel
52 This package contains the header files for developing applications
53 that use libdee library.
54
55 %description devel -l pl.UTF-8
56 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia aplikacji
57 wykorzystujących bibliotekę libdee.
58
59 %package static
60 Summary:        Static libdee library
61 Summary(pl.UTF-8):      Biblioteka statyczna libdee
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static libdee library.
67
68 %description static -l pl.UTF-8
69 Biblioteka statyczna libdee.
70
71 %package apidocs
72 Summary:        Libdee API documentation
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki libdee
74 Group:          Documentation
75
76 %description apidocs
77 API documentation for libdee library.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API biblioteki libdee.
81
82 %package -n python-dee
83 Summary:        Python bindings for libdee
84 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libdee
85 Group:          Development/Languages/Python
86 Requires:       python-pygobject3
87
88 %description -n python-dee
89 Python bindings for libdee.
90
91 %description -n python-dee -l pl.UTF-8
92 Wiązania Pythona do biblioteki libdee.
93
94 %package -n vala-dee
95 Summary:        Libdee API for Vala language
96 Summary(pl.UTF-8):      API libdee dla języka Vala
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Requires:       vala
100
101 %description -n vala-dee
102 Libdee API for Vala language.
103
104 %description -n vala-dee -l pl.UTF-8
105 API libdee dla języka Vala.
106
107 %prep
108 %setup -q
109
110 %build
111 %configure \
112         --disable-silent-rules \
113         %{?with_static_libs:--enable-static} \
114         --with-html-dir=%{_gtkdocdir}
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %py_postclean
126
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdee*.la
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS
138 %attr(755,root,root) %{_bindir}/dee-tool
139 %attr(755,root,root) %{_libdir}/libdee-1.0.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libdee-1.0.so.4
141 %{_libdir}/girepository-1.0/Dee-1.0.typelib
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libdee-1.0.so
146 %{_includedir}/dee-1.0
147 %{_pkgconfigdir}/dee-1.0.pc
148 %{_pkgconfigdir}/dee-icu-1.0.pc
149 %{_datadir}/gir-1.0/Dee-1.0.gir
150
151 %if %{with static_libs}
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libdee-1.0.a
155 %endif
156
157 %files apidocs
158 %defattr(644,root,root,755)
159 %{_gtkdocdir}/dee-1.0
160
161 %files -n python-dee
162 %defattr(644,root,root,755)
163 %{py_sitedir}/gi/overrides/Dee.py[co]
164
165 %files -n vala-dee
166 %defattr(644,root,root,755)
167 %{_datadir}/vala/vapi/dee-1.0.vapi
168 %{_datadir}/vala/vapi/dee-1.0.deps
This page took 0.096167 seconds and 3 git commands to generate.