]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
ce9f8cacde280789388afd42f933b4cc37712a52
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Summary(ja.UTF-8):      GDB,DBX,Ladebug,JDB,Perl,Pythonのグラフィカルデバッガのフロントエンド
3 Summary(pl.UTF-8):      Interfejs X do debugerów GDB, DBX i XDB
4 Summary(zh_CN.UTF-8):   图形化的程序调试器前端;如GDB,DBX,Ladebug,JDB,Perl,Python
5 Name:           ddd
6 Version:        3.3.12
7 Release:        9
8 Epoch:          1
9 License:        GPL
10 Group:          Development/Debuggers
11 Source0:        http://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
12 # Source0-md5:  c50396db7bac3862a6d2555b3b22c34e
13 Source1:        %{name}.desktop
14 Source2:        http://art.gnome.org/images/icons/other/Debugger.png
15 # Source2-md5:  c046d9b0a04abdbb4a2be08a374ac2cd
16 Patch0:         %{name}-ptrace.patch
17 Patch1:         %{name}-info.patch
18 Patch2:         %{name}-home_etc.patch
19 Patch3:         %{name}-am185.patch
20 Patch4:         %{name}-gcc.4.4-build.patch
21 URL:            http://www.gnu.org/software/ddd/
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1:1.9
24 BuildRequires:  bison
25 BuildRequires:  elfutils-devel
26 BuildRequires:  flex
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool
29 BuildRequires:  motif-devel
30 BuildRequires:  ncurses-devel >= 5.0
31 BuildRequires:  readline-devel
32 BuildRequires:  xorg-lib-libXmu-devel
33 BuildRequires:  xorg-lib-libXpm-devel
34 BuildRequires:  texinfo
35 Requires:       gdb
36 Requires:       xorg-lib-libXt >= 1.0.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _appdefsdir     %{_datadir}/X11/app-defaults
40
41 %define         specflags       -fno-strict-aliasing
42
43 %description
44 The Data Display Debugger (DDD) is a common graphical user interface
45 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
46 ``classical'' front-end features such as viewing source texts, DDD
47 provides a graphical data display, where data structures are displayed
48 as graphs. A simple mouse click dereferences pointers or views
49 structure contents, updated each time the program stops. Using DDD,
50 you can reason about your application by viewing its data, not just by
51 viewing it execute lines of source code. Other DDD features include:
52 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
53 Modula-2, or Modula-3; machine-level debugging; hypertext source
54 navigation and lookup; breakpoint, backtrace, and history editors;
55 preferences and settings editors; program execution in terminal
56 emulator window; debugging on remote host; on-line manual; interactive
57 help on the Motif user interface; GDB/DBX/XDB command-line interface
58 with full editing, history, search, and completion capabilities. DDD
59 has been designed to compete with well-known commercial debuggers
60
61 %description -l ja.UTF-8
62 DDDは、GDB,DBX,WDB,Ladebug,JDB,XDB,Perlデバッガ、またはPythonデバッガ
63 のようなコマンドライン型デバッガをグラフィカル型のデバッガに変身させる
64 フロントエンドです。ソースコードの参照等のような"通常"のフロントエンド
65 の機能のみならず、DDDはデータ構造をグラフとして表示する、会話式グラフ
66 ィカルデータ表示することで有名になりました。
67
68 %description -l pl.UTF-8
69 Data Display Debugger (DDD) jest typowym graficznym interfejsem do
70 GDB, DBX, i XDB - popularnych UNIXowych debuggerów. Poza
71 ``klasycznymi'' możliwościami interfejsów graficznych takich jak
72 przeglądanie kodów źródłowych DDD dostarcza graficznych narzędzi,
73 gdzie struktury wyświetlane są w postaci graficznej. Proste kliknięcie
74 myszą pozwala na przeglądanie zawartości struktur (aktualizowane za
75 każdym razem gdy program się zatrzyma). Inne możliwości DDD to:
76 możliwość debugowania programów napisanych w C, C++, Ada, Fortran,
77 Java, Pascal, Modula-2, or Modula-2; debugowanie na poziomie maszyny;
78 hypertekstowa nawigacja po źródłach; breakpoint, backtrace i emulator
79 okna historii; możliwość ustawiania preferencji; uruchamianie
80 programów w oknie terminala; debugowanie na zdalnych serwerach;
81 podręcznik on-line; interaktywna pomoc; linia poleceń GDB/DBX/XDB z
82 pełną edycją, historią i wyszukiwaniem.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90 %patch4 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --with-motif \
99         --with-readline \
100         --with-termlib=tinfo
101
102 %{__make} \
103         CXXOPT="-DNDEBUG %{rpmcflags}"
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT{%{_appdefsdir},%{_desktopdir},%{_pixmapsdir}}
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install ddd/Ddd $RPM_BUILD_ROOT%{_appdefsdir}
113
114 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
115 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/ddd.png
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p      /sbin/postshell
121 -/usr/sbin/fix-info-dir -c %{_infodir}
122
123 %postun -p      /sbin/postshell
124 -/usr/sbin/fix-info-dir -c %{_infodir}
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS NEWS README TIPS TODO doc/*.pdf
129 %attr(755,root,root) %{_bindir}/ddd
130 %{_datadir}/ddd*
131 %{_appdefsdir}/Ddd
132 %{_desktopdir}/ddd.desktop
133 %{_pixmapsdir}/*.png
134 %{_mandir}/man1/*
135 %{_infodir}/ddd*
This page took 0.053337 seconds and 2 git commands to generate.