]> git.pld-linux.org Git - packages/ddcui.git/blob - ddcui.spec
new
[packages/ddcui.git] / ddcui.spec
1 %define         qt_ver  5.5
2
3 Summary:        Graphical user interface for ddcutil
4 Name:           ddcui
5 Version:        0.4.2
6 Release:        1
7 License:        GPL v2+
8 Group:          X11/Applications
9 #Source0Download: https://github.com/rockowitz/ddcui/releases
10 Source0:        https://github.com/rockowitz/ddcui/archive/v%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  09c18396b9610b0978b82b2897d85505
12 URL:            http://www.ddcutil.com/
13 BuildRequires:  Qt5Core-devel >= %{qt_ver}
14 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
15 BuildRequires:  Qt5Help-devel >= %{qt_ver}
16 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
17 BuildRequires:  cmake >= 3.10
18 BuildRequires:  ddcutil-devel >= 2.0.0
19 BuildRequires:  glib2-devel >= 1:2.40
20 BuildRequires:  libstdc++-devel >= 6:4.8.1
21 BuildRequires:  pkgconfig
22 BuildRequires:  qt5-build >= %{qt_ver}
23 BuildRequires:  rpmbuild(macros) >= 1.605
24 Requires(post,postun):  desktop-file-utils
25 Requires(post,postun):  gtk-update-icon-cache
26 Requires:       Qt5Core >= %{qt_ver}
27 Requires:       Qt5Gui >= %{qt_ver}
28 Requires:       Qt5Widgets >= %{qt_ver}
29 Requires:       glib2 >= 1:2.40
30 Requires:       hicolor-icon-theme
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 ddcui is a graphical user interface for ddcutil, implemented using Qt.
35
36 %prep
37 %setup -q
38
39 : > validate_CMAKE_BUILD_TYPE.cmake
40
41 %build
42 install -d build
43 cd build
44 %cmake .. \
45         -DUSE_CCACHE:BOOL=OFF
46
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} -C build install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %update_desktop_database_post
60 %update_icon_cache hicolor
61
62 %postun
63 %update_desktop_database_postun
64 %update_icon_cache hicolor
65
66 %files
67 %defattr(644,root,root,755)
68 %doc AUTHORS {CHANGELOG,NEWS,README}.md
69 %attr(755,root,root) %{_bindir}/ddcui
70 %{_mandir}/man1/ddcui.1*
71 %{_desktopdir}/ddcui.desktop
72 %{_iconsdir}/hicolor/*/apps/ddcui.png
73 %{_datadir}/metainfo/ddcui.appdata.xml
This page took 0.091833 seconds and 3 git commands to generate.