]> git.pld-linux.org Git - packages/dbh.git/blob - dbh.spec
- up to 5.0.7
[packages/dbh.git] / dbh.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Disk based hash library
6 Summary(pl.UTF-8):      Biblioteka obsługująca tablice haszujące na dysku
7 Name:           dbh
8 Version:        5.0.7
9 Release:        1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/dbh/%{name}-%{version}.tar.gz
13 # Source0-md5:  15e1bd22aca735415dfb5ec60f48181b
14 Patch0:         am.patch
15 URL:            http://dbh.sourceforge.net/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Disk based hashes is a method to create multidimensional binary trees
23 on disk. This library permits the extension of database concept to a
24 plethora of electronic data, such as graphic information. With the
25 multidimensional binary tree it is possible to mathematically prove
26 that access time to any particular record is minimized (using the
27 concept of critical points from calculus), which provides the means to
28 construct optimized databases for particular applications.
29
30 %description -l pl.UTF-8
31 Hasze przechowywane na dysku to metoda tworzenia wielowymiarowych
32 drzew binarnych na dysku. Biblioteka pozwala rozszerzać pojęcie bazy
33 danych o bogactwo danych elektronicznych, takich jak informacje
34 graficzne. Można udowodnić matematycznie, że przy użyciu
35 wielowymiarowego drzewa binarnego czas dostępu do każdego konkretnego
36 rekordu jest minimalny (używając zasady punktów krytycznych), co
37 daje środki do tworzenia zoptymalizowanych baz danych dla aplikacji.
38
39 %package devel
40 Summary:        Disk based hash library development files
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dbh
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Obsoletes:      dbh-examples
45
46 %description devel
47 Disk based hash library development files.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki dbh.
51
52 %package static
53 Summary:        Disk based hash static library
54 Summary(pl.UTF-8):      Statyczna biblioteka dbh
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Disk based hash static library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka dbh.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 %{__libtoolize}
70 %{__aclocal} -I m4
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         %{!?with_static_libs:--disable-static}
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 cd examples
87 install filesystem.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
88 install simple_hash.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog
99 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/lib*.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/lib*.so
105 %{_gtkdocdir}/dbh
106 %{_libdir}/lib*.la
107 %{_includedir}/dbh
108 %{_pkgconfigdir}/*.pc
109 %{_examplesdir}/%{name}-%{version}
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/lib*.a
115 %endif
This page took 0.070389 seconds and 3 git commands to generate.