]> git.pld-linux.org Git - packages/dbgpproxy.git/blob - dbgpproxy.spec
afbe669fe686c13e582b10fcd8acb9e7af504435
[packages/dbgpproxy.git] / dbgpproxy.spec
1 # TODO
2 # - initscript+config
3 %define rel             0.1
4 %define subver  83298
5 Summary:        DBGp Proxy for PHP Xdebug
6 Name:           dbgpproxy
7 Version:        8.5.3
8 Release:        0.%{subver}.%{rel}
9 License:        MIT
10 Group:          Libraries
11 # SourceDownload: http://code.activestate.com/komodo/remotedebugging/
12 Source0:        http://downloads.activestate.com/Komodo/releases/%{version}/remotedebugging/Komodo-PythonRemoteDebugging-%{version}-%{subver}-linux-x86.tar.gz
13 # Source0-md5:  9490a78e5bb1e68257d88dd089e690b0
14 Source1:        http://downloads.activestate.com/Komodo/releases/%{version}/remotedebugging/Komodo-PythonRemoteDebugging-%{version}-%{subver}-linux-x86_64.tar.gz
15 # Source1-md5:  a485c07846fb82a69194b5099cf173d4
16 URL:            http://derickrethans.nl/debugging-with-multiple-users.html
17 ExclusiveArch:  %{ix86} %{x8664}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # avoid empty debuginfo package
21 %define         _enable_debug_packages  0
22
23 %description
24 DBGp is protocol to facilitate communication between an IDE (such as
25 Komodo, or any of the other clients) and PHP+Xdebug.
26
27 %prep
28 %ifarch %{ix86}
29 %setup -qcT -b 0
30 %endif
31 %ifarch %{x8664}
32 %setup -qcT -b 1
33 %endif
34 mv Komodo-PythonRemoteDebugging-%{version}-%{subver}-linux-*/* .
35
36 cd pythonlib
37 py_ver=$(echo %py_ver | tr -d .)
38 mv dbgp/_client$py_ver.so .
39 rm -vf dbgp/_client??.so
40 mv _client$py_ver.so dbgp
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_bindir},%{py_sitescriptdir}/dbgp}
45 install -p pydbgpproxy $RPM_BUILD_ROOT%{_bindir}
46 cp -a pythonlib/* $RPM_BUILD_ROOT%{py_sitescriptdir}
47
48 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
49 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
50 %py_postclean
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc LICENSE.txt
58 %attr(755,root,root) %{_bindir}/pydbgpproxy
59 %{py_sitescriptdir}/dbgpClient.py[co]
60 %{py_sitescriptdir}/dbgp/*.py[co]
61 %dir %{py_sitescriptdir}/dbgp
62 %dir %{py_sitescriptdir}/dbgp/_logging
63 %attr(755,root,root) %{py_sitescriptdir}/dbgp/_client*.so
64 %{py_sitescriptdir}/dbgp/_logging/*.py[co]
This page took 0.049143 seconds and 2 git commands to generate.