]> git.pld-linux.org Git - packages/dav1d.git/blob - dav1d.spec
4323fa99222816746330bb31428b9a8784cf4e46
[packages/dav1d.git] / dav1d.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        AV1 decoder library
7 Summary(pl.UTF-8):      Biblioteka dekodera AV1
8 Name:           dav1d
9 Version:        0.8.1
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        https://download.videolan.org/videolan/dav1d/%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  492517d01b72256774d1389e5f891ab2
15 Patch0:         %{name}-nasm.patch
16 URL:            https://code.videolan.org/videolan/dav1d
17 %{?with_apidocs:BuildRequires:  doxygen}
18 BuildRequires:  meson >= 0.49.0
19 %ifarch %{ix86} %{x8664} x32
20 BuildRequires:  nasm >= 2.13.02
21 %endif
22 BuildRequires:  ninja >= 1.5
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpmbuild(macros) >= 1.752
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 dav1d is a new AV1 cross-platform decoder, open-source, and focused on
31 speed and correctness.
32
33 %description -l pl.UTF-8
34 dav1d to nowy, wieloplatformowy dekoder AV1, mający otwarte źródła,
35 rozwijany głównie z myślą o szybkości i poprawności.
36
37 %package devel
38 Summary:        Header files for DAV1D library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki DAV1D
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for DAV1D library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki DAV1D.
48
49 %package static
50 Summary:        Static DAV1D library
51 Summary(pl.UTF-8):      Statyczna biblioteka DAV1D
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static DAV1D library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka DAV1D.
60
61 %package apidocs
62 Summary:        API documentation for DAV1D library
63 Summary(pl.UTF-8):      Dokumentacja API biblioteki DAV1D
64 Group:          Documentation
65 BuildArch:      noarch
66
67 %description apidocs
68 API documentation for DAV1D library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API biblioteki DAV1D.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 %meson build \
79         %{!?with_static_libs:--default-library=shared}
80
81 %ninja_build -C build all %{?with_apidocs:doc/html}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %ninja_install -C build
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc COPYING NEWS README.md THANKS.md doc/PATENTS
97 %attr(755,root,root) %{_bindir}/dav1d
98 %attr(755,root,root) %{_libdir}/libdav1d.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libdav1d.so.5
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/libdav1d.so
104 %{_includedir}/dav1d
105 %{_pkgconfigdir}/dav1d.pc
106
107 %if %{with static_libs}
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libdav1d.a
111 %endif
112
113 %if %{with apidocs}
114 %files apidocs
115 %defattr(644,root,root,755)
116 %doc build/doc/html/*
117 %endif
This page took 0.083165 seconds and 2 git commands to generate.