]> git.pld-linux.org Git - packages/darktable.git/blob - darktable.spec
- up to 4.0.1
[packages/darktable.git] / darktable.spec
1 #
2 # Conditional build:
3 %bcond_without  gegl    # build without GeGL
4 %bcond_without  openmp  # OpenMP threading support
5 %bcond_without  opencl  # OpenCL support
6 %bcond_with     vte     # lighttable mode shell ("file manager" April fool)
7
8 Summary:        darktable - a virtual lighttable and darkroom for photographers
9 Summary(pl.UTF-8):      darktable - wirtualny podświetlany stół i ciemnia dla fotografów
10 Name:           darktable
11 Version:        4.0.1
12 Release:        1
13 License:        GPL v3
14 Group:          X11/Applications/Graphics
15 Source0:        https://github.com/darktable-org/darktable/releases/download/release-%{version}/%{name}-%{version}.tar.xz
16 # Source0-md5:  b63acce06ef91425f13387464cdec8ca
17 Patch0:         cmake-glib.patch
18 URL:            https://www.darktable.org/
19 BuildRequires:  GraphicsMagick-devel
20 %{?with_opencl:BuildRequires:   OpenCL-devel}
21 BuildRequires:  OpenEXR-devel >= 3.0
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel >= 1.2
24 BuildRequires:  cairo-devel
25 BuildRequires:  cmake >= 3.10
26 BuildRequires:  colord-devel
27 BuildRequires:  colord-gtk-devel
28 BuildRequires:  cups-devel
29 BuildRequires:  curl-devel >= 7.56.0
30 BuildRequires:  dbus-glib-devel >= 0.80
31 BuildRequires:  desktop-file-utils
32 BuildRequires:  exiv2-devel >= 0.27.4
33 BuildRequires:  flickcurl-devel
34 BuildRequires:  fop
35 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.3}
36 BuildRequires:  gdk-pixbuf2-devel >= 2
37 %{?with_gegl:BuildRequires:     gegl-devel}
38 BuildRequires:  gettext
39 BuildRequires:  gettext-tools
40 BuildRequires:  glib2-devel >= 1:2.40
41 BuildRequires:  gnome-doc-utils
42 BuildRequires:  gtk+3-devel >= 3.22
43 BuildRequires:  intltool
44 BuildRequires:  iso-codes >= 4.4
45 BuildRequires:  json-glib-devel
46 BuildRequires:  lcms2-devel >= 2
47 BuildRequires:  lensfun-devel
48 BuildRequires:  libavif-devel >= 0.7.2
49 BuildRequires:  libglade2-devel
50 BuildRequires:  libgnome-keyring-devel
51 %{?with_openmp:BuildRequires:   libgomp-devel}
52 BuildRequires:  libgphoto2-devel >= 2.4.5
53 BuildRequires:  libjpeg-devel
54 BuildRequires:  libpng-devel
55 BuildRequires:  librsvg-devel >= 1:2.26
56 BuildRequires:  libsoup-devel >= 2
57 BuildRequires:  libtiff-devel
58 BuildRequires:  libwebp-devel >= 0.3.0
59 BuildRequires:  libxml2-devel >= 1:2.6
60 BuildRequires:  libxml2-progs
61 BuildRequires:  libxslt-progs
62 BuildRequires:  llvm-devel >= 12.0
63 BuildRequires:  lua54-devel >= 5.4
64 BuildRequires:  openjpeg-devel >= 1.5.0
65 BuildRequires:  pango-devel
66 BuildRequires:  perl-tools-pod
67 BuildRequires:  pkgconfig >= 1:0.22
68 BuildRequires:  po4a
69 BuildRequires:  pugixml-devel >= 1.8
70 BuildRequires:  python3-jsonschema
71 BuildRequires:  sqlite3-devel >= 3.24
72 BuildRequires:  squish-devel
73 %{?with_vte:BuildRequires:      vte-devel >= 0.26.0}
74 Requires(post,postun):  gtk-update-icon-cache
75 Requires(post,postun):  hicolor-icon-theme
76 Requires:       curl >= 7.18.0
77 Requires:       dbus-glib >= 0.80
78 Requires:       glib2 >= 1:2.30
79 Requires:       gtk+3 >= 3.22
80 Requires:       openjpeg >= 1.5.0
81 %{?with_vte:Requires:   vte >= 0.26.0}
82 ExclusiveArch:  %{x8664}
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %description
86 darktable is a virtual lighttable and darkroom for photographers.
87
88 %description -l pl.UTF-8
89 darktable to wirtualny podświetlany stół i ciemnia dla fotografów.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 install -d build
97 cd build
98 export CXXFLAGS="%{rpmcxxflags}"
99 %cmake .. \
100         -DCMAKE_BUILD_TYPE=%{!?debug:RELEASE}%{?debug:DEBUG} \
101         %{?with_vte:-DAPRIL_FOOLS=ON} \
102         -DBINARY_PACKAGE_BUILD=ON \
103         -DPROJECT_VERSION:STRING="%{version}" \
104         -DUSE_AVIF=OFF \
105         -DTESTBUILD_OPENCL_PROGRAMS=OFF \
106         %{!?with_opencl:-DUSE_OPENCL=OFF} \
107         %{!?with_openmp:-DUSE_OPENMP=OFF}
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT/etc/ld.so.conf.d
114 echo "%{_libdir}/%{name}" >$RPM_BUILD_ROOT/etc/ld.so.conf.d/%{name}.conf
115 %{__make} -C build install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
119
120 %find_lang %{name} --with-gnome --with-omf
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post
126 /sbin/ldconfig
127 %update_desktop_database_post
128 %update_icon_cache hicolor
129
130 %banner %{name} -e << EOF
131 When updating from the stable 3.8.x series, please bear in mind that
132 your edits will be preserved during this process, but the new library
133 and configuration will no longer be usable with 3.8.x.
134
135 You are strongly advised to take a backup first.
136
137 EOF
138
139 %postun
140 /sbin/ldconfig
141 %update_desktop_database_postun
142 %update_icon_cache hicolor
143
144 %files -f %{name}.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS CONTRIBUTING.md README.md RELEASE_NOTES.md
147 %doc doc/{TRANSLATORS.md,grouping.txt,thumbnail_color_management.txt}
148 %attr(755,root,root) %{_bindir}/darktable
149 %attr(755,root,root) %{_bindir}/darktable-chart
150 %attr(755,root,root) %{_bindir}/darktable-cli
151 %attr(755,root,root) %{_bindir}/darktable-cltest
152 %attr(755,root,root) %{_bindir}/darktable-cmstest
153 %attr(755,root,root) %{_bindir}/darktable-generate-cache
154 %attr(755,root,root) %{_bindir}/darktable-rs-identify
155 /etc/ld.so.conf.d/%{name}.conf
156 %{_datadir}/metainfo/darktable.appdata.xml
157 %{_datadir}/darktable
158 %{_desktopdir}/darktable.desktop
159 %{_iconsdir}/hicolor/*/apps/darktable.png
160 %{_iconsdir}/hicolor/scalable/apps/darktable*.svg
161 %dir %{_libdir}/darktable
162 %dir %{_libdir}/darktable/plugins
163 %dir %{_libdir}/darktable/plugins/imageio
164 %dir %{_libdir}/darktable/plugins/imageio/format
165 %dir %{_libdir}/darktable/plugins/imageio/storage
166 %dir %{_libdir}/darktable/plugins/lighttable
167 %dir %{_libdir}/darktable/views
168 %attr(755,root,root) %{_libdir}/darktable/libdarktable.so
169 %attr(755,root,root) %{_libdir}/darktable/plugins/*.so
170 %attr(755,root,root) %{_libdir}/darktable/plugins/imageio/format/*.so
171 %attr(755,root,root) %{_libdir}/darktable/plugins/imageio/storage/*.so
172 %attr(755,root,root) %{_libdir}/darktable/plugins/lighttable/*.so
173 %attr(755,root,root) %{_libdir}/darktable/views/*.so
174 %lang(de) %{_mandir}/de/man1/darktable.1*
175 %lang(de) %{_mandir}/de/man1/darktable-cli.1*
176 %lang(de) %{_mandir}/de/man1/darktable-cltest.1*
177 %lang(de) %{_mandir}/de/man1/darktable-cmstest.1*
178 %lang(de) %{_mandir}/de/man1/darktable-generate-cache.1*
179 %lang(es) %{_mandir}/es/man1/darktable.1*
180 %lang(es) %{_mandir}/es/man1/darktable-cli.1*
181 %lang(es) %{_mandir}/es/man1/darktable-cltest.1*
182 %lang(es) %{_mandir}/es/man1/darktable-cmstest.1*
183 %lang(es) %{_mandir}/es/man1/darktable-generate-cache.1*
184 %lang(fr) %{_mandir}/fr/man1/darktable.1*
185 %lang(fr) %{_mandir}/fr/man1/darktable-cli.1*
186 %lang(fr) %{_mandir}/fr/man1/darktable-cltest.1*
187 %lang(fr) %{_mandir}/fr/man1/darktable-cmstest.1*
188 %lang(fr) %{_mandir}/fr/man1/darktable-generate-cache.1*
189 %{_mandir}/man1/darktable.1*
190 %{_mandir}/man1/darktable-cli.1*
191 %{_mandir}/man1/darktable-cltest.1*
192 %{_mandir}/man1/darktable-cmstest.1*
193 %{_mandir}/man1/darktable-generate-cache.1*
This page took 0.082993 seconds and 3 git commands to generate.