]> git.pld-linux.org Git - packages/dante.git/blob - dante.spec
75d0d953e1e9351a1823d7f36e1c117cd72e2cbc
[packages/dante.git] / dante.spec
1 # NOTE: ldap and sasl seems stub in this (free only?) version
2 #
3 # Conditional build:
4 %bcond_without  upnp    # UPnP support (via miniupnp)
5 #
6 Summary:        A free Socks v4/v5 client implementation
7 Summary(pl.UTF-8):      Darmowa implementacja klienta Socks v4/5
8 Name:           dante
9 Version:        1.4.2
10 Release:        4
11 License:        BSD-like
12 Group:          Networking/Daemons
13 #Source0Download: http://www.inet.no/dante/download.html
14 Source0:        http://www.inet.no/dante/files/%{name}-%{version}.tar.gz
15 # Source0-md5:  29c2931339655da51576c4d2b7bf16f3
16 Source1:        sockd.init
17 Patch0:         %{name}-am.patch
18 Patch1:         %{name}-build.patch
19 Patch2:         %{name}-cpp.patch
20 URL:            http://www.inet.no/dante/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake
23 BuildRequires:  cyrus-sasl-devel
24 BuildRequires:  heimdal-devel
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  libwrap-devel
27 %{?with_upnp:BuildRequires:     miniupnpc-devel >= 1.6}
28 BuildRequires:  openldap-devel
29 BuildRequires:  pam-devel
30 %{?with_upnp:Requires:  miniupnpc >= 1.6}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Dante is a free implementation of the proxy protocols socks version 4,
35 socks version 5 (rfc1928) and msproxy. It can be used as a firewall
36 between networks. It is being developed by Inferno Nettverk A/S, a
37 Norwegian consulting company. Commercial support is available.
38
39 This package contains the dynamic libraries required to "socksify"
40 existing applications to become socks clients.
41
42 %description -l pl.UTF-8
43 Dante jest darmową implementacją protokołów proxy: socks w wersji 4,
44 socks w wersji 5 (rfc1928) oraz msproxy. Może być używany jako zapora
45 pomiędzy sieciami. Implementacja jest rozwijana przez Inferno Nettverk
46 A/S - Norweską firmę konsultingową. Komercyjne wsparcie jest dostępne.
47
48 Ten pakiet zawiera dynamiczne biblioteki wymagane do "usocksowiania"
49 istniejących aplikacji tak by działały one jako klienci socks.
50
51 %package server
52 Summary:        A free Socks v4/v5 server implementation
53 Summary(pl.UTF-8):      Darmowa implementacja serwera Socks v4/5
54 Group:          Networking/Daemons
55 Requires(post,preun):   /sbin/chkconfig
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       rc-scripts
58
59 %description server
60 This package contains the socks proxy daemon and its documentation.
61 The sockd is the server part of the Dante socks proxy package and
62 allows socks clients to connect through it to the network.
63
64 %description server -l pl.UTF-8
65 Ten pakiet zawiera serwer proxy socks oraz jego dokumentację. Serwer
66 sockd jest częścią pakietu proxy Dante. Za pośrednictwem serwera
67 klienci mogą łączyć się z serwerami w sieci.
68
69 %package devel
70 Summary:        Development files for socks library
71 Summary(pl.UTF-8):      Pliki programistyczne biblioteki socks
72 Group:          Networking/Daemons
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       heimdal-devel
75 %{?with_upnp:Requires:  miniupnpc-devel >= 1.6}
76 Requires:       pam-devel
77
78 %description devel
79 Development files required to compile programs that use socks.
80
81 %description devel -l pl.UTF-8
82 Pliki programistyczne wymagane do rozwoju programów korzystających z
83 socks.
84
85 %package static
86 Summary:        Static socks library
87 Summary(pl.UTF-8):      Statyczna biblioteka socks
88 Group:          Networking/Daemons
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static socks library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka socks.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --disable-silent-rules \
111         --without-glibc-secure \
112         %{!?with_upnp:--without-upnp}
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install example/sock{s,d}.conf $RPM_BUILD_ROOT%{_sysconfdir}
124
125 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/sockd
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %post server
134 /sbin/chkconfig --add sockd
135 if [ -f /var/lock/subsys/sockd ]; then
136         /etc/rc.d/init.d/sockd restart 1>&2
137 else
138         echo "Run \"/etc/rc.d/init.d/sockd start\" to start dante sockd daemon."
139 fi
140
141 %postun server
142 if [ "$1" = "0" ]; then
143         if [ -f /var/lock/subsys/sockd ]; then
144                 /etc/rc.d/init.d/sockd stop 1>&2
145         fi
146         /sbin/chkconfig --del sockd
147 fi
148
149 %files
150 %defattr(644,root,root,755)
151 %doc BUGS CREDITS LICENSE NEWS README SUPPORT UPGRADE
152 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/socks.conf
153 %attr(755,root,root) %{_libdir}/libsocks.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libsocks.so.0
155 %attr(755,root,root) %{_libdir}/libdsocks.so
156 %attr(755,root,root) %{_bindir}/socksify
157 %{_mandir}/man5/socks.conf.5*
158 %{_mandir}/man1/socksify.1*
159
160 %files server
161 %defattr(644,root,root,755)
162 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sockd.conf
163 %attr(754,root,root) /etc/rc.d/init.d/sockd
164 %attr(755,root,root) %{_sbindir}/sockd
165 %{_mandir}/man8/sockd.8*
166 %{_mandir}/man5/sockd.conf.5*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libsocks.so
171 %{_libdir}/libsocks.la
172 %{_libdir}/libdsocks.la
173 %{_includedir}/socks.h
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libsocks.a
This page took 0.044107 seconds and 2 git commands to generate.