]> git.pld-linux.org Git - packages/czmq.git/blob - czmq.spec
3e6346c8a4f08c56ec8475932098bb15c1cc3bbd
[packages/czmq.git] / czmq.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        High-level C binding for 0MQ
7 Summary(pl.UTF-8):      Wysokopoziomowe wiązania C dla 0MQ
8 Name:           czmq
9 Version:        4.2.0
10 Release:        1
11 License:        LGPL v3+
12 Group:          Libraries
13 #Source0Download: https://github.com/zeromq/czmq/releases
14 Source0:        https://github.com/zeromq/czmq/releases/download/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  7e09997db6ac3b25e8ed104053040722
16 Patch1:         %{name}-link.patch
17 URL:            http://zeromq.org/
18 BuildRequires:  asciidoc
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake
21 BuildRequires:  curl-devel >= 7.28.0
22 BuildRequires:  libmicrohttpd-devel
23 BuildRequires:  libtool
24 BuildRequires:  libuuid-devel
25 BuildRequires:  lz4-devel
26 %if %{with python2}
27 BuildRequires:  python-devel >= 1:2.5
28 BuildRequires:  python-setuptools
29 %endif
30 %if %{with python3}
31 BuildRequires:  python3-devel >= 1:3.2
32 BuildRequires:  python3-setuptools
33 %endif
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 BuildRequires:  systemd-devel >= 1:200
37 BuildRequires:  xmlto
38 BuildRequires:  zeromq-devel >= 4
39 Requires:       curl-libs >= 7.28.0
40 Requires:       systemd-libs >= 1:200
41 Requires:       zeromq >= 4
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 High-level C binding for 0MQ.
46
47 %description -l pl.UTF-8
48 Wysokopoziomowe wiązania C dla 0MQ.
49
50 %package devel
51 Summary:        Header files for CZMQ library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CZMQ
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       curl-devel >= 7.28.0
56 Requires:       libmicrohttpd-devel
57 Requires:       libuuid-devel
58 Requires:       lz4-devel
59 Requires:       systemd-devel >= 1:200
60 Requires:       zeromq-devel >= 4
61
62 %description devel
63 Header files for CZMQ library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki CZMQ.
67
68 %package static
69 Summary:        Static CZMQ library
70 Summary(pl.UTF-8):      Statyczna biblioteka CZMQ
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static CZMQ library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka CZMQ.
79
80 %package -n python-czmq
81 Summary:        Python 2 bindings for CZMQ
82 Summary(pl.UTF-8):      Wiązania Pythona 2 do CZMQ
83 Group:          Libraries/Python
84 Requires:       %{name} = %{version}-%{release}
85
86 %description -n python-czmq
87 Python 2 bindings for CZMQ - the high level C binding for 0MQ.
88
89 %description -n python-czmq -l pl.UTF-8
90 Wiązania Pythona 2 do CZMQ - wysokopoziomowego wiązania C do 0MQ.
91
92 %package -n python3-czmq
93 Summary:        Python 3 bindings for CZMQ
94 Summary(pl.UTF-8):      Wiązania Pythona 3 do CZMQ
95 Group:          Libraries/Python
96 Requires:       %{name} = %{version}-%{release}
97
98 %description -n python3-czmq
99 Python 3 bindings for CZMQ - the high level C binding for 0MQ.
100
101 %description -n python3-czmq -l pl.UTF-8
102 Wiązania Pythona 3 do CZMQ - wysokopoziomowego wiązania C do 0MQ.
103
104 %prep
105 %setup -q
106 %patch1 -p1
107
108 %build
109 %{__libtoolize}
110 %{__aclocal} -I config
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 # use include subdir - file names could be too common (zfile.h etc.)
115 %configure \
116         --enable-bindings-python \
117         --disable-silent-rules \
118         --includedir=%{_includedir}/czmq
119 %{__make}
120
121 cd bindings/python
122
123 %if %{with python2}
124 %py_build
125 %endif
126
127 %if %{with python3}
128 %py3_build
129 %endif
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 cd bindings/python
138
139 %if %{with python2}
140 %py_install
141
142 %py_postclean
143 %endif
144
145 %if %{with python3}
146 %py3_install
147 %endif
148
149 # obsoleted by pkg-config
150 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libczmq.la
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %files
156 %defattr(644,root,root,755)
157 %doc AUTHORS NEWS README.md
158 %attr(755,root,root) %{_bindir}/zmakecert
159 %attr(755,root,root) %{_libdir}/libczmq.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libczmq.so.4
161 %{_mandir}/man1/zmakecert.1*
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libczmq.so
166 %{_includedir}/czmq
167 %{_pkgconfigdir}/libczmq.pc
168 %dir %{_datadir}/zproject
169 %{_datadir}/zproject/czmq
170 %{_mandir}/man3/zactor.3*
171 %{_mandir}/man3/zargs.3*
172 %{_mandir}/man3/zarmour.3*
173 %{_mandir}/man3/zauth.3*
174 %{_mandir}/man3/zbeacon.3*
175 %{_mandir}/man3/zcert.3*
176 %{_mandir}/man3/zcertstore.3*
177 %{_mandir}/man3/zchunk.3*
178 %{_mandir}/man3/zclock.3*
179 %{_mandir}/man3/zconfig.3*
180 %{_mandir}/man3/zdigest.3*
181 %{_mandir}/man3/zdir.3*
182 %{_mandir}/man3/zdir_patch.3*
183 %{_mandir}/man3/zfile.3*
184 %{_mandir}/man3/zframe.3*
185 %{_mandir}/man3/zgossip.3*
186 %{_mandir}/man3/zhash.3*
187 %{_mandir}/man3/zhashx.3*
188 %{_mandir}/man3/zhttp_client.3*
189 %{_mandir}/man3/zhttp_request.3*
190 %{_mandir}/man3/zhttp_response.3*
191 %{_mandir}/man3/zhttp_server.3*
192 %{_mandir}/man3/zhttp_server_options.3*
193 %{_mandir}/man3/ziflist.3*
194 %{_mandir}/man3/zlist.3*
195 %{_mandir}/man3/zlistx.3*
196 %{_mandir}/man3/zloop.3*
197 %{_mandir}/man3/zmonitor.3*
198 %{_mandir}/man3/zmsg.3*
199 %{_mandir}/man3/zpoller.3*
200 %{_mandir}/man3/zproc.3*
201 %{_mandir}/man3/zproxy.3*
202 %{_mandir}/man3/zrex.3*
203 %{_mandir}/man3/zsock.3*
204 %{_mandir}/man3/zstr.3*
205 %{_mandir}/man3/zsys.3*
206 %{_mandir}/man3/ztimerset.3*
207 %{_mandir}/man3/ztrie.3*
208 %{_mandir}/man3/zuuid.3*
209 %{_mandir}/man7/czmq.7*
210
211 %files static
212 %defattr(644,root,root,755)
213 %{_libdir}/libczmq.a
214
215 %if %{with python2}
216 %files -n python-czmq
217 %defattr(644,root,root,755)
218 %{py_sitescriptdir}/czmq
219 %{py_sitescriptdir}/czmq-%{version}-py*.egg-info
220 %endif
221
222 %if %{with python3}
223 %files -n python3-czmq
224 %defattr(644,root,root,755)
225 %{py3_sitescriptdir}/czmq
226 %{py3_sitescriptdir}/czmq-%{version}-py*.egg-info
227 %endif
This page took 0.077989 seconds and 2 git commands to generate.