]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
curl-libs: minimal required versions of libssh2 and openssl
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # without SSH support
4 %bcond_without  ssl             # without SSL support
5 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
6 %bcond_without  ldap            # without LDAP support
7 %bcond_with     http2           # without HTTP/2.0 support (nghttp2 based)
8 %bcond_without  metalink        # without metalink support
9 %if "%{pld_release}" != "ac"
10 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
11 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
12 %bcond_without  rtmp            # without Real Time Media Protocol
13 %else
14 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library
15 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
16 %bcond_with     rtmp            # without Real Time Media Protocol
17 %endif
18
19 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
20 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
24 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
25 Name:           curl
26 Version:        7.33.0
27 Release:        1
28 License:        MIT-like
29 Group:          Applications/Networking
30 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
31 # Source0-md5:  eb463192f37c260163e006d6c4d3f114
32 Patch0:         %{name}-ac.patch
33 Patch1:         %{name}-krb5flags.patch
34 # make the curl tool link SSL libraries also used by src/tool_metalink.c
35 Patch2:         metalink.patch
36 URL:            http://curl.haxx.se/
37 BuildRequires:  autoconf >= 2.57
38 BuildRequires:  automake
39 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
40 %{?with_kerberos5:BuildRequires:        heimdal-devel}
41 %{?with_http2:BuildRequires:    nghttp2-devel}
42 BuildRequires:  libidn-devel >= 0.4.1
43 %{?with_metalink:BuildRequires: libmetalink-devel}
44 %{?with_rtmp:BuildRequires:     librtmp-devel}
45 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
46 BuildRequires:  libtool
47 BuildRequires:  nettle-devel
48 %{?with_ldap:BuildRequires:     openldap-devel}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpm >= 4.4.9-56
51 BuildRequires:  rpmbuild(macros) >= 1.453
52 %if %{with ssl}
53 %if %{with gnutls}
54 BuildRequires:  gnutls-devel
55 %else
56 BuildRequires:  openssl-devel >= 0.9.7d
57 %endif
58 %endif
59 BuildRequires:  tar >= 1:1.22
60 BuildRequires:  zlib-devel
61 Requires:       %{name}-libs = %{version}-%{release}
62 Requires:       libidn >= 0.4.1
63 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
64 Obsoletes:      libcurl2
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 cURL is a tool for getting files with URL syntax, supporting FTP,
69 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
70 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
71 cookies, user+password authentication and a busload of other useful
72 tricks. The main use for curl is when you want to get or send files
73 automatically to or from a site using one of the supported protocols.
74
75 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
76 Dict servers, using any of the supported protocols. cURL is designed
77 to work without user interaction or any kind of interactivity. cURL
78 offers many useful capabilities, like proxy support, user
79 authentication, FTP upload, HTTP post, and file transfer resume.
80
81 %description -l pl.UTF-8
82 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
83 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
84 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
85 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
86 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
87 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
88 pliki z/na serwer używając jednego z dostępnych protokołów.
89 %{?with_ssl:Ten pakiet obsługuje także SSL.}
90
91 %description -l pt_BR.UTF-8
92 Curl é um cliente para baixar/enviar arquivos de/para servidores
93 usando um dos protocolos suportados. É projetado para funcionar sem a
94 interação do usuário.
95
96 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
97 continuar transferências interrompidas, e mais...
98
99 %description -l ru.UTF-8
100 curl - это клиент с множеством поддерживаемых протоколов для получения
101 файлов с серверов, спроектированный для работы как в неинтерактивном
102 режиме, так и с возможностью диалога с пользователем.
103
104 curl поддерживает много полезных возможностей, среди которых поддержка
105 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
106 POST, восстановление прерванной пересылки и многое другое.
107
108 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
109 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
110 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
111
112 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
113 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
114 в╕дновлення перервано╖ пересилки та багато ╕ншого.
115
116 %package libs
117 Summary:        curl library
118 Summary(pl.UTF-8):      Biblioteka curl
119 Group:          Libraries
120 %{?with_ares:Requires:  c-ares >= 1.7.0}
121 %{?with_ssh:Requires:   libssh2 >= 1.0.0}
122 %if %{with ssl} && %{without gnutls}
123 BuildRequires:  openssl >= 1.0.1
124 %endif
125 Suggests:       ca-certificates
126 Conflicts:      ca-certificates < 20080809-4
127
128 %description libs
129 curl library.
130
131 %description libs -l pl.UTF-8
132 Biblioteka curl.
133
134 %package devel
135 Summary:        Header files and development documentation for curl library
136 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
137 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
138 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
139 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
140 Group:          Development/Libraries
141 Requires:       %{name}-libs = %{version}-%{release}
142 %{?with_ares:Requires:  c-ares-devel}
143 %{?with_kerberos5:Requires:     heimdal-devel}
144 Requires:       libidn-devel >= 0.4.1
145 %{?with_rtmp:Requires:  librtmp-devel}
146 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
147 %{?with_ldap:Requires:  openldap-devel}
148 %if %{with ssl}
149 %if %{with gnutls}
150 Requires:       gnutls-devel
151 %else
152 Requires:       openssl-devel >= 0.9.7c
153 %endif
154 %endif
155 Requires:       zlib-devel
156 Obsoletes:      libcurl2-devel
157
158 %description devel
159 Header files and development documentation for curl library.
160
161 %description devel -l pl.UTF-8
162 Pliki nagłówkowe i dokumentacja do biblioteki curl.
163
164 %description devel -l pt_BR.UTF-8
165 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
166
167 %description devel -l ru.UTF-8
168 Этот пакет содержит файлы, необходимые для разработки программ с
169 использованием библиотеки curl.
170
171 %description devel -l uk.UTF-8
172 Цей пакет містить файли, необхідні для розробки програм з
173 використанням бібліотеки curl.
174
175 %package static
176 Summary:        Static version of curl library
177 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
178 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
179 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
180 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
181 Group:          Development/Libraries
182 Requires:       %{name}-devel = %{version}-%{release}
183
184 %description static
185 Static version of curl library.
186
187 %description static -l pl.UTF-8
188 Statyczna wersja biblioteki curl.
189
190 %description static -l pt_BR.UTF-8
191 Bibliotecas estáticas para desenvolvimento com o curl.
192
193 %description static -l ru.UTF-8
194 Этот пакет содержит статическую библиотеку для разработки программ с
195 использованием библиотеки curl.
196
197 %description static -l uk.UTF-8
198 Цей пакет містить статичну бібліотеку для розробки програм з
199 використанням бібліотеки curl.
200
201 %prep
202 %setup -q
203 %patch0 -p1
204 %patch1 -p1
205
206 %{__rm} -v m4/lt*.m4 m4/libtool.m4
207
208 %build
209 %{__libtoolize}
210 %{__aclocal} -I m4
211 %{__autoconf}
212 %{__autoheader}
213 %{__automake}
214 %configure \
215         ac_cv_header_gss_h=no \
216 %if %{with ssl}
217         --with-ca-bundle=/etc/certs/ca-certificates.crt \
218 %if %{with gnutls}
219         --with-gnutls --without-ssl \
220 %else
221         --with-ssl=%{_prefix} \
222 %endif
223 %endif
224         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
225         %{?with_metalink:--with-libmetalink} \
226         %{?with_rtmp:--with-librtmp} \
227         %{?with_http2:--with-nghttp2} \
228         %{?with_ares:--enable-ares} \
229         --enable-ipv6 \
230         %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
231
232 %{__make}
233
234 %install
235 rm -rf $RPM_BUILD_ROOT
236 %{__make} install \
237         DESTDIR=$RPM_BUILD_ROOT
238
239 # no longer in upstream but a lot of apps tries to include it so we create fake one
240 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
241 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %post   libs -p /sbin/ldconfig
247 %postun libs -p /sbin/ldconfig
248
249 %files
250 %defattr(644,root,root,755)
251 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
252 %attr(755,root,root) %{_bindir}/curl
253 %{_mandir}/man1/curl.1*
254
255 %files libs
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
258 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
259
260 %files devel
261 %defattr(644,root,root,755)
262 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
263 %attr(755,root,root) %{_bindir}/curl-config
264 %attr(755,root,root) %{_libdir}/libcurl.so
265 %{_libdir}/libcurl.la
266 %{_includedir}/curl
267 %{_pkgconfigdir}/libcurl.pc
268 %{_mandir}/man1/curl-config.1*
269 %{_mandir}/man3/curl_*.3*
270 %{_mandir}/man3/libcurl*.3*
271
272 %files static
273 %defattr(644,root,root,755)
274 %{_libdir}/libcurl.a
This page took 0.085647 seconds and 4 git commands to generate.