]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- up to 7.24.0
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # without SSH support
4 %bcond_without  ssl             # without SSL support
5 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
6 %bcond_without  ldap            # without LDAP support
7 %if "%{pld_release}" != "ac"
8 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
9 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
10 %bcond_without  rtmp            # without Real Time Media Protocol
11 %else
12 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library
13 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
14 %bcond_with     rtmp            # without Real Time Media Protocol
15 %endif
16
17 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
18 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
22 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
23 Name:           curl
24 Version:        7.24.0
25 Release:        1
26 License:        MIT-like
27 Group:          Applications/Networking
28 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
29 # Source0-md5:  713d7d7cbc5cfaabd785a2ff905096f2
30 Patch0:         %{name}-no_strip.patch
31 Patch1:         %{name}-ac.patch
32 Patch2:         %{name}-pc.patch
33 Patch3:         %{name}-krb5flags.patch
34 Patch4:         lib%{name}.fb-changes.diff
35 Patch5:         gnutls3.patch
36 URL:            http://curl.haxx.se/
37 BuildRequires:  autoconf >= 2.57
38 BuildRequires:  automake
39 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
40 %{?with_kerberos5:BuildRequires:        heimdal-devel}
41 BuildRequires:  libidn-devel >= 0.4.1
42 %{?with_rtmp:BuildRequires:     librtmp-devel}
43 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
44 BuildRequires:  libtool
45 %{?with_ldap:BuildRequires:     openldap-devel}
46 BuildRequires:  pkgconfig
47 BuildRequires:  rpm >= 4.4.9-56
48 BuildRequires:  rpmbuild(macros) >= 1.453
49 %if %{with ssl}
50 %if %{with gnutls}
51 BuildRequires:  gnutls-devel
52 %else
53 BuildRequires:  openssl-devel >= 0.9.7d
54 %endif
55 %endif
56 BuildRequires:  tar >= 1:1.22
57 BuildRequires:  zlib-devel
58 Requires:       %{name}-libs = %{version}-%{release}
59 Requires:       libidn >= 0.4.1
60 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
61 Obsoletes:      libcurl2
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 cURL is a tool for getting files with URL syntax, supporting FTP,
66 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
67 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
68 cookies, user+password authentication and a busload of other useful
69 tricks. The main use for curl is when you want to get or send files
70 automatically to or from a site using one of the supported protocols.
71
72 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
73 Dict servers, using any of the supported protocols. cURL is designed
74 to work without user interaction or any kind of interactivity. cURL
75 offers many useful capabilities, like proxy support, user
76 authentication, FTP upload, HTTP post, and file transfer resume.
77
78 %description -l pl.UTF-8
79 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
80 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
81 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
82 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
83 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
84 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
85 pliki z/na serwer używając jednego z dostępnych protokołów.
86 %{?with_ssl:Ten pakiet obsługuje także SSL.}
87
88 %description -l pt_BR.UTF-8
89 Curl é um cliente para baixar/enviar arquivos de/para servidores
90 usando um dos protocolos suportados. É projetado para funcionar sem a
91 interação do usuário.
92
93 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
94 continuar transferências interrompidas, e mais...
95
96 %description -l ru.UTF-8
97 curl - это клиент с множеством поддерживаемых протоколов для получения
98 файлов с серверов, спроектированный для работы как в неинтерактивном
99 режиме, так и с возможностью диалога с пользователем.
100
101 curl поддерживает много полезных возможностей, среди которых поддержка
102 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
103 POST, восстановление прерванной пересылки и многое другое.
104
105 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
106 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
107 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
108
109 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
110 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
111 в╕дновлення перервано╖ пересилки та багато ╕ншого.
112
113 %package libs
114 Summary:        curl library
115 Summary(pl.UTF-8):      Biblioteka curl
116 Group:          Libraries
117 %{?with_ares:Requires:  c-ares >= 1.7.0}
118 Suggests:       ca-certificates
119 Conflicts:      ca-certificates < 20080809-4
120
121 %description libs
122 curl library.
123
124 %description libs -l pl.UTF-8
125 Biblioteka curl.
126
127 %package devel
128 Summary:        Header files and development documentation for curl library
129 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
130 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
131 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
132 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
133 Group:          Development/Libraries
134 Requires:       %{name}-libs = %{version}-%{release}
135 %{?with_ares:Requires:  c-ares-devel}
136 %{?with_kerberos5:Requires:     heimdal-devel}
137 Requires:       libidn-devel >= 0.4.1
138 %{?with_rtmp:Requires:  librtmp-devel}
139 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
140 %{?with_ldap:Requires:  openldap-devel}
141 %if %{with ssl}
142 %if %{with gnutls}
143 Requires:       gnutls-devel
144 %else
145 Requires:       openssl-devel >= 0.9.7c
146 %endif
147 %endif
148 Requires:       zlib-devel
149 Obsoletes:      libcurl2-devel
150
151 %description devel
152 Header files and development documentation for curl library.
153
154 %description devel -l pl.UTF-8
155 Pliki nagłówkowe i dokumentacja do biblioteki curl.
156
157 %description devel -l pt_BR.UTF-8
158 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
159
160 %description devel -l ru.UTF-8
161 Этот пакет содержит файлы, необходимые для разработки программ с
162 использованием библиотеки curl.
163
164 %description devel -l uk.UTF-8
165 Цей пакет містить файли, необхідні для розробки програм з
166 використанням бібліотеки curl.
167
168 %package static
169 Summary:        Static version of curl library
170 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
171 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
172 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
173 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
174 Group:          Development/Libraries
175 Requires:       %{name}-devel = %{version}-%{release}
176
177 %description static
178 Static version of curl library.
179
180 %description static -l pl.UTF-8
181 Statyczna wersja biblioteki curl.
182
183 %description static -l pt_BR.UTF-8
184 Bibliotecas estáticas para desenvolvimento com o curl.
185
186 %description static -l ru.UTF-8
187 Этот пакет содержит статическую библиотеку для разработки программ с
188 использованием библиотеки curl.
189
190 %description static -l uk.UTF-8
191 Цей пакет містить статичну бібліотеку для розробки програм з
192 використанням бібліотеки curl.
193
194 %prep
195 %setup -q
196 %patch0 -p1
197 %patch1 -p1
198 %patch2 -p1
199 %patch3 -p1
200 %patch4 -p1
201 %patch5 -p1
202
203 %{__rm} -v m4/lt*.m4 m4/libtool.m4
204
205 %build
206 %{__libtoolize}
207 %{__aclocal} -I m4
208 %{__autoconf}
209 %{__autoheader}
210 %{__automake}
211 %configure \
212         ac_cv_header_gss_h=no \
213 %if %{with ssl}
214         --with-ca-bundle=/etc/certs/ca-certificates.crt \
215 %if %{with gnutls}
216         --with-gnutls --without-ssl \
217 %else
218         --with-ssl=%{_prefix} \
219 %endif
220 %endif
221         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
222         %{?with_rtmp:--with-librtmp} \
223         %{?with_ares:--enable-ares} \
224         %{?with_ldap:--enable-ldaps} \
225         %{!?with_ldap:--disable-ldap} \
226         --enable-ipv6
227
228 %{__make}
229
230 %install
231 rm -rf $RPM_BUILD_ROOT
232
233 %{__make} install \
234         DESTDIR=$RPM_BUILD_ROOT
235
236 # no longer in upstream but a lot of apps tries to include it so we create fake one
237 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
238 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
239
240 %clean
241 rm -rf $RPM_BUILD_ROOT
242
243 %post   libs -p /sbin/ldconfig
244 %postun libs -p /sbin/ldconfig
245
246 %files
247 %defattr(644,root,root,755)
248 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
249 %attr(755,root,root) %{_bindir}/curl
250 %{_mandir}/man1/curl.1*
251
252 %files libs
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
255 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
256
257 %files devel
258 %defattr(644,root,root,755)
259 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
260 %attr(755,root,root) %{_bindir}/curl-config
261 %attr(755,root,root) %{_libdir}/libcurl.so
262 %{_libdir}/libcurl.la
263 %{_includedir}/curl
264 %{_pkgconfigdir}/libcurl.pc
265 %{_mandir}/man1/curl-config.1*
266 %{_mandir}/man3/curl_*.3*
267 %{_mandir}/man3/libcurl*.3*
268
269 %files static
270 %defattr(644,root,root,755)
271 %{_libdir}/libcurl.a
This page took 0.041895 seconds and 4 git commands to generate.