]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
up to 7.76.1
[packages/curl.git] / curl.spec
1 # TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
2 #
3 # Conditional build:
4 %bcond_without  ssh             # SSH support
5 %bcond_without  ssl             # SSL support
6 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
7 %bcond_without  gsasl           # SCRAM support with gsasl
8 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
9 %bcond_without  ldap            # LDAP support
10 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
11 %bcond_without  metalink        # metalink support
12 %if "%{pld_release}" != "ac"
13 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
14 %bcond_without  rtmp            # Real Time Media Protocol support
15 %else
16 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
17 %bcond_with     rtmp            # Real Time Media Protocol support
18 %endif
19
20 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
21 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
22 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
23 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
24 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
25 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
26 Name:           curl
27 Version:        7.76.1
28 Release:        1
29 License:        MIT-like
30 Group:          Applications/Networking
31 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.xz
32 # Source0-md5:  5296108646ca7f318b468a7a9d4a0eb2
33 Patch0:         %{name}-ac.patch
34 Patch1:         %{name}-krb5flags.patch
35 URL:            http://curl.haxx.se/
36 BuildRequires:  autoconf >= 2.57
37 BuildRequires:  automake
38 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
39 %{?with_gsasl:BuildRequires:    gsasl-devel}
40 %{?with_kerberos5:BuildRequires:        heimdal-devel}
41 BuildRequires:  libbrotli-devel >= 1.0.0
42 BuildRequires:  libidn2-devel
43 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
44 BuildRequires:  libpsl-devel
45 %{?with_rtmp:BuildRequires:     librtmp-devel}
46 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
47 BuildRequires:  libtool
48 BuildRequires:  nettle-devel
49 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.12.0}
50 %{?with_ldap:BuildRequires:     openldap-devel}
51 BuildRequires:  pkgconfig
52 BuildRequires:  rpm >= 4.4.9-56
53 BuildRequires:  rpmbuild(macros) >= 1.527
54 %if %{with ssl}
55 %if %{with gnutls}
56 BuildRequires:  gnutls-devel >= 3.1.10
57 %else
58 BuildRequires:  openssl-devel >= 1.0.1
59 %endif
60 %endif
61 BuildRequires:  tar >= 1:1.22
62 BuildRequires:  xz
63 BuildRequires:  zlib-devel
64 BuildRequires:  zstd-devel
65 Requires:       %{name}-libs = %{version}-%{release}
66 Obsoletes:      libcurl2
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 cURL is a tool for getting files with URL syntax, supporting FTP,
71 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
72 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
73 cookies, user+password authentication and a busload of other useful
74 tricks. The main use for curl is when you want to get or send files
75 automatically to or from a site using one of the supported protocols.
76
77 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
78 Dict servers, using any of the supported protocols. cURL is designed
79 to work without user interaction or any kind of interactivity. cURL
80 offers many useful capabilities, like proxy support, user
81 authentication, FTP upload, HTTP post, and file transfer resume.
82
83 %description -l pl.UTF-8
84 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
85 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
86 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
87 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
88 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
89 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
90 pliki z/na serwer używając jednego z dostępnych protokołów.
91 %{?with_ssl:Ten pakiet obsługuje także SSL.}
92
93 %description -l pt_BR.UTF-8
94 Curl é um cliente para baixar/enviar arquivos de/para servidores
95 usando um dos protocolos suportados. É projetado para funcionar sem a
96 interação do usuário.
97
98 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
99 continuar transferências interrompidas, e mais...
100
101 %description -l ru.UTF-8
102 curl - это клиент с множеством поддерживаемых протоколов для получения
103 файлов с серверов, спроектированный для работы как в неинтерактивном
104 режиме, так и с возможностью диалога с пользователем.
105
106 curl поддерживает много полезных возможностей, среди которых поддержка
107 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
108 POST, восстановление прерванной пересылки и многое другое.
109
110 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
111 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
112 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
113
114 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
115 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
116 в╕дновлення перервано╖ пересилки та багато ╕ншого.
117
118 %package libs
119 Summary:        curl library
120 Summary(pl.UTF-8):      Biblioteka curl
121 Group:          Libraries
122 %{?with_ares:Requires:  c-ares >= 1.7.0}
123 %{?with_gnutls:Requires:        gnutls-libs >= 3.1.10}
124 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
125 %{?with_http2:Requires: nghttp2-libs >= 1.12.0}
126 %if %{with ssl} && %{without gnutls}
127 Requires:       libbrotli >= 1.0.0
128 Requires:       openssl >= 1.0.1
129 %endif
130 Suggests:       ca-certificates
131 Conflicts:      ca-certificates < 20080809-4
132
133 %description libs
134 curl library.
135
136 %description libs -l pl.UTF-8
137 Biblioteka curl.
138
139 %package devel
140 Summary:        Header files and development documentation for curl library
141 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
142 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
143 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
144 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
145 Group:          Development/Libraries
146 Requires:       %{name}-libs = %{version}-%{release}
147 %{?with_ares:Requires:  c-ares-devel}
148 %{?with_gsasl:Requires: gsasl-devel}
149 %{?with_kerberos5:Requires:     heimdal-devel}
150 Requires:       libbrotli-devel >= 1.0.0
151 Requires:       libidn2-devel
152 Requires:       libpsl-devel
153 %{?with_rtmp:Requires:  librtmp-devel}
154 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
155 %{?with_http2:Requires: nghttp2-devel >= 1.12.0}
156 %{?with_ldap:Requires:  openldap-devel}
157 %if %{with ssl}
158 %if %{with gnutls}
159 Requires:       gnutls-devel >= 3.1.10
160 %else
161 Requires:       openssl-devel >= 0.9.7c
162 %endif
163 %endif
164 Requires:       zlib-devel
165 Requires:       zstd-devel
166 Obsoletes:      libcurl2-devel
167
168 %description devel
169 Header files and development documentation for curl library.
170
171 %description devel -l pl.UTF-8
172 Pliki nagłówkowe i dokumentacja do biblioteki curl.
173
174 %description devel -l pt_BR.UTF-8
175 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
176
177 %description devel -l ru.UTF-8
178 Этот пакет содержит файлы, необходимые для разработки программ с
179 использованием библиотеки curl.
180
181 %description devel -l uk.UTF-8
182 Цей пакет містить файли, необхідні для розробки програм з
183 використанням бібліотеки curl.
184
185 %package static
186 Summary:        Static version of curl library
187 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
188 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
189 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
190 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
191 Group:          Development/Libraries
192 Requires:       %{name}-devel = %{version}-%{release}
193
194 %description static
195 Static version of curl library.
196
197 %description static -l pl.UTF-8
198 Statyczna wersja biblioteki curl.
199
200 %description static -l pt_BR.UTF-8
201 Bibliotecas estáticas para desenvolvimento com o curl.
202
203 %description static -l ru.UTF-8
204 Этот пакет содержит статическую библиотеку для разработки программ с
205 использованием библиотеки curl.
206
207 %description static -l uk.UTF-8
208 Цей пакет містить статичну бібліотеку для розробки програм з
209 використанням бібліотеки curl.
210
211 %package -n fish-completion-%{name}
212 Summary:        Fish completion for curl command
213 Summary(pl.UTF-8):      Dopełnianie parametrów w fish dla polecenia curl
214 Group:          Applications/Shells
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       fish
217
218 %description -n fish-completion-%{name}
219 Fish completion for curl command.
220
221 %description -n fish-completion-%{name} -l pl.UTF-8
222 Dopełnianie parametrów w fish dla polecenia curl.
223
224 %package -n zsh-completion-curl
225 Summary:        ZSH completion for curl command
226 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
227 Group:          Applications/Shells
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       zsh
230
231 %description -n zsh-completion-curl
232 ZSH completion for curl command.
233
234 %description -n zsh-completion-curl -l pl.UTF-8
235 Dopełnianianie parametrów w ZSH dla polecenia curl.
236
237 %prep
238 %setup -q
239 %patch0 -p1
240 %patch1 -p1
241
242 %{__rm} m4/lt*.m4 m4/libtool.m4
243
244 %build
245 %{__libtoolize}
246 %{__aclocal} -I m4
247 %{__autoconf}
248 %{__autoheader}
249 %{__automake}
250 %configure \
251         ac_cv_header_gss_h=no \
252         %{__enable_disable ares} \
253         %{__enable_disable gsasl} \
254         --enable-ipv6 \
255         %{__enable_disable ldap} \
256         %{__enable_disable ldap ldaps} \
257         --disable-silent-rules \
258 %if %{with ssl}
259         --with-ca-bundle=/etc/certs/ca-certificates.crt \
260 %if %{with gnutls}
261         --with-gnutls --without-ssl \
262 %else
263         --with-ssl=%{_prefix} \
264 %endif
265 %else
266         --without-ssl --without-gnutls \
267 %endif
268         --with-fish-functions-dir=%{fish_compdir} \
269         %{__with_without kerberos5 gssapi %{_prefix}} \
270         %{__with_without metalink libmetalink} \
271         %{__with_without rtmp librtmp} \
272         %{__with_without http2 nghttp2} \
273         %{__with_without ssh libssh2}
274
275 %{__make}
276
277 %install
278 rm -rf $RPM_BUILD_ROOT
279
280 %{__make} install \
281         DESTDIR=$RPM_BUILD_ROOT
282
283 %{__make} -C scripts install \
284         DESTDIR=$RPM_BUILD_ROOT
285
286 # obsoleted by pkg-config
287 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcurl.la
288
289 # no longer in upstream but a lot of apps tries to include it so we create fake one
290 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
291 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
292
293 %clean
294 rm -rf $RPM_BUILD_ROOT
295
296 %post   libs -p /sbin/ldconfig
297 %postun libs -p /sbin/ldconfig
298
299 %files
300 %defattr(644,root,root,755)
301 %doc CHANGES COPYING README docs/{BUGS.md,FAQ,FEATURES.md,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting.md}
302 %attr(755,root,root) %{_bindir}/curl
303 %{_mandir}/man1/curl.1*
304
305 %files libs
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
308 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
309
310 %files devel
311 %defattr(644,root,root,755)
312 %doc docs/{CONTRIBUTE.md,INTERNALS.md}
313 %attr(755,root,root) %{_bindir}/curl-config
314 %attr(755,root,root) %{_libdir}/libcurl.so
315 %{_includedir}/curl
316 %{_pkgconfigdir}/libcurl.pc
317 %{_aclocaldir}/libcurl.m4
318 %{_mandir}/man1/curl-config.1*
319 %{_mandir}/man3/curl_*.3*
320 %{_mandir}/man3/libcurl*.3*
321 %{_mandir}/man3/CURLINFO_*.3*
322 %{_mandir}/man3/CURLOPT_*.3*
323 %{_mandir}/man3/CURLMOPT_*.3*
324
325 %files static
326 %defattr(644,root,root,755)
327 %{_libdir}/libcurl.a
328
329 %files -n fish-completion-%{name}
330 %defattr(644,root,root,755)
331 %{fish_compdir}/%{name}.fish
332
333 %files -n zsh-completion-curl
334 %defattr(644,root,root,755)
335 %{_datadir}/zsh/site-functions/_curl
This page took 0.090815 seconds and 4 git commands to generate.